Bug 188595 - system-config-httpd does not seem to be compatible with apache 2.2
system-config-httpd does not seem to be compatible with apache 2.2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
:
: 198591 200742 (view as bug list)
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-04-11 12:24 EDT by Mike Walker
Modified: 2015-03-04 20:16 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 11:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Walker 2006-04-11 12:24:45 EDT
Description of problem:

The system-config-httpd program doesn't seem to be compatible with the current
version of apache in FC5 - at least when I've tried it on my machine (if this is
not reproducable on other machines please ignore - I must have done something
stupid - but I can't think what). 

Basically the httpd.conf file the config program creates contains Module loading
lines for modules that aren't present in apache 2.2 (I guess they're apache
version 1 or even version 2.0 modules). Note also that there might be further
incompatiblities, which I haven't investigated.

If this is indeed the case, would it be possible to create a newer version of
system-config-httpd that works against apache 2.2?

Version-Release numbers (Both come from the standard fedora core 5 i386 CD
distribution): 

system-config-httpd:
- version: 1.3.3
- release: 1.1
- package downloaded: system-config-httpd-1.3.3-1.1.noarch.rpm

httpd:
- version: 2.2.0 
- release: 5.1.2
- package dowloaded: httpd-2.2.0-5.1.2.i386.rpm

How reproducible:

Only done on my home machine, but I'd guess it may be universal to all fc5
installations.

Steps to Reproduce:

1. Install the two programs into the system (via yum or even I guess during
initial system installation).

2. Check that apache httpd daemon runs ok with current (default) configuration.
(e.g. 'apachectl start', or 'apachectl restart' as root). Then once you've shown
it to be running ok (e.g check the url 'http:/localhost' in a web browser), stop
the http daemon - 'apachectl stop'.

3. First save the default /etc/httpd/conf/httpd.conf file to your home directory
ready to compare it later, then run system-config-httpd. Make no changes to the
setup, just make sure you save the settings and get them written to file before
exiting.

4. try to start the apache httpd daemon e.g 'apachectl start'. You should get an
error saying that a module couldn't be found (probably 'mod_access.mod')- this
is the first module listed in the newly generated httpd.conf file. Check the
current httpd.conf in /etc/httpd/conf and the one saved in your home directory -
notice that the modules litsed are different.

5. To clean up - just replace the current httpd.conf with the one in your home
directory (alternativly use the .bak file). and then you shoule be able to
restart httpd fine.
Comment 1 Brian G. Anderson 2006-04-13 19:06:30 EDT
I copied the modules list from the old config into the one generated by
system-config-httpd and that at least got the httpd service starting.  However
things are still not well:  I setup a virtual host by hand on a different port
(say 8585) that goes to a different directory so that http://localhost:8585 will
go to /var/www/html/gallery while http://localhost/ goes to /var/www/html; 
however when I do the same thing using config-http http://localhost:8585/
insists on going to /var/www/html.
Comment 2 Anthony van Leeuwen 2006-07-06 23:42:55 EDT
I found that system-config-httpd needs to be updated to reflect the module name
changes that have occurred in the version of Apache that ships with FC5. 
system-config-httpd writes the wrong module names in the httpd.conf file.  The
httpd.conf file that ships with Apache has it right, but it is overwritten by
system-config-httpd.
Comment 3 Paul Howarth 2006-07-30 12:32:00 EDT
Try the patch in Bug #180056, which is supposed to fix this. There really should
 have been an errata for this by now.
Comment 4 Johan Kok 2006-09-18 07:18:09 EDT
*** Bug 200742 has been marked as a duplicate of this bug. ***
Comment 5 Johan Kok 2006-09-18 07:21:18 EDT
*** Bug 198591 has been marked as a duplicate of this bug. ***
Comment 6 Sander Hoentjen 2006-09-18 08:03:02 EDT
changed to all platforms, severity high since it happens on all platforms and 
the bug is a blocker bug for having this piece of software in fedora. Also it 
is an easy fix and has been ignored for way too long.
Comment 7 Remon Pel 2006-10-18 15:56:44 EDT
Is this ever going to be fixed ???

Does it really have to take more than 6 months to get at least a decent answer ?

Forgive me for saying, but this does NOT encourage me to keep promoting Fedora
Comment 8 Phil Knirsch 2006-10-19 11:30:21 EDT
The patch in Bug #180056 only temporarily fixes the problem.

I'm currently working through all the open s-c-h bugs and will fix this one a
little different:

Instead of overwriting the main httpd.conf file i will create a
system-config-httpd.conf file in the config.d directory.

This will prevent several things:

- You can still manually edit and modify your main httpd.conf file. This has
always been something i really disliked about our original design of s-c-h, but
wasn't possible to do differently back then.

- By having only 1 file with all configuration data that s-c-h modifies you can
easily figure out what the problem is and much easier fix it, in the worst case
by simply removing the s-c-h.conf file.

- Manual changes in the s-c-h.conf file can and will still be noted and the user
accordingly notified.

The only real negative sideeffect i can see at the moment is that the s-c-h.conf
file might overwrite things that you've set in your main httpd.conf file, but
there's really no way that can be prevented.

Read ya, Phil
Comment 9 Phil Knirsch 2006-10-25 11:32:16 EDT
s-c-h-1.4.0-1 and later will now create a separate config file in
/etc/httpd/conf.d/system-config-httpd.conf instead of overwriting the original one.

This should solve most if not all of the problems mentioned in here.

Read ya, Phil

PS: I'll try to get at least an FC6 update version of it out as well, hopefully
tomorrow or so.
Comment 10 Remon Pel 2006-10-25 17:14:29 EDT
Not saying anything in response might unjustly be taken for not caring.
Replying with a comment not contributing anything to this thread might seem a
misuse of this 'forum'.

I'll take my chances;

Thank you!

Note You need to log in before you can comment on or make changes to this bug.