Bug 189278 - 1.5.0.2-1.1.fc5 update generates "install.rdf" error message on first run
1.5.0.2-1.1.fc5 update generates "install.rdf" error message on first run
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 189307 189343 (view as bug list)
Depends On:
Blocks: FC5Update
  Show dependency treegraph
 
Reported: 2006-04-18 15:00 EDT by Paul
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 04:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 324832 None None None Never

  None (edit)
Description Paul 2006-04-18 15:00:29 EDT
Description of problem:
The following message appears after downloading, installing and restarting
Firefox with the .2 update: 

"Firefox could not install this item because "install.rdf" (provided by the
item) is not well-formed or does not exist. Please contact the author about this
problem."

Version-Release number of selected component (if applicable):
15.0.2

How reproducible:
Almost all the time (?)

Steps to Reproduce:
1. Start Firefox
2.
3.
  
Actual results:
The error message appears.

Expected results:
No error message.

Additional info:

This is the stock DVD installed program with no outside updates.
Comment 1 Nicholas Miell 2006-04-18 21:30:54 EDT
*** Bug 189307 has been marked as a duplicate of this bug. ***
Comment 2 Nicholas Miell 2006-04-18 21:37:49 EDT
Possibly one or several of these? Of all of them, the only one I'm actually
seeing in my extension list is langpack-nb-NO.

[nicholas@entropy extensions]$ xmlwf */install.rdf
langpack-ko@firefox.mozilla.org/install.rdf:2:0: xml declaration not at start of
external entity
langpack-mk@firefox.mozilla.org/install.rdf:2:0: xml declaration not at start of
external entity
langpack-nb-NO@firefox.mozilla.org/install.rdf:10:34: not well-formed (invalid
token)
langpack-pa-IN@firefox.mozilla.org/install.rdf:2:0: junk after document element
Comment 3 Ignacio Vazquez-Abrams 2006-04-19 08:08:56 EDT
*** Bug 189343 has been marked as a duplicate of this bug. ***
Comment 4 Matthew Miller 2006-04-19 15:11:05 EDT
[changing summary to be more specific]
Comment 5 Paul 2006-04-19 16:13:51 EDT
Sorry to bother you again but the problem still exists with the new update.

I removed the package 1.5.0.2-1.1.fc5 and installed 1.5.0.2-1.2.fc5 and the same
message appears.
Comment 6 Nicholas Miell 2006-04-19 17:21:36 EDT
langpack-pa-IN@firefox.mozilla.org is still included.
Comment 7 Linda Worthington 2006-04-19 20:27:13 EDT
I'm having the same problem. Installed the Firefox update yesterday and the new
update today, 1.5.0.2-1.2.fc5 and both times on first run I received the error
message:

"Firefox could not install this item because "install.rdf" (provided by the
item) is not well-formed or does not exist. Please contact the author about this
problem."
Comment 8 Gilboa Davara 2006-04-20 00:33:43 EDT
Be aware that as far as I can see, all the language packs still belong to
1.5.0.1 and were not upgraded to 0.2.

Oh... and https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189444 might be a
duplicate.
Comment 9 Johan Kröckel 2006-04-20 09:52:30 EDT
I can reproduce the bug by removing ~/.mozilla 
Comment 10 Zenon Panoussis 2006-04-21 01:10:57 EDT
# /etc/cron.daily/slocate.cron
# rm -rf `locate langpack-pa-IN`
# rm -rf `locate langpack-nb-NO`
# rm -rf `locate langpack-ko`
# rm -rf `locate langpack-mk`

The error disappeared after the last command. Whether that means that -mk was
the offending item or that all of them were, is an open question. 
Comment 11 Thomas Chung 2006-05-02 18:03:59 EDT
I can reproduce this error message on my test system as well.
Here is a screenshot captured.
http://fedoraproject.org/wiki/ThomasChung/FC5?action=AttachFile&do=get&target=Screenshot-Malformed_File.png
Comment 12 Bob Gustafson 2006-05-05 10:00:42 EDT
When I was trying to view the HELP on
 System->Administration->Server Settings->Services

I would get the rdf error dialog.

I then did the /etc/cron..  (but I only had mlocate, not slocate)
rm ..
rm ..

as indicated below.

Now, I get a new error dialog message:

Close Firefox
Firefox is already running, but is not responding. To open a new window, you
must first close the existing Firefox process, or restart your system.

???
Since I can open a new Firefox window without any problem and in fact am writing
this message in a Firefox window, I wonder whether this is a bogus message.

(Besides, I am in the middle of another project and have 18 Firefox windows open
and don't want to close them all just yet..)
Comment 13 Bob Gustafson 2006-05-05 10:06:18 EDT
Ahah, I noticed that there was still the 'Malformed... install.rdf' error dialog
still open from a previous try at 
  System->Administration->Server Settings->Services

When I closed this window, the HELP window:
  Services Configuration Tool - Mozilla Firefox
opened up.

So the above 'Close Firefox' error message was complaining about just the one
error dialog window, not all of Firefox..  
Comment 14 Andrew Martynov 2006-05-06 12:47:00 EDT
I run 
# export LANG=ru_RU.UTF-8
# strace -f firefox 
and "Mailformed ..." dialog shows during opening file
/usr/lib/firefox-1.5.0.2/extensions/langpack-pa@firefox.mozilla.org/install.rdf

This XML is really mailformed.
Removing this file solve the problem for ru_RU.UTF-8 locale.
Comment 15 Bob Gustafson 2006-05-06 22:41:38 EDT
When I originally installed FC5, the processor load was running about 35-65%
most of the time (dual xeon..) without doing much at all. Firefox was open with
a number of windows.

After the "rm -rf `locate langpack-pa-IN` ..etc" was run, the processor load
dropped off to normal (a few percent..). I don't know what was sucking up the
power, but am glad that it went away.
Comment 16 Christopher Aillon 2006-09-27 04:48:27 EDT
This was fixed in one of the updates.

Note You need to log in before you can comment on or make changes to this bug.