Bug 190003 - sshd segfaults - all connection attempts fail
sshd segfaults - all connection attempts fail
Status: CLOSED DUPLICATE of bug 190002
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-26 11:52 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-27 03:47:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2006-04-26 11:52:53 EDT
Description of problem:
sshd segfaults - all connection attempts fail

Apr 26 11:44:38 ontap kernel: sshd[12592]: segfault at 0000000000000038 rip
00002aaaabf38803 rsp 00007fff96cbc760 error 4


Version-Release number of selected component (if applicable):
glibc-2.4.90-1

How reproducible:
100%

Steps to Reproduce:
1.ssh -v localhost
2.
3.
  
Actual results:
OpenSSH_4.3p2, OpenSSL 0.9.8a 11 Oct 2005
debug1: Reading configuration data /home/ellson/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: Connection established.
debug1: identity file /home/ellson/.ssh/identity type -1
debug1: identity file /home/ellson/.ssh/id_rsa type -1
debug1: identity file /home/ellson/.ssh/id_dsa type 2
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
debug1: match: OpenSSH_4.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'localhost' is known and matches the RSA host key.
debug1: Found key in /home/ellson/.ssh/known_hosts:21
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/ellson/.ssh/identity
debug1: Trying private key: /home/ellson/.ssh/id_rsa
debug1: Offering public key: /home/ellson/.ssh/id_dsa
debug1: Server accepts key: pkalg ssh-dss blen 433
debug1: read PEM private key done: type DSA
debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LC_COLLATE = C
debug1: Sending env LANG = en_US.UTF-8
debug1: channel 0: free: client-session, nchannels 1
debug1: fd 2 clearing O_NONBLOCK
Connection to localhost closed by remote host.
Connection to localhost closed.
debug1: Transferred: stdin 0, stdout 0, stderr 81 bytes in 0.0 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 21182.0
debug1: Exit status -1


And /var/log/messages contains:

Apr 26 11:44:38 ontap kernel: sshd[12592]: segfault at 0000000000000038 rip
00002aaaabf38803 rsp 00007fff96cbc760 error 4


Expected results:


Additional info:

Downgrading to glibc-2.4-5 fixes the problem.

Problem is reproducible on i686 and x86_64 machines.
Comment 1 Jeff Needle 2006-04-26 12:02:09 EDT
See also Bug #189997
Comment 2 John Ellson 2006-04-26 18:18:38 EDT
I can confirm that Comment #1 from Bug #189997 works for me too.
    "Setting "UseDNS no" in sshd_config works around the problem temporarily"
Comment 3 Jakub Jelinek 2006-04-27 03:47:45 EDT

*** This bug has been marked as a duplicate of 190002 ***

Note You need to log in before you can comment on or make changes to this bug.