Bug 19071 - upgrade aborts while reading package information
Summary: upgrade aborts while reading package information
Status: CLOSED DUPLICATE of bug 18019
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-13 18:39 UTC by John Killian O'Brien
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 22:12:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file generated after upgrade aborted (1.04 KB, text/plain)
2000-10-13 18:41 UTC, John Killian O'Brien
no flags Details

Description John Killian O'Brien 2000-10-13 18:39:55 UTC
installation files downloaded to /dev/hda1
After "ugrade" is selected the "reading
package information" window appears.

Then the program reports that there is a
bug and requests that this be reported.

The following text is then saved to a
floppy disk...

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 941, in
upgradeFindPackages
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43,
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in
__getitem__
KeyError: LPRng

Local variables in innermost frame:
self: <comps.HeaderList instance at 8222ae8>
item: LPRng

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>

Comment 1 John Killian O'Brien 2000-10-13 18:41:45 UTC
Created attachment 4146 [details]
file generated after upgrade aborted

Comment 2 Michael Fulbright 2000-10-18 22:12:09 UTC

*** This bug has been marked as a duplicate of 18019 ***

Comment 3 Matt Wilson 2000-10-19 08:04:49 UTC
*** Bug 17721 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.