Bug 191159 - smbclient fails to login in tar creating mode
smbclient fails to login in tar creating mode
Status: CLOSED DUPLICATE of bug 176649
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On: 176649
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-09 06:53 EDT by Tomasz Ostrowski
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-23 19:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 3974 None None None Never

  None (edit)
Description Tomasz Ostrowski 2006-05-09 06:53:23 EDT
+++ This bug was initially created as a clone of Bug #176649 +++
+++ Cloned because FC5 is affected +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922
Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When using smbclient in tar creating mode, like this:
    smbclient //server/share -A server.auth -Tc /tmp/server-share.tar
there is an login failure although a command
    smbclient //server/share -A server.auth
logs in just fine.



Version-Release number of selected component (if applicable):
samba-3.0.20b-2.1

How reproducible:
Always

Steps to Reproduce:
1. smbclient //server/share -A server.auth -Tc /tmp/server-share.tar


Actual Results:  session setup failed: NT_STATUS_LOGON_FAILURE

Expected Results:  Domain=[DOMAIN] OS=[Windows NT 4.0] Server=[NT LAN Manager 4.0]
tar: dumped 5 files and directories
Total bytes written: 22577664


Additional info:

My configuration is an NT domain with Windows NT 4 server with latest service pack.

Smbclient from vanilla version of samba-3.0.20b works just fine (compiled with
./configure --prefix=/tmp/samba-3.0.20b.root && make CFLAGS=-O0 && make
install). Smbclient from Fedora Core 4 also works fine but I cannot use it
because of bug #167561.

-- Additional comment from tometzky@batory.org.pl on 2005-12-28 11:49 EST --
When I recompiled samba rpm without samba-3.0.15pre2-bug106483.patch it worked.
Comment 1 Kelly-Rand 2006-07-16 09:35:01 EDT
I have the exact same problem since upgrading to Fc5_x86_64 from Fc4_x86. This
problem did not exist for me until the upgrade. Below is example of failure:

# /root/Scripts/smbTmshost 
/usr/bin/smbclient  \\mshost\E$ -A /etc/samba/ADMINISTRATOR -Tc
session setup failed: NT_STATUS_LOGON_FAILURE

Yet I can execute the following script under  Fc5-x86_64 that is succesful:

]# /root/Scripts/smbmshost 
/usr/bin/smbclient  \\mshost\E$ -A /etc/samba/ADMINISTRATOR
Domain=[MSHOST] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]
smb: \> 

The event log in MSW-2000 records the following message for the unsuccesful login:

The logon to account: Administrator
 by: MICROSOFT_AUTHENTICATION_PACKAGE_V1_0
 from workstation: SAMBASERVER
 failed. The error code was: 3221225578

My research has found that the error code indicates the user name is correct but
the password is wrong.
##############################end of output#############################
I did an ethereal trace of samba activity that I could furnish if it is desired.
It did not reveal information that I could use since I do not have and IT
background.
Comment 2 Tomasz Ostrowski 2006-07-28 09:35:28 EDT
The cause of this is that tar creating option arguments of smbclient are
confused with password provided in command line. This is an upstream bug. I've
filed it in upstream bug tracker and I'm adding a reference to
https://bugzilla.samba.org/show_bug.cgi?id=3974
Comment 3 Tomasz Ostrowski 2006-09-27 03:39:38 EDT
Updating status as requested in
https://www.redhat.com/archives/fedora-package-announce/2006-September/msg00056.html

samba-3.0.23c-1.fc5 is still affected
Comment 4 Simo Sorce 2007-03-23 19:10:23 EDT
Please just add a comment in the original bug about which distro are affected in
the future.

*** This bug has been marked as a duplicate of 176649 ***

Note You need to log in before you can comment on or make changes to this bug.