Bug 176218 - xscreensaver gl-extras subpackages needs BuildRequires: libGLU-devel
xscreensaver gl-extras subpackages needs BuildRequires: libGLU-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 178410 (view as bug list)
Depends On: 191769
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 05:15 EST by Mamoru TASAKA
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-16 11:09:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to change installation directory (1.75 KB, patch)
2005-12-21 02:15 EST, Mamoru TASAKA
no flags Details | Diff
spec file diff (1.56 KB, patch)
2005-12-21 02:24 EST, Mamoru TASAKA
no flags Details | Diff
New rpm spec diff (1.33 KB, patch)
2005-12-21 08:37 EST, Mamoru TASAKA
no flags Details | Diff
Log file to search for xscreensaver dependency (1.12 KB, text/plain)
2006-01-13 02:10 EST, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2005-12-20 05:15:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
The latest rawhide rpm of xscreensaver-gl-extras contains NO FILES.

When I rebuilt all xscreensaver rpms from source rpm, xscreensaver-gl-extras
rpm rebuilt contains appropriate rpms.
So there must have been some compilation error about the latest 
xscreensaver.



Version-Release number of selected component (if applicable):
xscreensaver-4.22-21.2

How reproducible:
Always

Steps to Reproduce:
1. rpm -ql xscreensaver-gl-extras-4.22-21.2
2.
3.
  

Actual Results:  Simply, "(contains no files)"

Expected Results:  xscreensaver-gl-extras should contain appropriate files...

Additional info:
Comment 1 Joachim Frieben 2005-12-20 15:11:27 EST
Right. Moreover, the binary RPM currently cannot be built from
the sources. It seems that "xscreensaver-4.22-21.2" had been
built on a different OS version.

#################################################################

Warning: The "pkg-config" program produces errors. This often
         causes detection of the various GTK libraries to malfunction.
         The errors are:

         > Package xdmcp was not found in the pkg-config search path.
         > Perhaps you should add the directory containing `xdmcp.pc'
         > to the PKG_CONFIG_PATH environment variable
         > Package 'xdmcp', required by 'X11', not found

Warning: The GTK libraries do not seem to be available; the
             `xscreensaver-demo' program requires them.

#################################################################

Compilation aborts with the message:

"../../driver/xscreensaver-getimage.c:58:42: error:
   gdk-pixbuf/gdk-pixbuf-xlib.h: No such file or directory"

Moreover, the "configure" script still gets the "app-defaults"
path wrong:

"checking for X app-defaults directory...
   /usr/X11R6/lib/X11/app-defaults"
Comment 2 Mamoru TASAKA 2005-12-21 01:52:17 EST
First.  about pkg-config problem

Umm.. On my system the other packages needed for rebuilding xscreensaver
is installed. When I remove libXau-devel and libXdmcp-devel from my system,
rebuilding xscreensaver from source rpm fails as Joachim.

The warning Joachim reported was created by "pkg-config --list-all". Also,
rebuilding xscreensave fails the dependency for gtk+-2.0 (around at the
line 14626 of configure --- from config.log).   

Perhaps this is related to the issue discussed on fedora-devel mailing list
https://www.redhat.com/archives/fedora-devel-list/2005-December/msg00781.html ,
but I am not familiar with pkg-config or so.
Comment 3 Mamoru TASAKA 2005-12-21 02:15:58 EST
Created attachment 122482 [details]
Patch to change installation directory

Second. about app-defaults issue

This issue is already reported in the bug 173602, but I suggest one
solution for this here incidentially.

When I manually created /usr/X11R6/lib/X11/app-defaults directory,
configure pointed to the directory for installation of XScreenSaver.ad,
surely.  To solve this dealing with configure(.in) script is needed.

One solution is to add the option for installation directory to
configure.in. The attached patch is to add 
"--with-x-app-defaults=<dir>" to configure.in (autoconf required).
Comment 4 Mamoru TASAKA 2005-12-21 02:24:48 EST
Created attachment 122483 [details]
spec file diff

To apply the patch above (id=122482), rpm spec must be changed
as I attached.

As I mentioned in the bug 173602, installing XScreenSaver.ad in
/usr/lib/X11/app-defaults doesn't seem to work. Most app-defaults related
files are now in /usr/share/X11/app-defaults, and moving XScreenSaver.ad
to the latter directory also works for me.
Comment 5 Jamie Zawinski 2005-12-21 05:02:43 EST
> The warning Joachim reported was created by "pkg-config --list-all".

Yes, the reason that test is in there is that, in my experience, if "--list-all" generates *any* errors, even in 
unrelated packages, there's a good chance that random shit is going to fail.  I think it might be something 
along the lines of: tests for any package that is alphabetically-later than the one with the error fail. But I 
haven't tried to diagnose it very closely.

If it's possible to install some RPMs such that --list-all generates any errors, then there's a missing 
dependency in that RPM, and a bug ought to be reported against that package.
Comment 6 Mamoru TASAKA 2005-12-21 08:37:28 EST
Created attachment 122489 [details]
New rpm spec diff

> If it's possible to install some RPMs such that --list-all generates
> any errors, then there's a missing 
> dependency in that RPM, and a bug ought to be reported against that package.

As of the issue of pkg-config warning, I think that libX11-devel should own
the requirement dependency for libXau-devel (xau.pc) and libXdmcp-devel
(xdmcp.pc) (and the dependency should not be included into xscreensaver rpm)
as Jamie commented. Currently Jens Petersen opened the bug 176079
for this issue: until this issue is solved, xscreensaver cannot be rebuilt..?

By the way, for the current rawhide why only gl-extras rpm are missing any
files,
where the other 2 rpms include appropriate files?
Comment 7 Joachim Frieben 2006-01-05 12:20:13 EST
I have managed to build "xscreensaver-gl-extras-4.22-21.2" correctly
on a fresh "rawhide" system after installing "mesa-libGLU-devel". This
library is missing by default, and accordingly, the "OpenGL" screen
savers are not built in this case. The corresponding package is of
course empty then. Btw, the "configure" script even complains about
missing "GL" libraries.
Please rebuild the "xscreensaver" package after having made sure that
"mesa-libGLU-devel" is actually installed. Everything will then work
out as it should.
Comment 8 Mamoru TASAKA 2006-01-13 02:10:45 EST
Created attachment 123150 [details]
Log file to search for xscreensaver dependency

Umm.. When I suceeded to rebuild xscreensaver 3 rpms correctly, I tried
to search for xscreensaver dependency by the following command:

A. rpm -qp --requires xscreensaver*.i386.rpm | grep -v rpmlib | \
 LANG=C xargs rpm -q --whatprovides | grep -v package | sort | uniq
B. LANG=C rpmbuild --rebuild xscreensaver-4.22-21.2.src.rpm 2>&1 | \
 sed -e 's| |\n|g' | grep -- ^-l | grep -v \\.$ | sort | uniq

I attached these results; which should be some help for this problem.
Comment 9 Jeremy Fitzhardinge 2006-01-23 01:41:59 EST
*** Bug 178410 has been marked as a duplicate of this bug. ***
Comment 10 Joachim Frieben 2006-01-25 05:06:14 EST
Ok, "xscreensaver-4.23-1" seems to be complete again. However, it would
be certainly a good idea to explicitly add "mesa-libGLU-devel" to the
build requirements of "xscreensaver-gl-extras". Right now, this is not
the case.
Comment 11 Mamoru TASAKA 2006-09-16 11:09:35 EDT
Fixed in 4.24-3.fc5.

Note You need to log in before you can comment on or make changes to this bug.