Bug 192175 - modifier keys not delivered to IME in OOo
modifier keys not delivered to IME in OOo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: Reopened
: 198723 (view as bug list)
Depends On:
Blocks: FC6Target SCIM
  Show dependency treegraph
 
Reported: 2006-05-18 00:20 EDT by Akira TAGOH
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: scim-bridge-0.4.1-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 06:35:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2006-05-18 00:20:55 EDT
Description of problem:
scim allows to change IM with ctrl+shift and shift+ctrl by default. however it
do nothing on OOo.

Version-Release number of selected component (if applicable):
2.0.3-0.169.3

How reproducible:
always

Steps to Reproduce:
1.run OOo and make sure scim is running and working.
2.press ctrl+shift or shift+ctrl
3.
  
Actual results:
nothing happens.

Expected results:
should change IM.

Additional info:
Comment 1 Caolan McNamara 2006-05-19 13:55:04 EDT
This works for me with 2.0.3-1.1. Can you check there, and if it doesn't work
reopen and tell me the locale that OOo was run in, that may be relevent.
Comment 2 Akira TAGOH 2006-05-23 03:31:22 EDT
sorry for late testing, I've tested 2.0.3-2.1. but any modifier keys are not
passed through OOo. then ctrl+shift, shift+ctrl even tapping alt doesn't work.
guess keyevents for only modifier keys is discarded?
Comment 3 Caolan McNamara 2006-05-23 04:11:02 EDT
ctrl+shift and ctrl+space work for me on rawhide, so I don't understand what is
different for you that causes this. locale ?
Comment 4 Akira TAGOH 2006-05-23 04:42:40 EDT
You're right. it looks like a scim-bridge bug. when I run OOo with
GTK_IM_MODULE=scim, it works fine. but not with GTK_IM_MODULE=scim-bridge. I'll
assign this to scim-bridge then.
Comment 5 Ryo Dairiki 2006-06-14 03:44:47 EDT
This is because ooffice won't give IMContext key release events.
Scim-gtkim uses key snooper to grab these events, but it often causes problem in
firefox.
(That's why I didn't use it)

At last, I've added "use key snooper on demand" feature in scim-bridge-0.2.0-rc3
in the cvs repository.
You can enable this feature by setting the environmental variable as "export
SCIM_BRIDGE_KEY_SNOOPER_ENABLED=true".
That is, you can use such keystrokes in ooffice when you launch it with that
environmental variable.

Notice, I won't recommand you to use this feature in every application.
Use this only in ooffice by creating a shell script.
Comment 6 Jens Petersen 2006-06-14 04:55:47 EDT
Dairiki-san, thank you for this option.
Comment 7 Jens Petersen 2006-06-14 08:05:27 EDT
I built scim-bridge-0.2.0-0.1.20060614 for FC devel.
Comment 8 Jens Petersen 2006-07-03 23:22:25 EDT
Now that openoffice.org is working with IM input again, I confirm that
this is now fixed in current scim-bridge (tested with 0.2.3-1).
Comment 9 Jens Petersen 2006-07-05 09:25:59 EDT
Retesting, actually it only works with SCIM_BRIDGE_KEY_SNOOPER_ENABLED=true.
Comment 10 Jens Petersen 2006-07-05 09:29:54 EDT
Perhaps it should be added to the openoffice.org wrapper scripts.
Comment 11 Jens Petersen 2006-07-13 04:27:13 EDT
*** Bug 198723 has been marked as a duplicate of this bug. ***
Comment 12 Satyabrata Maitra 2006-08-31 06:35:13 EDT
This bug has been fixed now.

Component version tested : (Rawhide)
scim-1.4.4-32.fc6
scim-bridge-0.4.1-1.fc6

Arch : i386.

Closing the bug for now, if rproducable to anyone, pls reopen this bug again.  
                        

Note You need to log in before you can comment on or make changes to this bug.