Bug 192367 - arts fails to build in mock
arts fails to build in mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: arts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
: 192521 192522 192523 192526 192527 192529 (view as bug list)
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-05-18 22:33 EDT by Michael J Knox
Modified: 2013-01-09 22:45 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.5.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 14:48:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Matt Domsch's buildlog (331.42 KB, text/plain)
2006-05-18 22:33 EDT, Michael J Knox
no flags Details
New build.log (270.23 KB, text/plain)
2006-05-19 19:16 EDT, Michael J Knox
no flags Details

  None (edit)
Description Michael J Knox 2006-05-18 22:33:58 EDT
This package fails to build in mock.  build.log is attached.
Comment 1 Michael J Knox 2006-05-18 22:33:58 EDT
Created attachment 129569 [details]
Matt Domsch's buildlog
Comment 2 Ngo Than 2006-05-19 04:03:27 EDT
could you please try to build it without %{?_smp_mflags}? thanks
Comment 3 Michael J Knox 2006-05-19 19:15:56 EDT
OK, removed the %{?_smp_mflags} but it still fails. There is a ton of warnings
like "has virtual functions but non-virtual destructor" but I could not see
whats missing, just at the end, linking fails. 

Attaching new build.log
Comment 4 Michael J Knox 2006-05-19 19:16:35 EDT
Created attachment 129655 [details]
New build.log
Comment 5 Ngo Than 2006-05-22 12:25:25 EDT
Jakub,

it seems a bug in binutils-2.17.50.0.1-1 from rawhide. I have downgraded to
binutils-2.16.91.0.6-4.i386.rpm and can rebuild arts without any problem!
Comment 6 Ngo Than 2006-05-22 12:39:32 EDT
*** Bug 192529 has been marked as a duplicate of this bug. ***
Comment 7 Ngo Than 2006-05-22 12:40:21 EDT
*** Bug 192527 has been marked as a duplicate of this bug. ***
Comment 8 Ngo Than 2006-05-22 12:40:47 EDT
*** Bug 192526 has been marked as a duplicate of this bug. ***
Comment 9 Ngo Than 2006-05-22 12:47:23 EDT
*** Bug 192523 has been marked as a duplicate of this bug. ***
Comment 10 Ngo Than 2006-05-22 12:47:57 EDT
*** Bug 192522 has been marked as a duplicate of this bug. ***
Comment 11 Ngo Than 2006-05-22 12:48:35 EDT
*** Bug 192521 has been marked as a duplicate of this bug. ***
Comment 12 Matt Domsch 2006-06-08 14:48:57 EDT
arts-1.5.3-1.src.rpm builds on i386 and x86_64.

Note You need to log in before you can comment on or make changes to this bug.