Bug 19241 - Graphical installer doesn't work with Trident CyberBlade/i7 video
Graphical installer doesn't work with Trident CyberBlade/i7 video
Status: CLOSED DUPLICATE of bug 18773
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 05:46 EDT by Mikkel Lauritsen
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-17 17:39:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikkel Lauritsen 2000-10-17 05:46:30 EDT
When installing 7.0 on a PC which has a FIC PAG-2130 motherboard with VIA
MVP4 and thus built-in Trident CyberBlade and a ViewSonic GT775 monitor the
graphical installer starts up in a video mode that the monitor can't grok
at all.

After installing in text mode X seems to semi-work - 640x480 is okay but
all other resolutions don't work like with the installer.

In the installer the messages from the X server contain

(--) SVGA: PCI: Trident CyberBlade/i7 rev 91, Memory @ 0xe5800000, 0xe6000000
(--) Trident chipset version: 0xf3 (CyberBlade/i7)
(--) SVGA: Detected an STN  1280x1024 Display
(--) SVGA: Revision 91.
(--) SVGA: Using Trident programmable clocks
(--) SVGA: chipset:  cyberblade
(**) SVGA: videoram: 8192k
(**) SVGA: Using 8 bpp, Depth 8, Color weight: 666
(--) SVGA: Maximum allowed dot-clock: 230.000 MHz
(--) SVGA: Chipset supports a max. heightof 1024, Adjust Modes in XF86Config.
(**) SVGA: Mode "640x480": mode clock = 45.800
(--) SVGA: Virtual resolution set to 640x480
(--) SVGA: SpeedUp code selection modified because virtualX != 1024
(--) SVGA: Using Linear Frame Buffer at 0x05e800000, Size 8MB

The working 640x480 mode says the same except for

(**) SVGA: Mode "640x480": mode clock =  36.000


Without being an expert on the X server I'd say that the bit about having
detected an STN display sounds a bit fishy. Bug # 19097 seems a lot like
this one, only not on the exact same video card.
Comment 1 Mikkel Lauritsen 2000-10-18 05:11:16 EDT
Just tried the 4.0 X server which seems to be semi-working in other exciting
ways. Some other resolutions almost work, but the mouse pointer is missing, and
swithcing between them caused the PC to lock up hard - power off required.

Among a lot of other stuff the 4.0 X server goes

(--) TRIDENT(0): Revision is 91
(--) TRIDENT(0): Found CyberBlade/i7 chip
(--) TRIDENT(0): RAM type is SDRAM
(--) TRIDENT(0): Found 8MB board, using 4MB
(--) TRIDENT(0): VideoRAM: 4096 kByte
(--) TRIDENT(0): TFT Panel 1280x1024 found

so it seems like the display misdetection is common for the two.

Comment 2 Mike A. Harris 2001-03-13 22:39:03 EST
Please try my latest XFree86 packages and see if they solve the problem:

ftp://people.redhat.com/mharris/xfree86

Make sure you also get Mesa-3.4-11 or else you may have problems.

Does this fix it for you?
Comment 3 Mike A. Harris 2001-04-02 13:20:38 EDT

*** This bug has been marked as a duplicate of 18773 ***

Note You need to log in before you can comment on or make changes to this bug.