Bug 192595 - f-spot-0.1.11-1 faults (seg fault) on startup
f-spot-0.1.11-1 faults (seg fault) on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: f-spot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 192786 192879 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-21 12:23 EDT by Tom London
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 16:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to build against gtk# 2.9 (1.92 KB, patch)
2006-06-06 14:12 EDT, Bart Vanbrabant
no flags Details | Diff

  None (edit)
Description Tom London 2006-05-21 12:23:41 EDT
Description of problem:
f-spot dies immediately upon startup:

Starting new FSpot server
System.NullReferenceException: Object reference not set to an instance of an object
in <0x00019> Gtk.Widget:set_GdkWindow (Gdk.Window value)
in <0x00038> FSpot.GroupSelector:OnRealized ()
in <0x00036> Gtk.Widget:realized_cb (IntPtr widget)
in (wrapper native-to-managed) Gtk.Widget:realized_cb (intptr)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Box:gtk_box_pack_start
(intptr,intptr,bool,bool,uint)
in <0x0004b> Gtk.Box:PackStart (Gtk.Widget child, Boolean expand, Boolean fill,
UInt32 padding)
in <0x00966> MainWindow:.ctor (.Db db)
in <0x0002a> FSpot.Core:get_MainWindow ()
in <0x0000c> FSpot.Core:Organize ()
in <0x00530> FSpot.Driver:Main (System.String[] args)

(f-spot:13101): Gdk-CRITICAL **: gdk_window_get_user_data: assertion `window !=
NULL' failed

(f-spot:13101): Gtk-CRITICAL **: gtk_style_attach: assertion `window != NULL' failed

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Stacktrace:

in (wrapper managed-to-native) Gtk.Dialog:gtk_dialog_run (intptr) <0x4>
in (wrapper managed-to-native) Gtk.Dialog:gtk_dialog_run (intptr) <0xffffffdd>
in Gtk.Dialog:Run () <0x1d>
in FSpot.Driver:Main (string[]) <0x5a2>
in (wrapper runtime-invoke) System.Object:runtime_invoke_void_string[]
(object,intptr,intptr,intptr) <0x7d87079>

Native stacktrace:

        f-spot(mono_handle_native_sigsegv+0xbb) [0x8155ceb]
        f-spot [0x8124980]
        [0x49d6e440]
        /usr/lib/libgtk-x11-2.0.so.0 [0x4150c8d1]
        /usr/lib/libgtk-x11-2.0.so.0 [0x4150d17e]
        /usr/lib/libgtk-x11-2.0.so.0 [0x41511453]
        /usr/lib/libgtk-x11-2.0.so.0 [0x415116e7]
        /usr/lib/libgtk-x11-2.0.so.0 [0x412f8e80]
        /usr/lib/libgtk-x11-2.0.so.0(gtk_container_forall+0x6b) [0x4133c68b]
        /usr/lib/libgtk-x11-2.0.so.0 [0x415116cf]
        /usr/lib/libgtk-x11-2.0.so.0 [0x4140c97d]
        /usr/lib/libgtk-x11-2.0.so.0(gtk_container_forall+0x6b) [0x4133c68b]
        /usr/lib/libgtk-x11-2.0.so.0 [0x415116cf]
        /usr/lib/libgtk-x11-2.0.so.0 [0x412f8e80]
        /usr/lib/libgtk-x11-2.0.so.0(gtk_container_forall+0x6b) [0x4133c68b]
        /usr/lib/libgtk-x11-2.0.so.0 [0x415116cf]
        /usr/lib/libgtk-x11-2.0.so.0 [0x412f8e80]
        /usr/lib/libgtk-x11-2.0.so.0(gtk_container_forall+0x6b) [0x4133c68b]
        /usr/lib/libgtk-x11-2.0.so.0 [0x415116cf]
        /usr/lib/libgtk-x11-2.0.so.0 [0x412f5055]
        /usr/lib/libgtk-x11-2.0.so.0(gtk_container_forall+0x6b) [0x4133c68b]
        /usr/lib/libgtk-x11-2.0.so.0 [0x415116cf]
        /usr/lib/libgtk-x11-2.0.so.0(gtk_widget_reset_rc_styles+0x4d) [0x4151173d]
        /usr/lib/libgtk-x11-2.0.so.0 [0x4142cb80]
        /usr/lib/libgtk-x11-2.0.so.0 [0x413a7512]
        /usr/lib/libglib-2.0.so.0 [0x4ee24bc1]
        /usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x16d) [0x4ee2657d]
        /usr/lib/libglib-2.0.so.0 [0x4ee2980f]
        /usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a9) [0x4ee29bb9]
        /usr/lib/libgtk-x11-2.0.so.0(gtk_dialog_run+0x1a2) [0x4134fd42]
        [0x30b535]
        [0x30b4e6]
        [0x32d6e3]
        [0x32c823]
        f-spot(mono_runtime_exec_main+0x62) [0x80b3872]
        f-spot(mono_runtime_run_main+0x14e) [0x80b3ade]
        f-spot(mono_main+0xf1f) [0x805db0f]
        f-spot [0x805c702]
        /lib/libc.so.6(__libc_start_main+0xdc) [0x49da17e4]
        f-spot [0x805c651]
[tbl@localhost ~]$


Version-Release number of selected component (if applicable):
f-spot-0.1.11-1

How reproducible:
every time

Steps to Reproduce:
1.start f-spot
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bart Vanbrabant 2006-06-06 14:11:54 EDT
gtk-sharp2 should get updated to the svn version for gtk+2.9 like in this bug:
#194262

After this update f-spot needs to be rebuild with the attached patch for changes
in the gtk# api. It's a hacky update that could result in some lost animation in
the UI. 

For now updated rpms can be found here: 
http://files.zoeloelip.be/rpm/
Comment 2 Bart Vanbrabant 2006-06-06 14:12:43 EDT
Created attachment 130627 [details]
Patch to build against gtk# 2.9
Comment 3 Tom London 2006-06-06 16:12:11 EDT
Fixed in gtk2-2.9.2-1
Comment 4 Matthias Clasen 2006-07-25 13:19:47 EDT
*** Bug 192879 has been marked as a duplicate of this bug. ***
Comment 5 Matthias Clasen 2006-07-25 13:20:10 EDT
*** Bug 192786 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.