Bug 19301 - Gnorpm crash when using install
Gnorpm crash when using install
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Dale Lovelace
:
: 19899 20961 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-17 23:06 EDT by Knut J BJuland
Modified: 2007-04-18 12:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 13:27:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2000-10-17 23:06:46 EDT
When I click on install the program crash. I use the lates version of
gnorpm 0.95-3.
Application "gnorpm-auth" has crashed due to fatal error. My Redhat linux
7.0 version is update with up2date.
Comment 1 Need Real Name 2000-10-21 05:05:34 EDT
I have the same problem.  

If I have added a directory to the RPM Directories in the Install Window
Preference settings, the gnorpm crached due to segfault when I click on the
Install button in the Main window. If  delete the entry, then I can bring up the
Install window, then go to Add.  In the Add window, gnorpm crashes (due to
segfault) when try to highlight an rpm file.
Comment 2 Need Real Name 2000-10-21 13:29:08 EDT
In addition, the query window doesn't list the files contained in the package. 
The window where the file list should be is just blank.
Comment 3 decompiled 2000-10-23 17:20:15 EDT
Ditto Here....But I'm not sure if it existed before I ran up2date.

Application "gnorpm-auth" (process ###) has crashed
due to a fatal error.
(segmentation fault)
Comment 4 Need Real Name 2000-10-25 11:01:12 EDT
I'm also experiencing gnorpm crashes when attempting to install additional RPMs
from the
distribution CD.  I downloaded and installed the most recent version of RPM
available at
gnome.org, and I get the same behavior.

Come to think of it, I don't see the file list during query either.  Hrrmmm...
Comment 5 Alan Cox 2000-10-27 11:37:47 EDT
Throw away the Red Hat provided package and replace it with the gnorpm rpm from
ftp://ftp.linux.org.uk/pub/linux/alan/Gnorpm

That one works
Comment 6 Jeff Johnson 2000-10-30 13:27:53 EST
*** Bug 19899 has been marked as a duplicate of this bug. ***
Comment 7 Jeff Johnson 2000-10-30 13:32:35 EST
Fixed in gnorpm-0.95.1-5 errata
Comment 8 Jeff Johnson 2000-11-22 15:11:14 EST
*** Bug 20961 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.