Bug 19301 - Gnorpm crash when using install
Summary: Gnorpm crash when using install
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnorpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
: 19899 20961 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-18 03:06 UTC by Knut J BJuland
Modified: 2007-04-18 16:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 18:27:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Knut J BJuland 2000-10-18 03:06:46 UTC
When I click on install the program crash. I use the lates version of
gnorpm 0.95-3.
Application "gnorpm-auth" has crashed due to fatal error. My Redhat linux
7.0 version is update with up2date.

Comment 1 Need Real Name 2000-10-21 09:05:34 UTC
I have the same problem.  

If I have added a directory to the RPM Directories in the Install Window
Preference settings, the gnorpm crached due to segfault when I click on the
Install button in the Main window. If  delete the entry, then I can bring up the
Install window, then go to Add.  In the Add window, gnorpm crashes (due to
segfault) when try to highlight an rpm file.

Comment 2 Need Real Name 2000-10-21 17:29:08 UTC
In addition, the query window doesn't list the files contained in the package. 
The window where the file list should be is just blank.

Comment 3 decompiled 2000-10-23 21:20:15 UTC
Ditto Here....But I'm not sure if it existed before I ran up2date.

Application "gnorpm-auth" (process ###) has crashed
due to a fatal error.
(segmentation fault)

Comment 4 Need Real Name 2000-10-25 15:01:12 UTC
I'm also experiencing gnorpm crashes when attempting to install additional RPMs
from the
distribution CD.  I downloaded and installed the most recent version of RPM
available at
gnome.org, and I get the same behavior.

Come to think of it, I don't see the file list during query either.  Hrrmmm...

Comment 5 Alan Cox 2000-10-27 15:37:47 UTC
Throw away the Red Hat provided package and replace it with the gnorpm rpm from
ftp://ftp.linux.org.uk/pub/linux/alan/Gnorpm

That one works


Comment 6 Jeff Johnson 2000-10-30 18:27:53 UTC
*** Bug 19899 has been marked as a duplicate of this bug. ***

Comment 7 Jeff Johnson 2000-10-30 18:32:35 UTC
Fixed in gnorpm-0.95.1-5 errata

Comment 8 Jeff Johnson 2000-11-22 20:11:14 UTC
*** Bug 20961 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.