Bug 19392 - wv 0.6.1 fails to compile with a gcc internal error
Summary: wv 0.6.1 fails to compile with a gcc internal error
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 19545 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-19 18:24 UTC by Ole Gjerde
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 18:24:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ole Gjerde 2000-10-19 18:24:30 UTC
Here is the output from the compile attempt.  This is the latest version of
wv (0.6.1) from www.wvware.com

gcc -g -O2  -DHAVE_CONFIG_H  -I. -I./ -I./ -I./iconv/ -I./magick/
-I./expat/xmlp
arse/ -I/include -I/usr/local/include -DTTFDIR=\"/usr/local/lib/wv/ttf\"
-DXMLCO
NFIG=\"/usr/local/lib/wv/wvConfig.xml\"
-DHTMLCONFIG=\"/usr/local/lib/wv/wvHtml.
xml\"  -I./libole2/ -I./glib-wv/ -I./oledecod/ -Wall -c ./wvWare.c
./wvWare.c: In function `main':
./wvWare.c:186: elements of array `long_options' have incomplete type
./wvWare.c:188: warning: excess elements in struct initializer
./wvWare.c:188: warning: (near initialization for `long_options[0]')
./wvWare.c:188: warning: excess elements in struct initializer
./wvWare.c:188: warning: (near initialization for `long_options[0]')
./wvWare.c:188: warning: excess elements in struct initializer
./wvWare.c:188: warning: (near initialization for `long_options[0]')
./wvWare.c:188: warning: excess elements in struct initializer
./wvWare.c:188: warning: (near initialization for `long_options[0]')
./wvWare.c:189: warning: excess elements in struct initializer
./wvWare.c:189: warning: (near initialization for `long_options[1]')
./wvWare.c:189: warning: excess elements in struct initializer
./wvWare.c:189: warning: (near initialization for `long_options[1]')
./wvWare.c:189: warning: excess elements in struct initializer
./wvWare.c:189: warning: (near initialization for `long_options[1]')
./wvWare.c:189: warning: excess elements in struct initializer
./wvWare.c:189: warning: (near initialization for `long_options[1]')
./wvWare.c:190: warning: excess elements in struct initializer
./wvWare.c:190: warning: (near initialization for `long_options[2]')
./wvWare.c:190: warning: excess elements in struct initializer
./wvWare.c:190: warning: excess elements in struct initializer
./wvWare.c:190: warning: (near initialization for `long_options[2]')
./wvWare.c:191: warning: excess elements in struct initializer
./wvWare.c:191: warning: (near initialization for `long_options[3]')
./wvWare.c:191: warning: excess elements in struct initializer
./wvWare.c:191: warning: (near initialization for `long_options[3]')
./wvWare.c:191: warning: excess elements in struct initializer
./wvWare.c:191: warning: (near initialization for `long_options[3]')
./wvWare.c:191: warning: excess elements in struct initializer
./wvWare.c:191: warning: (near initialization for `long_options[3]')
./wvWare.c:192: warning: excess elements in struct initializer
./wvWare.c:192: warning: (near initialization for `long_options[4]')
./wvWare.c:192: warning: excess elements in struct initializer
./wvWare.c:192: warning: (near initialization for `long_options[4]')
./wvWare.c:192: warning: excess elements in struct initializer
./wvWare.c:192: warning: (near initialization for `long_options[4]')
./wvWare.c:192: warning: excess elements in struct initializer
./wvWare.c:192: warning: (near initialization for `long_options[4]')
./wvWare.c:193: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
make: *** [wvWare.o] Error
1

Comment 1 Jakub Jelinek 2000-10-20 12:17:52 UTC
This is primarily bug in wv that it fails to #include <getopt.h> on glibc 2.2+
systems (for some reason it includes its own "getopt.h" for glibc up to 2.1.3
or non-glibc). I have mailed the author of wv about this.
The segfault on bad input seems to be fixed in both rawhide gcc-2.96-57 and
current gcc-2.96-60 (which will appear in rawhide soon), so with those gcc
packages you just get the error and warnings, but don't get Internal error,
which is the correct behaviour.
Future gcc errata will be of course based on gcc-2.96-60 (plus new fixes),
so this should not appear again.

Comment 2 Jakub Jelinek 2000-10-23 07:30:41 UTC
*** Bug 19554 has been marked as a duplicate of this bug. ***

Comment 3 Jakub Jelinek 2000-10-23 07:42:17 UTC
*** Bug 19545 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.