Bug 194141 - yum install evolution now fails
Summary: yum install evolution now fails
Status: CLOSED DUPLICATE of bug 194174
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
urgent
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
: 194301 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-05 22:38 UTC by Eric Goff
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 02:25:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Goff 2006-06-05 22:38:32 UTC
Description of problem:
yum upgrade of evolution fails

Version-Release number of selected component (if applicable):
2.6.2-1.fc5.1

How reproducible:
Always

Steps to Reproduce:
1. yum install evolution
2.
3.
  
Actual results:
--> Populating transaction set with selected packages. Please wait.
---> Package evolution.x86_64 0:2.6.2-1.fc5.1 set to be updated
--> Running transaction check
--> Processing Dependency: libecal-1.2.so.3()(64bit) for package: evolution
--> Processing Dependency: libgpilotd.so.2()(64bit) for package: evolution
--> Processing Dependency: gnome-pilot >= 2.0.13 for package: evolution
--> Processing Dependency: libgpilotdcm.so.2()(64bit) for package: evolution
--> Processing Dependency: libgpilotdconduit.so.2()(64bit) for package: evolution
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gnome-pilot.x86_64 0:2.0.13-7.fc5.6 set to be updated
--> Running transaction check
--> Processing Dependency: libecal-1.2.so.3()(64bit) for package: evolution
--> Processing Dependency: libpanel-applet-2.so.0()(64bit) for package: gnome-pilot
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gnome-panel.x86_64 0:2.14.1-1.fc5.1 set to be updated
--> Running transaction check
--> Processing Dependency: libecal-1.2.so.3()(64bit) for package: evolution
--> Processing Dependency: libecal-1.2.so.3()(64bit) for package: gnome-panel
--> Finished Dependency Resolution
Error: Missing Dependency: libecal-1.2.so.3()(64bit) is needed by package evolution
Error: Missing Dependency: libecal-1.2.so.3()(64bit) is needed by package
gnome-panel


Expected results:
It is insalled

Additional info:
Either evolution package or evolution-data-server package installtion
is broken, because evolution-data-server provides libecal-1.2.so.6, not
libecal-1.2.so.3

Comment 1 Jacek Piskozub 2006-06-06 06:35:07 UTC
In my case three packages need the dependency:

Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-sharp
Error: Missing Dependency: libecal-1.2.so.3 is needed by package gnome-panel
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution


Comment 2 Jacek Piskozub 2006-06-06 06:38:59 UTC
The bug probably should be amade Hardware:All as it is both x86_64 and i386
Fedora problem.

Comment 3 Nicolas Troncoso Carrere 2006-06-07 01:21:09 UTC
*** Bug 194301 has been marked as a duplicate of this bug. ***

Comment 4 Nicolas Troncoso Carrere 2006-06-07 01:24:57 UTC
The problem is that evolution-data-server used to provide libecal-1.2.so.3, but
in the last update it changed to libecal-1.2.so.6. Probably these packages were
built against the old evolution-data-server.

Comment 5 Matthew Barnes 2006-06-07 02:25:14 UTC

*** This bug has been marked as a duplicate of 194174 ***


Note You need to log in before you can comment on or make changes to this bug.