Bug 1949350 - Kibana page is showing blank
Summary: Kibana page is showing blank
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.11.0
Hardware: Unspecified
OS: Linux
low
high
Target Milestone: ---
: 3.11.z
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard: logging-exploration
: 2040601 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-14 04:36 UTC by sphoorthi
Modified: 2022-02-23 15:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-23 15:04:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1705589 1 None None None 2021-04-14 04:36:10 UTC
Red Hat Bugzilla 1719733 1 None None None 2021-04-14 04:36:10 UTC
Red Hat Bugzilla 1726433 1 None None None 2021-04-14 04:36:10 UTC
Red Hat Bugzilla 1791837 1 unspecified CLOSED Kibana user indices continue to need to be deleted and restored due to permissions errors 2022-10-25 03:15:47 UTC

Description sphoorthi 2021-04-14 04:36:11 UTC
Description of problem:
I have a customer where he is facing a blank page when accessing the kibana URL.

There are already bugzilla [1],[2] were created and it's in a released state but the permanent fix is not working for the customer. 

For time being only the workaround [1] is working and it's not reproducible in our environment.

Version-Release number of selected component (if applicable):
ocp version is 3.11.306

How reproducible: Its not reproducible


Steps to Reproduce:
1.
2.
3.

Actual results:

Kibana URL is showing blank page/any exception errors.

Expected results:

Kibana URL should not show blank page/any exception errors.

Additional info:

The customer has created the bugzilla [1] and [2],however fix is released and customer is already using the latest version( v3.11.306).

I found additional bugs [3] and [4] for the same issue however customer need a permanent fix 

[1].https://bugzilla.redhat.com/show_bug.cgi?id=1791837
[2].https://bugzilla.redhat.com/show_bug.cgi?id=1719733
[3].https://bugzilla.redhat.com/show_bug.cgi?id=1705589
[4].https://bugzilla.redhat.com/show_bug.cgi?id=1726433

Workaround 
[1].https://access.redhat.com/solutions/3722751

Comment 1 Jeff Cantrill 2022-02-22 16:21:07 UTC
Do you continue to experience this issue if:
* You use a private browser
* You clear your cookies from your browser cache

We have seen cases in the past where a user's OpenShift bearer token expires while using Kibana but there session is not refreshed and renders Kibana unusable

Comment 2 Jeff Cantrill 2022-02-22 16:25:16 UTC
*** Bug 2040601 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Cantrill 2022-02-23 15:04:39 UTC
Closing this issue:
* due to the age.  
* We do have wide spread reports of this issue
* There are not any urgent responses in the customer case indicating they are still experiencing issues.

Please reopen as needed


Note You need to log in before you can comment on or make changes to this bug.