Bug 19512 - Install died with fatal error message from anaconda
Install died with fatal error message from anaconda
Status: CLOSED DUPLICATE of bug 18031
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-21 12:48 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 14:10:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-21 12:48:04 EDT
During an install of RH7, I received an error message that poped up and
said to report to bugzilla. Below is the information that was saved from
the bug report. I beleive the problem was caused by cdrom hardware failure.
I replaced the cdrom drive, and everything installed fine. Just wanted to
make sure the bug was reported in case it wasn't hardware failure and
anyone else had the problem

Bug Report:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1543, in
doInstall
    self.instCallback, p)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1298, in
instCallback
    self.rpmFD = os.open(fn, os.O_RDONLY)
OSError: [Errno 2] No such file or directory:
'/mnt/source/RedHat/RPMS/sgml-common-0.1-10.noarch.rpm'
 
Local variables in innermost frame:
fn: /mnt/source/RedHat/RPMS/sgml-common-0.1-10.noarch.rpm
total: 0
self: <todo.ToDo instance at 84a15b8>
h: <header object at 8b696b8>
amount: 0
intf: <progress_gui.InstallProgressWindow instance at 84f23b8>
what: 2
 
ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9
 
<failed>
Comment 1 Michael Fulbright 2000-10-30 14:10:25 EST
Thanks for the report, it is similar to bug 18031 and bug 15982, among others.

We plan on making a more graceful mechanism to handle these types of problems
other than just crashing as you experienced.

Marking as a dupe of 18031 since we have request for enhancements related to
improving this behavior.

*** This bug has been marked as a duplicate of 18031 ***

Note You need to log in before you can comment on or make changes to this bug.