Bug 195633 - Cannot convert Korean to Chinese char in SCIM using F9
Cannot convert Korean to Chinese char in SCIM using F9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n, Reopened
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2006-06-16 00:47 EDT by Jong Bae KO
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: scim-1.4.4-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-30 07:51:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jong Bae KO 2006-06-16 00:47:30 EDT
Description of problem:
When I click the F9. It doesn't work.
Korean input pad is changed to English input pad.

Version-Release number of selected component (if applicable):
scim-1.4.4-20 

How reproducible:
always

Steps to Reproduce:
1.type rh(ê³ )
2. press F9    
3.
  
Actual results:
Korean input pad is changed to English input pad.

Expected results:
Show Chinese chars for selecting.

Additional info:
Ctrl+space doesn't work as well bug #194573
Comment 1 Jong Bae KO 2006-06-16 00:50:11 EDT
It is tested in gedit, oowriter and firefox
Comment 2 Akira TAGOH 2006-06-16 00:57:16 EDT
can you provide the result of rpm -qa | grep scim?
Comment 3 Jong Bae KO 2006-06-16 01:18:31 EDT
[root@host202 /]# rpm -qa | grep scim*
scim-libs-1.4.4-18
scim-libs-1.4.4-19
scim-1.4.4-20
scim-qtimm-0.9.4-4
scim-hangul-0.2.2-3.fc6
scim-libs-1.4.4-20
Comment 4 Akira TAGOH 2006-06-16 09:07:42 EDT
sorry, it looks to me like the installation failed. how about rpm -qa
--queryformat="%{name}-%{version}-%{release}.%{arch}\n" | grep scim ?
Comment 5 Jong Bae KO 2006-06-16 10:25:33 EDT
[root@host202 ~]# rpm -qa
--queryformat="%{name}-%{version}-%{release}.%{arch}\n" | grep scim
scim-libs-1.4.4-18.i386
scim-libs-1.4.4-19.i386
scim-1.4.4-20.i386
scim-qtimm-0.9.4-4.i386
scim-hangul-0.2.2-3.fc6.i386
scim-libs-1.4.4-20.i386
Comment 6 Akira TAGOH 2006-06-16 10:35:07 EDT
ok, it looks like the upgrading somehow failed. try removing the older scim-libs
package:

# rpm -e scim-libs-1.4.4-18 scim-libs-1.4.4-19

and test again after restarting your desktop.
Comment 7 Jong Bae KO 2006-06-16 10:53:35 EDT
I cannot remove it.
Ask to aalam.
sorry

[root@host202 ~]# rpm -e scim-libs-1.4.4-18 scim-libs-1.4.4-19
/usr/bin/update-gtk-immodules: line 27:
/etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules: \uadf8\ub7f0
\ud30c\uc77c\uc774\ub098 \ub514\ub809\ud1a0\ub9ac\uac00 \uc5c6\uc74c
\uc624\ub958: %postun(scim-libs-1.4.4-18.i386) scriptlet failed, exit status 1
/usr/bin/update-gtk-immodules: line 27:
/etc/gtk-2.0/i386-redhat-linux-gnu/gtk.immodules: \uadf8\ub7f0
\ud30c\uc77c\uc774\ub098 \ub514\ub809\ud1a0\ub9ac\uac00 \uc5c6\uc74c
\uc624\ub958: %postun(scim-libs-1.4.4-19.i386) scriptlet failed, exit status 1
Comment 8 Akira TAGOH 2006-06-18 23:47:56 EDT
ok, then better using --noscripts too.

# rpm -e --noscripts scim-libs-1.4.4-18 scim-libs-1.4.4-19
Comment 9 Satyabrata Maitra 2006-06-19 03:10:48 EDT
This bug is fixed now. After typing r and h, when pressing F9, The chinese
characters are showing for selecting. 
The default for scim-hangul is 2bul. Another types in the lists are 3bul, 3bul
390, 3bul No-shift, 3bul Yetgeul, 3bul 2bul-shifted. Among which selecting 3bul
Yetgeul only not showing the chinese character for selecting after pressing F9.

Test environments and package versions are given below :

scim-1.4.4-20
scim-tables-chinese-0.5.6-5
scim-libs-1.4.4-20
scim-hangul-0.2.2-4.fc6
scim-tables-0.5.6-5
scim-anthy-1.0.0-2.fc6
scim-devel-1.4.4-20
scim-qtimm-0.9.4-4
scim-libs-1.4.4-17
scim-m17n-0.2.0-3

And O.S. version in which tested is Fedora Core release 5.89 (Rawhide) - i386.
Comment 10 Satyabrata Maitra 2006-06-19 09:34:32 EDT
Hello Tagoh

I am extremely sorry that I closed the bug changing the status NOT A BUG. I have
done it by mistake, and apolozing for my wrongness. So, I am reopening the bug,
and requesting you to see my test result on comment no. 9. May I expect u to
forgive me please.

Regards
Satya
Comment 11 Akira TAGOH 2006-06-19 14:25:24 EDT
No apologies. I couldn't even reproduce this and apparently it was caused by the
misinstallation. so it should be no problem. if someone can see this issue
again, reopen this or file a new bug, please.
Comment 12 Jens Petersen 2006-06-19 20:50:36 EDT
I think F9 is currently set as a scim hotkey (trigger key) for
the Korean desktop.  This should get fixed in the next scim build.
Comment 13 Jens Petersen 2006-06-26 01:28:27 EDT
Should be fixed with scim-1.4.4-21 - you likely need to remove ~/.scim/config
or at least the cached hotkey settings in order for the new configuration
to appear.
Comment 14 Satyabrata Maitra 2006-06-30 07:51:37 EDT
Bug PASS.

F9 is working on 2bul, 3bul 390, 3bul Final, 3bul 2bul-shifted, 3bul No Shift.
Only on 3bul Yetgeul, it is not working.

Tested on environments and package versions :

scim-pinyin-0.5.91-5
scim-chewing-0.3.1-1
scim-devel-1.4.4-21
scim-tables-chinese-0.5.6-5
scim-hangul-0.2.2-4.fc6
scim-tables-0.5.6-5
scim-1.4.4-21
scim-anthy-1.0.0-2.fc6
scim-libs-1.4.4-21
scim-qtimm-0.9.4-4
scim-libs-1.4.4-17
scim-m17n-0.2.0-3 

And O.S. version in which tested is Fedora Core release 5.89 (Rawhide) - i386.

Note You need to log in before you can comment on or make changes to this bug.