Bug 194573 - scim is not working with Indic langs after installation
scim is not working with Indic langs after installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n, Reopened
: 195428 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 02:16 EDT by A S Alam
Modified: 2013-07-02 20:37 EDT (History)
5 users (show)

See Also:
Fixed In Version: scim-1.4.4-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 02:40:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2006-06-14 02:16:27 EDT
Description of problem:
when Installation is finished in Indic Langauge, SCIM is not working with
gnome/openoffice application, but working fine with 'kedit/kbabel'

Version-Release number of selected component (if applicable):
scim-1.4.4-18

How reproducible:
everytime after login with new installation

Steps to Reproduce:
1. Fresh install rawhide
2. login in Hindi Desktop
3. gedit
4.  Ctrl-SPACE (for scim active)

Actual results:
nothing happen

Expected results:
should be able to type in Hindi (any language)

Additional info:
for all supported Indic locale this is true (bn,gu,hi,mr,ml,or,pa,ta)
Comment 1 A S Alam 2006-06-15 02:14:26 EDT
*** Bug 195428 has been marked as a duplicate of this bug. ***
Comment 2 Jong Bae KO 2006-06-15 22:25:46 EDT
Ctrl-Space doesn't work in Korean
Version-Release number of selected component (if applicable):
scim-1.4.4-20
Comment 3 Warren Togami 2006-06-16 10:45:54 EDT
What version of scim-bridge?
Comment 4 A S Alam 2006-06-16 23:24:33 EDT
scim-bridge-0.1.12-2
(rawhide on 7th June 2006)
Comment 5 A S Alam 2006-06-16 23:28:06 EDT
sorry, scim-bridge is not installed for any of these locales (by default
installation)
Comment 6 Akira TAGOH 2006-06-18 22:51:21 EDT
I've heard from jko that the machine that he used is the same as you used. so it
looked like this issue may be caused by the installation failure of scim.
probably it needs to be correct first. I mean you need to remove the duplicated
scim-libs. see Bug#195633. if you see the scriptlet failed at removing, try it
with --noscripts then.
Comment 7 Jens Petersen 2006-06-19 04:28:07 EDT
Could you please try again with a fresh install of fc6test1 or later rawhide?
Comment 8 Satyabrata Maitra 2007-12-13 00:34:16 EST
*** Bug 421171 has been marked as a duplicate of this bug. ***
Comment 9 Satyabrata Maitra 2007-12-13 00:42:22 EST
Reopening this bug as this bug found once again in scim during testing with FC8
Released Version (did not test with rawhide so far). And this is a regression
test case, thatswhy reopening this bug.

IN FC8 Released version scim is behaving strangely for Indic Locale with gtk and
openoffice packages. Its not activating with Ctrl+Space button press. And more
with that, the IME "RAWCODE" not showing in scim global setup menu. 

Component Version -
scim-1.4.7-7.fc8
scim-bridge-0.4.13-4.fc8
scim-bridge-gtk-0.4.13-4.fc8
scim-libs-1.4.7-7.fc8
scim-m17n-0.2.2-2.fc8
scim-tables-0.5.7-3.fc7


Hi Huang
The file you wanted ($HOME/.xinputrc), in the bug #421171, could not be found
there in my test system where I tested this bug. Is it that the file must be
there, or it may not be present also? pls inform. Any other way to get this
file? Pls inform.
Satya
Comment 10 Peng Huang 2007-12-13 00:50:04 EST
Did you install scim-lang-hindi, scim-lang-assamese, and etc?
Please send `rpm -qa scim\*` output to me.
Comment 11 Jens Petersen 2008-01-10 02:40:38 EST
Satya, any update on this?  Otherwise maybe we can close it.

Note You need to log in before you can comment on or make changes to this bug.