Bug 229979 - Update Savage driver to fix DRI hang
Update Savage driver to fix DRI hang
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-25 07:04 EST by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-20 15:47:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2007-02-25 07:04:49 EST
+++ This bug was initially created as a clone of Bug #195851 +++

Description of problem:
Choosing one of the rss-glx modules in the "gnome-screensaver"
preferences and clicking the "Preview" button makes a mouse cursor
appear in front of a white background - no screensaver is visible
though. Hitting a key or clicking the left mouse button has no effect.
The screen is actually blocked.

Version-Release number of selected component (if applicable):
rss-glx-gnome-screensaver-0.8.1.p-3.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Open "gnome-screensaver" preferences.
2. Choose an "rss-glx" module.
3. Click "Preview" button.
  
Actual results:
Screen turns white. It is possible to move the mouse cursor but it's
impossible to exit the preview mode gracefully.

Expected results:
Screensaver should set in and exit upon mouse click or keystroke.

Additional info:
The screensaver module correctly renders the small preview window in
the preferences window but not full-screen.

-- Additional comment from jfrieben@hotmail.com on 2006-06-24 08:33 EST --
Seems to be driver issue ("xorg-x11-drv-savage") since on my desktop
system with a "Radeon 7200" graphics card, everything works correctly.

-- Additional comment from nphilipp@redhat.com on 2006-07-04 09:00 EST --
*** Bug 195854 has been marked as a duplicate of this bug. ***

-- Additional comment from jfrieben@hotmail.com on 2006-07-06 14:35 EST --
After commenting out 'Load  "dri"' in "xorg.conf" and restarting the
"X" server, the screensaver behaves correctly. Moreover, "glxgears",
which otherwise only displays a black window, works again, albeit at
an (expected) slow frame rate.

-- Additional comment from nphilipp@redhat.com on 2006-07-06 15:42 EST --
glxgears displaying a black window with DRI enabled is a good indicator for a
problem in the driver (IMO).

-- Additional comment from jfrieben@hotmail.com on 2006-07-06 16:55 EST --
I had also posted bug #196011 which might be of potential interest and which
is related to an issue with "xscreensaver-gl-extras".

-- Additional comment from jfrieben@hotmail.com on 2006-09-18 12:25 EST --
I have submitted a patch derived from A. Deucher's suggestion at:

  https://bugs.freedesktop.org/show_bug.cgi?id=6357 .

The Fedora patch can be found here:

  https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=136548 .

It fixes both bug 196011 and bug 195851.

-- Additional comment from jfrieben@hotmail.com on 2006-09-19 09:30 EST --
According to the author of the patch, it has been committed upstream:

  https://bugs.freedesktop.org/show_bug.cgi?id=6357#c30

-- Additional comment from ajackson@redhat.com on 2006-09-20 17:53 EST --
Updating summary to remind me to take care of this.

-- Additional comment from jfrieben@hotmail.com on 2006-09-21 08:56 EST --
Caveat: I have rebuilt the "xorg-x11-drv-savage" package again, this
time using a pristine copy of the current "git" tree of the "savage"
driver, including the "DRI locking" fix and it turns out that direct
rendering is not working anymore. "env LIBGL_DEBUG=verbose glxgears"
now reports:

  ... libGL error: drmMap of framebuffer failed (Invalid argument)
      libGL error: reverting to (slow) indirect rendering ...

So, the task is possibly not as straightforward as one might have thought.

-- Additional comment from jfrieben@hotmail.com on 2006-09-27 17:26 EST --
A rather soonish update of the driver by adding the patch submitted above
would be highly welcome, as it might also be beneficial for users affected
by bug 206710.

-- Additional comment from jfrieben@hotmail.com on 2006-12-02 09:18 EST --
(In reply to comment #9)
After updating the "savage" driver "RPM" to version "2.1.12" from
"Xorg 7.2 RC2" and dropping all patches, one still gets the "drmMap"
error message from comment #9. Btw, "Xorg.0.log" has a:

   (II) SAVAGE(0): Direct rendering enabled

so it's rather a "GL" problem. Reverting to "2.1.11" plus A. Deucher's
"DRI" patch from comment #6.

-- Additional comment from jfrieben@hotmail.com on 2006-12-08 08:50 EST --
The "drmMap" issue of the 2.1.2 driver release has already been reported
upstream, see: https://bugs.freedesktop.org/show_bug.cgi?id=8800

-- Additional comment from jfrieben@hotmail.com on 2007-01-14 07:46 EST --
The current "rawhide" kernel "2.6.19-1.2911.fc7" still does not have
the upstream "DRM" version required to make the "2.1.2" driver of
"Xorg 7.2 RC3" work.
This suggests to fix settle the issue preliminary according to the
procedure outlined in comment #6. The inclusion of the relevant patch
[level "easy fix"] has been pending for almost 4 months now (!).

-- Additional comment from jfrieben@hotmail.com on 2007-02-03 06:03 EST --
The failure reported in comment #9 still applies to the combination of
"kernel-2.6.19-1.2917.fc7" and "xorg-x11-drv-savage-2.1.2-1.fc7".

-- Additional comment from jfrieben@hotmail.com on 2007-02-17 10:08 EST --
The failure reported in comment #9 still applies to the combination of
"kernel-2.6.20-1.2932.fc7" and "xorg-x11-drv-savage-2.1.2-2.fc7".
Comment 1 Joachim Frieben 2007-02-25 07:07:35 EST
Still broken for "FC6" due to missing update of "xorg-x11-drv-savage"
by adding the "fodoraized" patch submitted at:

  https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=136548
Comment 2 Joachim Frieben 2007-04-02 11:31:40 EDT
Hi Ajax,

could you be somewhat more specific about why this bug report got
closed as "NOTABUG"? There were several issues with "Xorg 7.1"
such as black "glxgears" windows, non-functional screensavers, etc.
A. Deucher's patch actually managed to make things work correctly.
Moreover, it has been included upstream in version 2.1.2 of the
"savage" driver. I can only wonder how this issue can be judged to
be -no- bug then .. ?
Comment 3 Matěj Cepl 2007-04-02 17:00:13 EDT
Ajax, is totally innocent in this -- this was mistake by me, desktop team
bugmaster. Sorry, the bug is alive and kicking again.
Comment 4 Fedora Update System 2007-04-12 15:12:05 EDT
xorg-x11-drv-savage-2.1.2-3.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Joachim Frieben 2007-04-13 06:24:10 EDT
(In reply to comment #4)
Update "xorg-x11-drv-savage-2.1.2-3.fc6" from "Fedora Test Updates" was
doomed to fail, as I had already reported above that driver version "2.1.2"
is -incompatible- with the currrent kernel "DRM". Therefore, after the
update, the error message: "libGL error: drmMap of framebuffer failed
(Invalid argument) libGL error: reverting to (slow) indirect rendering" pops
up when launching "glxgears" which does not really come as a surprise.
Again, please consider my request from comment #1.
Comment 6 Adam Jackson 2007-04-13 09:48:34 EDT
"Why" do you put "quote" marks around "arbitrary" words?

Sounds like the remainder of this bug is a kernel issue, so, reassigning.
Comment 7 Joachim Frieben 2007-04-14 03:42:57 EDT
Quote(In reply to comment #6)
> "Why" do you put "quote" marks around "arbitrary" words?
>
>Sounds like the remainder of this bug is a kernel issue, so, reassigning.

Well, I do like quoting proper names or citations [when suitable] but not 
ordinary nouns [e.g. when reporting an error message] because I find text more 
readable. What is so so uncommon or arbitrary about this? You see: there is 
not a single quote in my reply ... ;o)

Btw, assigning the bug to the kernel maintainers is not a good idea and rather 
suitable for the "rawhide" package. For the latter, bug 195851 is more 
appropriate because it already targets the development tree [needs to be 
reopened though]. I had reported the kernel issue upstream at

  http://bugzilla.kernel.org/show_bug.cgi?id=7767 ,

and I hope it will be fixed sometime soon. *This* bug report is about "FC6" 
and a *different* issue. If I remember correctly, the corresponding "Xorg" 
release is 7.1.1 whereas driver version 2.1.2 is part of "Xorg" release 7.2. 
The correct driver version is 2.1.1 and this one actually *is* compatible with 
the currrent "FC6" kernels. It would thus simply suffice to answer my prayers 
and incorporate A. Deucher's patch that I had attached above more than half a 
year ago. I cannot understand this obstinate refusal to make the "savage" work 
again when such an easy fix [in terms of investment] has been available for 
ages!
Comment 8 Adam Jackson 2007-04-15 01:11:20 EDT
(In reply to comment #7)
> Btw, assigning the bug to the kernel maintainers is not a good idea and rather 
> suitable for the "rawhide" package. For the latter, bug 195851 is more 
> appropriate because it already targets the development tree [needs to be 
> reopened though]. I had reported the kernel issue upstream at
> 
>   http://bugzilla.kernel.org/show_bug.cgi?id=7767 ,
> 
> and I hope it will be fixed sometime soon. *This* bug report is about "FC6" 
> and a *different* issue. If I remember correctly, the corresponding "Xorg" 
> release is 7.1.1 whereas driver version 2.1.2 is part of "Xorg" release 7.2. 
> The correct driver version is 2.1.1 and this one actually *is* compatible with 
> the currrent "FC6" kernels. It would thus simply suffice to answer my prayers 
> and incorporate A. Deucher's patch that I had attached above more than half a 
> year ago. I cannot understand this obstinate refusal to make the "savage" work 
> again when such an easy fix [in terms of investment] has been available for 
> ages!

What are you going on about?  That patch is already included in savage 2.1.2.
Comment 9 Joachim Frieben 2007-04-15 06:39:00 EDT
The patch is included in 2.1.2 but for this version the "DRM" interface is
known to be busted or at least is doesn't play correctly with current
kernels [see above]. Before the update, accelerated "OpenGL" was at least
working partially for "FC6" - now it's completely broken. What is the point
of updating a package, when it's already known in advance that it won't
work by the time it gets released? For A. Deucher's patch it was confirmed
half a year ago, that it actually works. I have mailed my patched package
to several users who requested it, and they were all happy.

To summarize:

(1) The direct rendering capability of "xorg-x11-drv-savage-2.1.1-5.fc6"
    is affected by an issue solved by A. Deucher's patch which I had
    attached above on 2006-09-18.

(2) Package "xorg-x11-drv-savage-2.1.2-3.fc6" [backported from "Xorg"
    7.2] incorporates this patch but it's "DRM" interface is incompatible
    with the current kernel "DRM". I had reported this fact above on
    2006-09-21. This issue applies both to the "Fedora" development tree
    and "FC6" making driver version 2.1.2 even more useless than 2.1.1.

(3) I had reported the "DRM" issue upstream at
    http://bugzilla.kernel.org/show_bug.cgi?id=7767, and it's completely
    unclear when the kernel tree might get an update to solve this issue.
    Still, such a future kernel would have to make its way into "FC6" yet.

Under these circumstances, updating the "savage" driver to version 2.1.2
for "FC6" is quite audacious. It has introduced a new issue, and the
result is negative as expected ["..libGL error: drmMap of framebuffer
failed .."].
Comment 10 Joachim Frieben 2007-10-20 15:47:39 EDT
Fixed in "xorg-x11-drv-savage-2.1.2-3.fc6" and recent kernels with
updated "DRM".

Note You need to log in before you can comment on or make changes to this bug.