Bug 196018 - restorecon errors on install
restorecon errors on install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-mls (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
: 192258 194018 (view as bug list)
Depends On:
Blocks: FC6Test3Blocker
  Show dependency treegraph
 
Reported: 2006-06-20 08:35 EDT by Joe Orton
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 18:09:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2006-06-20 08:35:55 EDT
Raw Hide install is showing this error in the install.log:

Installing selinux-policy-mls - 2.2.47-1.noarch
restorecon:  error while labeling files under /etc/selinux/mls
/usr/sbin/load_policy:  Can't load policy:  No such file or directory
libsemanage.semanage_reload_policy: load_policy returned error code 2.
libsemanage.semanage_install_active: Could not copy
/etc/selinux/mls/modules/active/policy.kern to /etc/selinux/mls/policy/policy.20.
semodule:  Failed!

and similarly for selinux-policy-strict.
Comment 1 Will Woods 2006-07-10 17:59:38 EDT
Still happening during FC6-Test2 trials:

Error(s) installing: selinux-policy-mls 2.3.2 1 noarch
/usr/sbin/load_policy:  Can't load policy:  No such file or directory
libsemanage.semanage_reload_policy: load_policy returned error code 2.
libsemanage.semanage_install_active: Could not copy
/etc/selinux/mls/modules/active/policy.kern to /etc/selinux/mls/policy/policy.20.
semodule:  Failed!
Comment 2 Daniel Walsh 2006-07-11 10:12:35 EDT
*** Bug 192258 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2006-07-11 10:26:17 EDT
*** Bug 194018 has been marked as a duplicate of this bug. ***
Comment 4 Jesse Keating 2006-07-20 17:58:06 EDT
Will, did this come up again in the latest tree from the 19th of July?
Comment 5 Jesse Keating 2006-08-17 17:07:58 EDT
Will, are you still seeing this in rawhide?
Comment 6 Will Woods 2006-08-17 17:45:37 EDT
No, this appears to be OK in rawhide:

Installing selinux-policy-targeted - 2.3.7-1.noarch
Installing selinux-policy-mls - 2.3.7-1.noarch

Notice: no errors. Yay!
Comment 7 IBM Bug Proxy 2007-02-19 12:21:23 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|FIXEDAWAITINGTEST           |ACCEPTED




------- Additional Comments From ed_pollard@us.ibm.com (prefers email at edpollar@linux.ibm.com)  2007-02-19 12:19 EDT -------
This has fixed by redhat for several months and hasn't tested by us. I am going
to close it internally, if we need to re-open please provide reproduction steps
and results. 

Note You need to log in before you can comment on or make changes to this bug.