Bug 196334 - Segmentation fault for network install with a Prism wireless card
Segmentation fault for network install with a Prism wireless card
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-22 12:32 EDT by Miloš Komarčević
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 17:01:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output (21.55 KB, text/plain)
2006-08-08 17:45 EDT, Miloš Komarčević
no flags Details

  None (edit)
Description Miloš Komarčević 2006-06-22 12:32:43 EDT
I get a SIGSEGV after entering the wireless network adapter details (ESSID only
on an unencrypted network here) when doing a network install (tried HTTP, FTP,
NFS) from the FC-6-Test1-i386-rescuecd.iso:

loader received SIGSEGV!. Backtrace
[0x80498c5]
[0x8047420]
[0x816be80]
[0x80606a8]
[0x804ad35]
[0x8149785]
[0x8048131]

This is on a T30 ThinkPad with Intel ethernet (eth0) and Prism wireless (eth1)
adapters.

Checking the VCs I saw the network modules loaded were: miix, e100, hermes,
orinoco, orinoco_pci, and no other errors were reported.
Comment 1 Jeremy Katz 2006-06-25 21:30:22 EDT
Can you try with the rescue CD from rawhide of 0625 or later?
Comment 2 Miloš Komarčević 2006-06-26 15:21:12 EDT
Segfault is still there with today's 0626 rescue CD, the backtrace is slightly
different:

[0x80498c5]
[0x8047420]
[0x816c320]
[0x80606c1]
[0x804ad35]
[0x8149c25]
[0x8048131]

Last few lines from vc3 are:

INFO: going to do getNetConfig
INFO: eth1 is a wireless adapter
Comment 3 Miloš Komarčević 2006-06-29 17:59:23 EDT
I tried todays 0629 rescuecd image after spotting some anaconda changes, but
still no working net install over the Prism wifi interface.

I've noticed that the orinoco driver has been replaced with hostap (as is the
case with FC5 after installation). The problem there is that the master wifi0
interface is given as the net install choice, but that one cannot be configured.
The interface that is configurable is wlan0 which hostap creates as a virtual
interface on top of wifi0.
Comment 4 Jeremy Katz 2006-07-03 23:28:59 EDT
But the segfault is gone, correct?  Can you provide the output of 'kudzu -p -c
NETWORK' on an installed system?
Comment 5 Miloš Komarčević 2006-07-04 17:12:21 EDT
I cannot confirm the segfault is gone because I cannot configure the wifi
interface since the driver changed to hostap. I get garbage in the ESSID box and
I was prevented from typing into it so I couldn't continue past that screen.
Comment 6 Lonni J Friedman 2006-08-07 19:35:32 EDT
FWIW, I'm seeing this same exact crash with FC6-test2 on an HP xw9300
workstation using the onboard NIC.  I tried both http & ftp installations, and
they both crash in the same fashion as originally reported.
Comment 7 Chris Lumens 2006-08-08 13:16:27 EDT
Could you please attach the backtrace you are getting?  These numbers change
with every single build.
Comment 8 Lonni J Friedman 2006-08-08 13:33:38 EDT
Actually, this turned out to be the bug where not entering a / before the
directory path to the server caused the crash.
Comment 9 Chris Lumens 2006-08-08 15:55:56 EDT
Ah, okay.  This is fixed in Rawhide then.

*** This bug has been marked as a duplicate of 197403 ***
Comment 10 Miloš Komarčević 2006-08-08 17:23:26 EDT
Sorry, but I don't think the bug as originally reported has much to do with the
forward slash path problem, at least not until really established otherwise.

The segfault happens just after entering the ESSID for a Prism based wireless
NIC (I never get to enter the path), when using the orinoco drivers. It did come
back with the FC6 test2 rescuecd sometime after 7/4 (see comment #5). The latest
backtrace from a FC6 test2 install is:

[0x8048284]
[0xb7fb4420]
[0x817ee80]
[0x806237a]
[0x804aea1]
[0x8153a07]
[0x8048131]

The strangest thing is that I again cannot reproduce this with todays 8/8
rawhide rescuecd because again that one went back to loading hostap drivers
instead of orinoco and the wifi0 interface cannot be configured (corrupted ESSID
box not responding to input).

More info on orinoco vs hostap: bug #173727, bug #181441, bug #189566, bug
#191326 and a few more similar in bugzilla.

In conclusion, you can't have both modules loading, which is what happens with
FC6test1 and FC6test2 installs, buts strangely enough not for rawhide ones
(although that has a separate problem of trying to configure only the hostap's
virtual wifi0 interface instead of the real wlan0).
Comment 11 Miloš Komarčević 2006-08-08 17:44:00 EDT
After installing FC6test2 through the ethernet NIC, here's the 'kudzu -p -c
NETWORK' output on this T30:

-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: e100
desc: "Intel Corporation 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller"
network.hwaddr: 00:09:6b:c2:24:d9
vendorId: 8086
deviceId: 1031
subVendorId: 1014
subDeviceId: 0209
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  8
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: orinoco_pci
desc: "Intersil Corporation Prism 2.5 Wavelan chipset"
network.hwaddr: 00:20:e0:8e:45:35
vendorId: 1260
deviceId: 3873
subVendorId: 1668
subDeviceId: 0406
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  2
pcifn:  0

The wireless NIC seems to be claimed by the orinoco driver, although both
orinoco and hostap are loaded, dmesg output to follow.
Comment 12 Miloš Komarčević 2006-08-08 17:45:30 EDT
Created attachment 133831 [details]
dmesg output
Comment 13 Chris Lumens 2006-08-09 14:58:43 EDT
Okay, I believe I have a fix for the traceback you are seeing.  I'm going to
stay out of the hostap vs. orinoco stuff for now and only worry about fixing up
the loader segfault.  Please test the next test release/rawhide and let me know
if it's working better for you.
Comment 14 Miloš Komarčević 2006-08-16 18:23:27 EDT
Tried today's (08/16) rescuecd with no apparent change.

I can't confirm the segfault is gone bacuse rawhide's rescuecd loads hostap
instead of orinoco as in test1 and test2 rescuecd. The master wifi0 interface is
presented as the choice instead of virtual wlan0 data interface, and can't be
configured further because of corruption of the ESSID input box.
Comment 15 Miloš Komarčević 2006-08-17 14:19:52 EDT
Ok, today's 08/17 rawhide rescuecd loads orinoco and the segfault is indeed
gone, and I can configure my wireless eth1 interface just fine.

I guess this bug can be closed, but I'm still baffled by the unexpected and
irregular driver switching in rawhide and test images.
Comment 16 Miloš Komarčević 2006-09-16 09:01:20 EDT
...and we're back to the whole hostap instead of orinoco issue with the FC6test3
CD - I can't configure my wifi0 wireless interface when the hostap driver is loaded.

Why are rawhide and test images always different when it comes to this issue?
Comment 17 Chris Lumens 2006-09-18 11:09:25 EDT
This is an aggravating one.  Okay, we're going to try removing hostap from the
module list in anaconda and seeing if that fixes this up.
Comment 18 Miloš Komarčević 2006-09-25 16:34:50 EDT
The last rawhide rescuecd I managed to get was from 09/22. It does indeed load
orinoco and there is no sign of hostap. The problem I have now is that it does
not associate with the AP for some reason any more.
Comment 19 Chris Lumens 2006-09-25 17:01:50 EDT
If you continue to see this problem, please open a new bug against anaconda and
we will either work on it there or see if it's a driver problem and reassign the
bug appropriately.

Note You need to log in before you can comment on or make changes to this bug.