Bug 196408 - gtkmozembed.so has an old path to libgtkembedmoz.so
gtkmozembed.so has an old path to libgtkembedmoz.so
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
: Desktop
: 207650 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-22 21:42 EDT by Zack Cerza
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: gnome-python2-extras-2.14.2-4.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-24 16:33:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2006-06-22 21:42:34 EDT
+++ This bug was initially created as a clone of Bug #164175 +++
Description of problem:
gtkmozembed.so cannot locate libgtkembedmoz.so because it has a hard-coded path
to an older mozilla version.

Version-Release number of selected component (if applicable):
gnome-python2-extras-2.10.0-2.1

How reproducible:
Always

Steps to Reproduce:
1. in python, "import gtkmozembed"
  
Actual Results:  ImportError: libgtkembedmoz.so: cannot open shared object file:
No such file or directory

Expected Results:  The import should be successful.

Additional info:

strings /usr/lib/python2.4/site-packages/gtk-2.0/gtkmozembed.so| fgrep /usr/lib
/usr/lib/mozilla-1.7.12

mozilla is now at version 1.7.13. Simply rebuilding gnome-python2-extras
resolves this problem.
Comment 1 Matthew Barnes 2006-09-22 14:58:19 EDT
*** Bug 207650 has been marked as a duplicate of this bug. ***
Comment 2 Matthew Barnes 2006-09-25 10:45:19 EDT
I just pushed a rebuilt package to Fedora-Updates-Testing.
Sorry this took so long.

gnome-python2-extras-2.14.0-3.fc5
Comment 3 Matthew Barnes 2006-10-24 16:33:30 EDT
This is now fixed in Fedora Core 6.

gnome-python2-extras-2.14.2-4.fc6

Note You need to log in before you can comment on or make changes to this bug.