Bug 1968840 - F35FailsToInstall: mirrormanager2, mirrormanager2-lib
Summary: F35FailsToInstall: mirrormanager2, mirrormanager2-lib
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mirrormanager2
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adrian Reber
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1987714 (view as bug list)
Depends On: 1899466 1926615
Blocks: F35FTBFS F35FailsToInstall F36FTBFS F36FailsToInstall PYTHON3.10 F35BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-06-07 23:11 UTC by Miro Hrončok
Modified: 2021-09-07 19:07 UTC (History)
6 users (show)

Fixed In Version: mirrormanager2-0.15-4.fc36 mirrormanager2-0.15-4.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-07 19:07:18 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-06-07 23:11:33 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (mirrormanager2) Fails To Install in Fedora 35:

can't install mirrormanager2:
  - nothing provides python3.9dist(flask) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(dnspython) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(email-validator) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(protobuf) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(python3-openid) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(flask-admin) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(flask-wtf) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(flask-xml-rpc) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(geoip2) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(python-fedora) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(python-openid-cla) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(python-openid-teams) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(webob) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(wtforms) needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python(abi) = 3.9 needed by mirrormanager2-0.15-2.fc35.noarch
  - nothing provides python3.9dist(sqlalchemy) >= 0.7 needed by mirrormanager2-0.15-2.fc35.noarch
  
can't install mirrormanager2-lib:
  - nothing provides python(abi) = 3.9 needed by mirrormanager2-lib-0.15-2.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-06-07 23:26:32 UTC
This bugzilla is likely a fallout from the Python 3.10 rebuild.

If your package (or some of the dependencies it has) failed to rebuild during the Python 3.10 rebuild, they now fail to install. To fix this, packages need to be rebuilt in Rawhide.

We will slowly triage the bugzillas, but we'd appreciate your help.

If you know this is blocked by an existing reported build failure or another package not yet rebuilt with Python 3.10, please mark it as such by using the "Depends On"/"Blocks" bugzilla fields. That will help us determine what failures to prioritize.

Thank you and sorry for the inconvenience. Let me know if you need any help.

Comment 2 Miro Hrončok 2021-06-15 00:30:11 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 4 Adrian Reber 2021-07-31 06:45:51 UTC
*** Bug 1987714 has been marked as a duplicate of this bug. ***

Comment 5 Ben Cotton 2021-08-10 13:06:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 6 Fedora Update System 2021-09-01 22:51:42 UTC
FEDORA-2021-b5d8651eed has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Fedora Update System 2021-09-01 22:51:50 UTC
FEDORA-2021-766121a38b has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-766121a38b

Comment 8 Miro Hrončok 2021-09-01 22:52:37 UTC
Proposing a freeze exception as the package does not even install without it.

Comment 9 Fedora Update System 2021-09-02 15:56:08 UTC
FEDORA-2021-766121a38b has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-766121a38b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-766121a38b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Adam Williamson 2021-09-06 15:07:34 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/426 , marking accepted.

Comment 11 Fedora Update System 2021-09-07 19:07:18 UTC
FEDORA-2021-766121a38b has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.