Bug 197033 - X doesn't work anymore with Matrox G400
X doesn't work anymore with Matrox G400
Status: CLOSED DUPLICATE of bug 203570
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
6
athlon Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-28 03:24 EDT by Jean-François Rameau
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 09:35:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg after starting with mga driver (49.35 KB, text/plain)
2006-06-28 03:24 EDT, Jean-François Rameau
no flags Details
Running without any xorg.conf file (49.84 KB, text/plain)
2006-10-05 21:38 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jean-François Rameau 2006-06-28 03:24:17 EDT
Description of problem:

X starts but I only see "waves" on screen. I tried the command
'system-config-display --reconfig' but still doesn't work. So I'm using vesa
driver to get a reasonable 1024x768 display.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mga-1.4.1-3 / xorg-x11-server-Xorg-1.1.0-23

Additional info:

lspci

00:00.0 Host bridge: VIA Technologies, Inc. VT8371 [KX133] (rev 02)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8371 [KX133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 21)
00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 10)
00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 10)
00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 10)
00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
00:08.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:08.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
00:09.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
00:0c.0 Mass storage controller: Promise Technology, Inc. PDC20267
(FastTrak100/Ultra100) (rev 02)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. G400/G450 (rev 05)

cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 4
model name      : AMD Athlon(tm) Processor
stepping        : 2
cpu MHz         : 701.719
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
mmx fxsr syscall mmxext 3dnowext 3dnow
bogomips        : 1405.84

xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "dri"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "fr"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Panasonic TX-D1734-E"
	Option	    "dpms"
EndSection

Section "Device"

	#Driver      "vesa"
	Identifier  "Videocard0"
	Driver      "mga"
	VendorName  "Videocard vendor"
	BoardName   "Matrox Graphics, Inc. G400/G450"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth    16 
	SubSection "Display"
		Viewport   0 0
		Depth     16
			Modes     "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"

		Modes    "1024x768" "640x480"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
Comment 1 Jean-François Rameau 2006-06-28 03:24:17 EDT
Created attachment 131644 [details]
Xorg after starting with mga driver
Comment 2 Jean-François Rameau 2006-06-28 10:30:58 EDT
Just recompiled mga driver from FC5 SRPMS ( xorg-x11-drv-mga-1.2.1.3-1.2 ) and
installed it. Works like a charm !
Comment 3 Michael Schwendt 2006-07-17 20:21:07 EDT
> X starts but I only see "waves" on screen.

What do you mean?

For me, the monitor is switched off when using the "mga" driver.
VESA mode 800x600 works, but is inacceptable.
Comment 4 Michael Schwendt 2006-07-17 20:39:29 EDT
After building FC5 xorg-x11-drv-mga-1.2.1.3-1.2 for Rawhide (Jul 18th)
I end up with a working mga driver again.

At least these are broken:

  xorg-x11-drv-mga-1.4.1-4
  xorg-x11-drv-mga-1.4.1-4.1
Comment 5 Mike A. Harris 2006-07-25 03:30:57 EDT
If you disable AIGLX and restart does the problem change at all?
Comment 6 Michael Schwendt 2006-07-26 04:23:55 EDT
FWIW, my xorg.conf doesn't mention AIGLX anywhere, only the "glx" module.
So I queried Google, landed at a confusing place in the Fedora Wiki,
which covers installing AIGLX from source and things like that, but
didn't find any concrete/good documentation on how to enable/disable
it at the server-level. Then I decided to move on. And disabling "glx"
didn't change anything. One thing I might try later is recompiling the
new driver with less optflags.
Comment 7 Michael Schwendt 2006-08-08 19:17:11 EDT
Recompiling xorg-x11-drv-mga-1.4.1-4.1 without optimisations didn't
"fix" anything either.
Comment 8 Michael Schwendt 2006-08-22 16:27:29 EDT
Will FC6 ship with a broken mga driver?
Comment 9 Jim Cornette 2006-09-24 18:44:46 EDT
Have you tried running X -configure and then copying the generated file in place
of the s-c-display generated file? I had severe problems with out of range
before using the X -configure generated file. I only had to reduce the Vertical
refresh range from a suprising maximum of 190 Hz to top out at 70 Hz to be
conservative.
With the FC5  xorg.conf file generated by s-c-display, I got an out of range
error when loading the game viruskiller. This config file did not do this with
Xorg-x11 from FC5. Filed a bug report recently. Bug 207804
Comment 10 Michael Schwendt 2006-10-05 09:54:44 EDT
Jim, "X -configure" lead to a very questionable 1600x1200 resolution
and a monitor that created a frightening bad smell in the office while
displaying a black screen with a mouse cursor. Nothing I would want to
look into further. Seems highly dangerous to me.

[...]

system-config-display is broken again, too. (-> different ticket)

With this real bad experience and the /dev/null symptoms here in
bugzilla I can only discourage any Matrox card users from trying
Fedora Core 6. :-(
Comment 11 Adam Pribyl 2006-10-05 10:30:22 EDT
(In reply to comment #6)
I may be this is new in wiki:
http://fedoraproject.org/wiki/RenderingProject/aiglx#head-936632a0253a7a1e6c04e697932546dde44175c1
Comment 12 Michael Schwendt 2006-10-05 15:38:36 EDT
Checking the "I am providing the requested information for this bug"
once more a original reporter is not responding and communication
has stalled.
Comment 13 Michael Schwendt 2006-10-05 15:56:52 EDT
Reply to comment 11:
In the log

(**) Option "AIGLX" "off"
(**) AIGLX disabled

makes no change. Symptoms stay the same. Blank screen, monitor is put to sleep.
Comment 14 Alexei Podtelezhnikov 2006-10-05 20:17:33 EDT
Provided xorg.conf is obviously modified from the original one. Let's stop 
panicking, and start diagnostics: move away your xorg.conf and reconfigure 
from scratch. You only have 16Mb videoram - try not pushing your card to 
1024x768. Do you see the same behavior with 800x600? 

Stop complaining and try to provide more symptoms than just "blank screen".
You didn't do your job in this bug report, but you want someone else to dance 
around you...? Don't even try to tell me that if xorg.conf worked before, it 
was not broken. No such compatibility is ever guaranteed.
Comment 15 Jim Cornette 2006-10-05 21:38:07 EDT
Created attachment 137891 [details]
Running without any xorg.conf file

I am running at 1152x864 @ 75 Hz
Comment 16 Michael Schwendt 2006-10-06 09:35:10 EDT

*** This bug has been marked as a duplicate of 203570 ***

Note You need to log in before you can comment on or make changes to this bug.