Bug 1974 - RPM does not get correctly installed during "Server" installation
RPM does not get correctly installed during "Server" installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
: 1913 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-04 01:03 EST by Adam Thompson
Modified: 2015-01-07 18:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-04 12:43:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Thompson 1999-04-04 01:03:56 EST
Did a clean "Server" install on a test system,
observed several problems in install.log (after it was
done).  [Will forward install.log later tonight.]

First problem I noticed after boot was ... well, the first
problem was that my mouse wasn't configured right and I
couldn't log into XDM, but after that...

rpm refused to run, claiming 'Unable to open
/usr/lib/rpm/rpmrc for reading: No such file or directory.'

And, indeed, /usr/lib/rpm did not exist, nor [obviously] did
any files in that directory exist.  After mkdir'ing
/usr/lib/rpm and simply touch'ing rpmrc, rpm was willing to
execute.

First thing I tried: 'rpm -ql rpm'
I got: 'package rpm is not installed'

Then I downloaded rpm-2.92-10.i386.rpm, attempted to insatll
with 'rpm -iv rpm-2.92-10.i386.rpm' and I get: (!!!)
'error: package rpm-2.92-10 is for a different architecture'
Hey, neat trick, guys!

Anyway, there's some problems.

I'll detail my hardware config when I send in the
install.log along with a dmesg dump from a clean boot.
Comment 1 Jeff Johnson 1999-04-04 14:58:59 EDT
*** Bug 1913 has been marked as a duplicate of this bug. ***

   The "rpm" command from commandline results in the
following, while the GnoRPM program, it run from nxterm,
also outputs:

Unable to open /usr/lib/rpm/rpmrc for reading: No such file
or directory.

------- Additional Comments From dkl@redhat.com  03/31/99 11:39 -------
I could not replicate this problem on the latest release of Starbuck.

------- Additional Comments From yngguru@earthlink.net  04/02/99 00:41 -------
I thought that there was only one version of Starbucks, that is, 5.9.
 Unless you mean its already been fixed....

------- Additional Comments From notting@redhat.com  04/02/99 22:53 -------
what does rpm -V rpm say?
Comment 2 Adam Thompson 1999-04-04 18:24:59 EDT
1) rpm -V rpm gives:
Package rpm is not installed

2) after looking at my install.log again, then looking carefully at
the instimage, the problem appears to reside with the starbuck
instimage.  [At least, the copy on my local mirror.  I can't get into
ftp.redhat.com to check the original.]

in
ftp.muug.mb.ca:/mirror/redhat/starbuck/i386/RedHat/instimage/usr/bin ,
 we have gzip & gunzip:

ftp> cd /mirror/redhat/starbuck/i386/RedHat/instimage/usr/bin
250 CWD command successful.
ftp> dir g*
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
-rwxr-xr-x   2 105      100       1054716 Oct 10 01:44 gdb
-rwxr-xr-x   1 105      100         69444 Sep 10  1998 grep
lrwxrwxrwx   1 105      100             4 Mar 17 23:24 gunzip -> gzip
lrwxrwxrwx   1 105      100            14 Mar 17 23:24 gzip -
> ../../bin/gzip
226 Transfer complete.
ftp: 271 bytes received in 0.05Seconds 5.42Kbytes/sec.
ftp>

which would be OK except for one minor problem:

ftp> dir ../../bin/gzip
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> cd ../../bin
550 ../../bin: No such file or directory.
ftp>

There are similar problems in the instimage/modules directory, where
some of them are symlinks to *absolute* paths [ds.o, i82365.o,
pcmcia_core.o, tcic.o]
into /tmp/pcmcia/lib/modules/preferred/pcmcia/ - which does not exist
on the mirror I'm using.

BTW: I'm noticing that VERY few of the redhat mirrors have the
starbuck distribution...
Comment 3 Adam Thompson 1999-04-04 18:28:59 EDT
Bug 1787 is a duplicate.
Comment 4 Adam Thompson 1999-04-04 18:32:59 EDT
Bug 1688 is also the same problem, but *WHERE* am I supposed to get a
newer version of the RPM rpm, if not from the starbuck *BETA*
distribution??

I stand by my previous comment that the root problem is actually in
the instimage.  (At least in my case.)  Several rpms did not install
correctly during install - fixing them after install is a pretty bad
workaround, if I have to read through install.log to figure out what
worked and what didn't!
Comment 5 Jeff Johnson 1999-04-04 19:15:59 EDT
*** Bug 1787 has been marked as a duplicate of this bug. ***

After installing rh5.9 on a box here, I found that there was
no /usr/lib/rpm/rpmrc, which meant I couldn't install any
new rpms. This is either a problem with the installer, or
the installation of rpm. In any case, my solution was to
switch to terminal 2 and copy the rpmrc file the installer
appeared to be using to /usr/lib (There was one in
/usr/lib/rpm during the installation, but not in
/mnt/usr/lib/ during the installation).
Comment 6 Jeff Johnson 1999-04-05 10:43:59 EDT
Judging from the number of bug reports, there's some problem here.
However, we are unable to reproduce the "missing rpmrc file".
(W've seen it once but could not be reproduced). Does anyone
see a common factor that I'm missing?
Comment 7 yngguru 1999-04-05 15:05:59 EDT
Have you tried a custom installation with everything installed?  I
know that the problem reproduces itself twice for a fact.  Also,
couldn't it be possible that one of the mirror sites corrupted a file
which is causing this problem?
Comment 8 Bill Nottingham 1999-04-05 16:30:59 EDT
there were comments that mirror sites didn't get a working RPM
binary in their tree. That may be what they're all running into.
Comment 9 yngguru 1999-04-05 19:31:59 EDT
There's one other element to consider, though.  The GnoRPM program
seems to work on my installation of StarBucks, yet it still outputs
that the 'rpmrc' file is missing.  If the GnoRPM program works, and it
is only a front end to 'rpm', then why is it working when 'rpm' will
not?
Comment 10 Jeff Johnson 1999-05-04 12:43:59 EDT
I believe this problem has been solved in later versions of
the installer. If not, please reopen this bug with enough info
to reproduce the problem.

Note You need to log in before you can comment on or make changes to this bug.