Bug 198717 - scim-bridge crash while switching to next input method
scim-bridge crash while switching to next input method
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2006-07-12 23:37 EDT by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: scim-bridge-0.2.6-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 08:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2006-07-12 23:37:33 EDT
Description of problem:
Pressing Crtl-Shift multiple times to move to the desirable IME caused
scim-bridge to crash.

$ gedit
sys:1: Warning: Invalid file descriptor.

sys:1: Warning: Error closing channel: Bad file descriptor
IO exception has been occured: IOException at scim_bridge_messenger_receive:
unknown reason
stacktrace: 
 at scim_bridge_messenger_receive ()
 at scim_bridge_client_key_event_occured ()
 at scim_bridge_client_imcontext_filter_key_event ()


Version-Release number of selected component (if applicable):
scim-debuginfo-1.4.4-23.fc6
scim-tables-0.5.6-5
scim-devel-1.4.4-23.fc6
scim-m17n-0.2.0-4.fc6
scim-libs-1.4.4-23.fc6
scim-hangul-0.2.2-5.fc6
scim-bridge-0.2.4-1.fc6
scim-bridge-debuginfo-0.2.4-1.fc6
scim-anthy-1.0.0-2.fc6
scim-doc-1.4.4-23.fc6
scim-qtimm-0.9.4-4
scim-tables-chinese-0.5.6-5
scim-bridge-gtkimm-0.2.4-1.fc6
scim-pinyin-0.5.91-11.fc6
scim-1.4.4-23.fc6
scim-chewing-0.3.1-2


How reproducible:
Always

Steps to Reproduce:
1.login with en_US locale
2.start gedit and activate scim
3.ctrl-shift to switch next input method
  
Actual results:
scim-bridge crash

Expected results:
transition should be fine

Additional info:
Comment 1 Lawrence Lim 2006-07-12 23:55:19 EDT
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1281090656 (LWP 3340)]
0x0805dd9f in ScimBridgeAgentIMContextImpl::set_enabled (this=0x99d6960, 
    new_state=true) at scim-bridge-agent-imcontext.cpp:452
452             PanelFactoryInfo info = PanelFactoryInfo (factory->get_uuid 
(), utf8_wcstombs (factory->get_name ()), factory->get_language (), 
factory->get_icon_file ());
(gdb) 
(gdb) bt
#0  0x0805dd9f in ScimBridgeAgentIMContextImpl::set_enabled (this=0x99d6960, 
    new_state=true) at scim-bridge-agent-imcontext.cpp:452
#1  0x080547d5 in ScimBridgeAgentImpl::filter_hotkeys (this=0x97cecf0, 
    imcontext=0x99d6960, key_event=@0x9a61144) at scim-bridge-agent.cpp:614
#2  0x08054f70 in ScimBridgeAgentImpl::filter_key_event (this=0x97cecf0, 
    event=0x9a61138) at scim-bridge-agent.cpp:760
#3  0x080550e1 in ScimBridgeAgentImpl::read_and_dispatch (this=0x97cecf0)
    at scim-bridge-agent.cpp:305
#4  0x08055138 in run_event_dispatcher (arg=0x97cecf0)
    at scim-bridge-agent.cpp:184
#5  0x00d973fc in start_thread () from /lib/libpthread.so.0
#6  0x001fe8ae in clone () from /lib/libc.so.6
(gdb) 
Comment 2 Lawrence Lim 2006-07-13 00:37:40 EDT
Seems to only crash with Gtk apps, work fine when I start kedit right away. Also
noticed that there are trouble starting Gtk apps such as gnome-terminal and
firefox after it crashed.
Comment 3 Ryo Dairiki 2006-07-14 01:24:34 EDT
I couldn't reproduce this at all.
It seems like more information is required.

Did you really press "ctrl+shift"?
The following line seems like you pressed trigger hot key.
#1  0x080547d5 in ScimBridgeAgentImpl::filter_hotkeys (this=0x97cecf0, 
    imcontext=0x99d6960, key_event=@0x9a61144) at scim-bridge-agent.cpp:614

Did you use "shared-imengine" mode, or "nonshared-imengine" mode?
It might have something to do with this problem.

Judging from #0 in the debug output, the "factory" must be NULL.
Is this true? Please check that later.
Comment 4 Lawrence Lim 2006-07-17 00:10:16 EDT
RE: Comment#3
Ryo-san,
You are right, ScimBridgeAgentIMContextImpl::set_enabled looks like coming 
through from hotkey triggering. I have tried to reproduce the bug again  and 
came up with new bt. Hope this is better. I will try to figure out if there is 
another bug related with the previous bt.

I reproduce with nonshared-imengine mode and for <the "factory" must be NULL> 
comment, I think it is more related to the previous trace, hopefully this is 
better.

Thanks and have a nice day. :)
===
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1280914528 (LWP 2673)]
0x0805f27b in ScimBridgeAgentIMContextImpl::focus_in (this=0x91f6d70)
    at scim-bridge-agent-imcontext.cpp:622
622             info = PanelFactoryInfo (factory->get_uuid (), utf8_wcstombs 
(factory->get_name ()), factory->get_language (), factory->get_icon_file ());
(gdb) bt
#0  0x0805f27b in ScimBridgeAgentIMContextImpl::focus_in (this=0x91f6d70)
    at scim-bridge-agent-imcontext.cpp:622
#1  0x0805e61a in ScimBridgeAgentIMContextImpl::open_imengine (this=0x91f6d70,
    factory=@0xb3a6c31c) at scim-bridge-agent-imcontext.cpp:585
#2  0x0805d495 in ScimBridgeAgentIMContextImpl::open_next_imengine (
    this=0x91f6d70) at scim-bridge-agent-imcontext.cpp:548
#3  0x0805459e in ScimBridgeAgentImpl::filter_hotkeys (this=0x90a3cf0,
    imcontext=0x91f6d70, key_event=@0x92323dc) at scim-bridge-agent.cpp:640
#4  0x08054990 in ScimBridgeAgentImpl::filter_key_event (this=0x90a3cf0,
    event=0x92323d0) at scim-bridge-agent.cpp:760
#5  0x08054b01 in ScimBridgeAgentImpl::read_and_dispatch (this=0x90a3cf0)
    at scim-bridge-agent.cpp:305
#6  0x08054b58 in run_event_dispatcher (arg=0x90a3cf0)
    at scim-bridge-agent.cpp:184
#7  0x00830fbc in start_thread () from /lib/libpthread.so.0
#8  0x002b630e in clone () from /lib/libc.so.6
Comment 5 Lawrence Lim 2006-07-17 00:26:52 EDT
Ryo-san, 
Thanks for pointing out my mistake, new bug 199078 has been created for the 
inital bt.
Comment 6 Jens Petersen 2006-07-24 06:30:35 EDT
Could you try again with scim-0.2.5?
Comment 7 Jens Petersen 2006-07-26 01:55:19 EDT
Fixed in current scim-bridge afaict.
Comment 8 Satyabrata Maitra 2006-07-27 08:36:57 EDT
I did not able to reproduce this bug. Closing it. If bug found again, please
reopen this bug.


Version-Release number of selected component

scim-libs-1.4.4-9.2.fc5
scim-qtimm-0.9.4-5
scim-pinyin-0.5.91-11.3.fc6
scim-bridge-gtkimm-0.2.6-1.fc6
scim-fcitx-3.1.1-5.fc6
scim-bridge-0.2.6-1.fc6
scim-input-pad-0.1.1-4.fc6
scim-libs-1.4.4-25.fc6
scim-devel-1.4.4-25.fc6
scim-fcitx-tools-3.1.1-5.fc6
scim-m17n-0.2.0-5.fc6
gedit-2.15.4-1 

Note You need to log in before you can comment on or make changes to this bug.