Bug 199250 - [Indic] scim is not working with Openoffice.org
[Indic] scim is not working with Openoffice.org
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: SCIM
  Show dependency treegraph
 
Reported: 2006-07-18 09:06 EDT by A S Alam
Modified: 2013-07-02 20:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 11:30:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2006-07-18 09:06:21 EDT
Description of problem:
when try to input in oowriter after login to Indic locale (Punjabi/hindi/tamil),
after pressing Ctrl+Space, not able to input

Version-Release number of selected component (if applicable):
scim-1.4.4.-23.1.fc6

How reproducible:
everytime

Steps to Reproduce:
1.login to indic locale (Punjabi)
2. start oowriter
3.Ctrl+Space to activate SCIM
  
Actual results:
nothing happen

Expected results:
able to input Indic language (Punjabi)

Additional info:
1) some close reference may be
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=184358

2)SCIM is working fine for gedit/kedit
3) working fine for CJK language
Comment 1 A S Alam 2006-07-18 09:13:54 EDT
Envrinment:
Fedora Core: Rawhide
Hardware: x86_64
Comment 2 Akira TAGOH 2006-07-20 00:21:33 EDT
It looks like you've run scim on the another locale before - which especially
have the different hotkey, such as Japanese and Korean. and apparently the patch
for Bug#186861 introduced this issue so that .scim/config is always stored when
scim runs at the first time. it should works again if you remove .scim/config.
I'm not sure if this is intentional behavior or not. need info from qwang.
Comment 3 Qingyu Wang 2006-07-21 02:54:36 EDT
Yeah, if you run scim on other locales before, the hotkeys configuration you
first use in other locales will be recorded in .scim/config file. Regardless
what locale you are using now, the hotkeys configuration will be what you used
in the first time to run scim. You can remove .scim/config file to set the
hotkey configuration to default(Ctrl+Space) or change hotkeys configuration in
setup panal. 
Comment 4 Jens Petersen 2006-07-25 07:39:51 EDT
AAlam, to confirm: this is oo.o specific?
Comment 5 A S Alam 2006-07-25 09:09:23 EDT
yes, OO.o only
Comment 6 Jens Petersen 2006-07-26 00:01:01 EDT
Ok.  Current oo.o segfaults for me at startup...
Comment 7 Leon Ho 2006-07-27 01:02:22 EDT
Is it about the multilib again? does it work with x86 binary?
Comment 8 A S Alam 2006-07-27 11:30:07 EDT
working for me with following version:
openoffice.org-core-2.0.3-7.4

scim-anthy-1.0.0-4.fc6
scim-m17n-0.2.0-5.fc6
scim-1.4.4-25.fc6
scim-libs-1.4.4-25.fc6

Note You need to log in before you can comment on or make changes to this bug.