Bug 199532 - [ml_IN] Digit (unicode) having latin glyphs
[ml_IN] Digit (unicode) having latin glyphs
Status: CLOSED DUPLICATE of bug 206434
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Rahul Bhalerao
: i18n
: 206239 (view as bug list)
Depends On:
Blocks: Indic
  Show dependency treegraph
Reported: 2006-07-20 02:57 EDT by A S Alam
Modified: 2013-07-02 20:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-03 10:07:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Answer to NEEDINFO (169.64 KB, image/png)
2006-08-31 10:42 EDT, Mayank Jain
no flags Details

  None (edit)
Description A S Alam 2006-07-20 02:57:47 EDT
Description of problem:
Malayalm Fonts having Latin digit glyphs (0,1,2) instead of malayalam glyphs
(check at http://www.unicode.org/charts/PDF/U0D00.pdf)

Version-Release number of selected component (if applicable):

How reproducible:

Following unicode points:


as malayalam digit are not used anywhere now, but as these are part of unicode,
so need to fix
Comment 1 Ani Peter 2006-07-27 04:10:32 EDT
As Aalam said Malayalam numbers are not used anywhere, other than in the Holy
Bible. 99% of the people do not know Malayalam numerals. Even the
government(where our product will be more used)documents are written using the
Latin numerals (0,1,2,3,4,5,6,7,8,9). Hence,when malayalam inscript is activated
on the keyboard, we need to have these Latin numerals only. But if we are so
particular that we need to include the malayalam numerals as the unicode exist,
we can but since it is not at all going to be used from the user side,when the
keyboard is used to write in Malayalam , Latin numerals must appear when the
keys 1-0 are pressed.
Comment 2 Leon Ho 2006-08-28 02:32:28 EDT
Not a very proirity if it is not used anymore. 

Mayank, can you confirm if keymapping are using keycode from U+0030 to U+0039 on
key maps 0-9?
Comment 3 Mayank Jain 2006-08-31 10:39:49 EDT
Leon, they appear as numbers.
I have lohit malayalam fonts installed.
Comment 4 A S Alam 2006-08-31 10:42:09 EDT
I want to confirm that these are 0d66 to 0d6f, not English (0030/0039).

confusion due to font only, where 0d66/0d6f contains Latin Glyph instead of
Comment 5 Mayank Jain 2006-08-31 10:42:21 EDT
Created attachment 135294 [details]
Answer to NEEDINFO

Comment 6 Mayank Jain 2006-09-01 05:17:30 EDT
Adding Leon to CC list.

Leon, who is owning this bug after dsantani's exit?
Comment 8 Rahul Bhalerao 2006-09-14 07:23:14 EDT
If keyboard is mapped to English numerals, then it does not make much difference
if the malayalam numerals are included in the font or the latin numerals are
placed in the place of malayalam numerals. Changing the priority to low.
Comment 9 Rahul Bhalerao 2006-09-14 08:20:04 EDT
*** Bug 206239 has been marked as a duplicate of this bug. ***
Comment 10 Rahul Bhalerao 2006-10-03 10:07:03 EDT

*** This bug has been marked as a duplicate of 206434 ***

Note You need to log in before you can comment on or make changes to this bug.