Bug 200942 - Iacute button with evdev driver doesn't work on hungarian keyboard
Iacute button with evdev driver doesn't work on hungarian keyboard
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xkeyboard-config (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
bzcl34nup
:
: 215322 (view as bug list)
Depends On: 237369
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-01 14:43 EDT by Zoltan Boszormenyi
Modified: 2008-05-02 17:45 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-02 17:45:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg with manual evdev configuration (1.15 KB, application/octet-stream)
2008-04-12 06:52 EDT, Zoltan Boszormenyi
no flags Details

  None (edit)
Description Zoltan Boszormenyi 2006-08-01 14:43:11 EDT
Description of problem:

iacute button doesn't work on a Hungarian keyboard.

Version-Release number of selected component (if applicable):

0.8-2

How reproducible:

Always.

Steps to Reproduce:
1. Use a keyboard configuration like below:

Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "evdev"
        Option      "Phys" "isa0060/serio0/input0"
        Option      "XkbLayout" "hu"
EndSection

2. Restart X.
3.
  
Actual results:

The "Í" (iacute) button between LShift and Y on the Hungarian keyboard
doesn't respond.

Expected results:

It should produce correct keycode.

Additional info:

/usr/share/X11/xkb/keycodes/evdev should contain
the following keycode then it works:

<LSGT> = 94;
Comment 1 Zoltan Boszormenyi 2006-09-04 09:33:02 EDT
xkeyboard-config-0.8-7.fc6 still buggy
Comment 2 Marcin Garski 2007-04-21 09:07:25 EDT
*** Bug 215322 has been marked as a duplicate of this bug. ***
Comment 3 Bug Zapper 2008-04-03 13:54:00 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 4 Zoltan Boszormenyi 2008-04-03 14:46:53 EDT
I have Fedora 8 on my machine currently.

$ rpm -q xkeyboard-config
xkeyboard-config-1.1-3.fc8

/usr/share/X11/xkb/keycodes/evdev contains these lines:

------------8<-----------8<-------------
// translation from evdev scancodes to something resembling xfree86 keycodes.

default xkb_keycodes "evdev" {
        minimum = 8;
        maximum = 255;

        # Added for pc105 compatibility
        <LSGT> = 94;
...
------------8<-----------8<-------------

The "pc105" compatibility line added is the same as suggested above.
I guess it is working now but I will also test it.
Comment 5 Zoltan Boszormenyi 2008-04-12 06:52:59 EDT
Created attachment 302204 [details]
Xorg with manual evdev configuration
Comment 6 Zoltan Boszormenyi 2008-04-12 06:53:43 EDT
I got a little time to test it, it works as expected. xorg.conf attached.
Comment 7 John Poelstra 2008-05-01 19:13:39 EDT
"it works as expected" so this bug can be closed?
Comment 8 Zoltan Boszormenyi 2008-05-02 02:34:11 EDT
yes
Comment 9 John Poelstra 2008-05-02 17:45:22 EDT
thanks for your update

Note You need to log in before you can comment on or make changes to this bug.