Bug 200998 - "Anaconda" fails to boot graphical installer
"Anaconda" fails to boot graphical installer
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Desktop
: 201639 (view as bug list)
Depends On:
Blocks: 202932
  Show dependency treegraph
Reported: 2006-08-02 01:33 EDT by A S Alam
Modified: 2013-07-02 20:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-18 05:37:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
X.org log from /tmp/ramfs/ directory (18.62 KB, text/plain)
2006-08-06 23:41 EDT, A S Alam
no flags Details

  None (edit)
Description A S Alam 2006-08-02 01:33:55 EDT
+++ This bug was initially created as a clone of Bug #200636 +++

Description of problem:
After booting from rawhide "boot.iso" as of 2007-07-28 and entering
the requested information for an "http" install, "stage2.img" gets
downloaded successfully. Hereafter, the installer correctly reports
the display type ("LG L1710B" analog) which is connected to the "VGA"
output of an "IBM ThinkPad T23". There is a short flicker on the
screen as if the "X" server was about to start, buth immediately the
screen goes black. The monitor light remains green though which means
that at least there is a signal. It is not possible to switch to a
virtual console to see what's going on but "ctrl-atl-bckspc" is still
able to trigger the reboot of the system.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot from corresponding "boot.iso" (2007-07-28).
2. Enter install details and proceed to downloading "stage2.img".
Actual results:
Screen goes black.

Expected results:
Graphical installer is launched successfully.

Additional info:
Adding additional boot parameters such as "noprobe", "skipddc"
combined with various resolutions from "640x480" etc. has
no effect.
Due to an installer regression, current "anaconda-" does
not get to the point where the "X" server is started. Hence, I cannot
make any statement about that version.

-- Additional comment from katzj@redhat.com on 2006-07-31 10:56 EST --
This should be better in trees with .73

-- Additional comment from jfrieben@hotmail.com on 2006-08-01 07:29 EST --
Right, works for me in "anaconda-".

I used .74 (earlyer also) from 1 August Build on i386/x86_64 with LG-700E
Mointer. but I m facing same problem and GUI is not working, 
TUI works fine, (after installation GUI failed to start)
It is showing Error like:

(mini-wm:440): Gtk-WARNING **:cannot open display: : 1

I try with VNC, but same issue on vnc also
Comment 1 Jeremy Katz 2006-08-02 10:22:55 EDT
This should be better with newer trees
Comment 2 Joachim Frieben 2006-08-06 15:17:33 EDT
Having closed bug 200636 a week ago, I am puzzled that the graphical
installer is broken again: Now (2006-08-05), I also obtain

  "(mini-wm: 460): Gtk-WARNING **: cannot open display :1"

I could swear it worked for me last Friday (2006-08-04). At least in my
case, the issue thus is probably related to the the "X" updates of last
Saturday (2006-08-05). :(
Comment 3 A S Alam 2006-08-06 23:41:52 EDT
Created attachment 133711 [details]
X.org log from /tmp/ramfs/ directory
Comment 4 Chris Lumens 2006-08-07 11:55:28 EDT
It was unable to open display :1 because X had troubles starting up.  See the
very end of the X.log:

Fatal server error:
No modes found on either pipe

Reassigning to the driver owner.
Comment 5 Chris Lumens 2006-08-07 17:24:33 EDT
*** Bug 201639 has been marked as a duplicate of this bug. ***
Comment 6 Joachim Frieben 2006-08-08 05:00:43 EDT
I addition to comment #2, I have to stress that the issue is by no
means restricted to the "i810" driver. Bug 200636 explicitly referred
to an "IBM ThinkPad T23" which is powered by a "SuperSavage/IXC 64"
chip and which thus uses the "savage" driver. Changing the component
to "xorg-x11-drv-i810" does not seem justified to me.
Comment 7 A S Alam 2006-08-08 05:50:55 EDT
I used two machine for testing one is Intel based (P-IV) and other has 
ATI (AMD64) Vedio Card.
Comment 8 Joachim Frieben 2006-08-08 07:07:24 EDT
This only supports my objection to the component change. Maybe Chris
somehow overlooked this circumstance?
Comment 9 Pekka Savola 2006-08-16 04:27:45 EDT
Graphical FC6 test 2 install on X30 (it has i810 chipset) failed because of 'No
modes found on either pipe'.  I'll add more messages to other bug reports..
Comment 10 Milan Kerslager 2006-08-19 05:55:30 EDT
I see Anaconda not trying to use VESA driver like in the past. Anaconda prints
out that X server started ok, but the server does not started ("no screens
found" at the very end of the log file).
Comment 11 Joachim Frieben 2006-08-19 09:24:59 EDT
Works for me at least since 2006-08-13 which corresponds to
"anaconda-" released on 2006-08-09. You should try
a net install of the current development tree.
Comment 12 Need Real Name 2007-03-29 10:38:14 EDT
Same problem with FC6 on "vanilla" desktop PC.  Graphical boot and X fail. 
/tmp/.X0-lock is not being cleared.  But, reinstalling grub bootloader will
cause graphical boot to work for first one or two times, then it reverts to text
mode (most of the time), will occasionally come up in graphical mode.  Must "rm
-f /tmp/.X0-lock" each time to make startx work.
Comment 13 Jesse Barnes 2008-01-10 16:37:25 EST
Does this still occur with the latest bits?  There have been lots of changes 
to the intel driver to detect modes better, so hopefully it works now.
Comment 14 Matěj Cepl 2008-01-11 11:12:19 EST

Could you please confirm whether it is reproducible on the supported distributions?
Comment 15 A S Alam 2008-01-18 05:36:53 EST
it was working with 14-JAN-2008 Build anaconda
Comment 16 Matěj Cepl 2008-01-18 06:38:12 EST
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.