Bug 201326 - Excessive resolution chosen by "X" server
Excessive resolution chosen by "X" server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-04 08:58 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-20 06:22:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration file "xorg.conf" produced by "anaconda" (542 bytes, text/plain)
2006-08-04 08:58 EDT, Joachim Frieben
no flags Details
"Xorg.0.log" for original "xorg.conf" (64.32 KB, text/plain)
2006-08-04 08:59 EDT, Joachim Frieben
no flags Details
"xorg.conf" produced by "anaconda" plus "UseBIOS" option (573 bytes, text/plain)
2006-08-05 11:57 EDT, Joachim Frieben
no flags Details
"Xorg.0.log" for original "xorg.conf" plus "UseBIOS" option (37.44 KB, text/plain)
2006-08-05 11:58 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2006-08-04 08:58:23 EDT
Description of problem:
Since the recent major overhaul of the "anaconda/firstboot" approach
to setting up the "X" configuration, the resulting "xorg.conf" file
essentially contains minimum information on the video settings; in
particular, no explicit video modes (e.g. "1280x1024") are included
at all. In my case of an "IBM ThinkPad T23" attached to an "LG L1710B"
flat panel monitor ("1280x1024"), the "X" server defaults to a
resolution of "1400x1050" which is obviously incorrect.

Version-Release number of selected component (if applicable):
xorg-x11-server-1.1.1-14.fc6

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora Core development. 
2. Boot into graphical mode.
  
Actual results:
The image is highly distorted and fuzzy due to the "1400x1050" mode
at 75 Hz imposed on a "1280x1024" display.

Expected results:
The "X" server should default to some sane setting.

Additional info:
After adding the correct mode of "1280x1024" to "xorg.conf", the "X"
server gets it right. After adding the frequency limits of the "L1710B",
too, the image is even crisp and clear at 60 Hz, whereas it was fuzzy
at the 75 Hz chosen by the "X" server. Concerning the latter, 75 Hz
actually correspond to the manufacturer specification, .. heaven knows
why!
Comment 1 Joachim Frieben 2006-08-04 08:58:23 EDT
Created attachment 133630 [details]
Configuration file "xorg.conf" produced by "anaconda"
Comment 2 Joachim Frieben 2006-08-04 08:59:41 EDT
Created attachment 133631 [details]
"Xorg.0.log" for original "xorg.conf"
Comment 3 Joachim Frieben 2006-08-04 09:06:58 EDT
I had reported trouble with "old style anaconda" earlier in bug 162466.
Comment 4 Adam Jackson 2006-08-04 18:40:34 EDT
What happens when you specify Option "UseBIOS" "false" in the savage's Driver
section?  (Please attach Xorg.0.log from attempting it.)
Comment 5 Joachim Frieben 2006-08-05 11:57:42 EDT
Created attachment 133689 [details]
"xorg.conf" produced by "anaconda" plus "UseBIOS" option
Comment 6 Joachim Frieben 2006-08-05 11:58:53 EDT
Created attachment 133690 [details]
"Xorg.0.log" for original "xorg.conf" plus "UseBIOS" option
Comment 7 Joachim Frieben 2006-08-05 12:05:42 EDT
For today's "boot.iso", the graphical installer fails completely.
After installing the system from scratch in text mode, there is
some "xorg.conf" file but the driver is set to "vesa". Anyway,
"firstboot" fails, and it continues to do so after setting the
driver type to "savage". Adding 'Option "UseBIOS" "false"' does
not help either as the attached "X" log file demonstrates.
Only after adding the correct video mode "1280x1024" to the "Screen"
section and adding a previously missing "Monitor" section to "xorg.conf",
the "X" server is launched successfully.
Comment 8 Joachim Frieben 2006-08-06 15:32:01 EDT
The grapical installer failure is tracked in bug 200998.
Comment 9 Joachim Frieben 2006-08-20 06:22:59 EDT
Works for the current "rawhide" tree at least since 2006-08-13.

Note You need to log in before you can comment on or make changes to this bug.