Bug 2014863 - generic-logos-httpd does not fulfill 'system-logos(httpd-logo-ng)' dependency of httpd in Fedora >= 34
Summary: generic-logos-httpd does not fulfill 'system-logos(httpd-logo-ng)' dependency...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: generic-logos
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-10-17 13:21 UTC by Matt McCutchen
Modified: 2021-11-30 02:23 UTC (History)
3 users (show)

Fixed In Version: generic-logos-18.0.0-15.fc34 generic-logos-18.0.0-15.fc35 generic-logos-18.0.0-15.fc33
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-30 01:11:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Matt McCutchen 2021-10-17 13:21:57 UTC
Description of problem:
In Fedora >= 34, httpd has gained a dependency on 'system-logos(httpd-logo-ng)' (see bug 1934739), but generic-logos-httpd does not fulfill this dependency, making the package unable to serve its intended purpose.

Version-Release number of selected component (if applicable):
generic-logos-httpd-0:18.0.0-13.fc34.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install the httpd package.  This will pull in fedora-logos-httpd.
2. dnf swap fedora-logos-httpd generic-logos-httpd

Actual results:

Error: 
 Problem: problem with installed package httpd-2.4.51-1.fc34.x86_64
  - package httpd-2.4.51-1.fc34.x86_64 requires system-logos(httpd-logo-ng), but none of the providers can be installed
  - package httpd-2.4.46-10.fc34.x86_64 requires system-logos-httpd >= 34.0.1, but none of the providers can be installed
  - conflicting requests

Expected results: Successful swap, resulting in a system with httpd and generic-logos-httpd installed but not fedora-logos-httpd.

Additional info:

Bug 2001272 looks like it is reporting the same end result (inability to use the httpd package without Fedora trademarks) but has misdiagnosed the cause.  Since I don't have permission to edit the summary of that bug, on the whole I think it's better if I file a new bug.

Comment 1 Matt McCutchen 2021-10-17 14:06:23 UTC
I submitted a pull request: https://src.fedoraproject.org/rpms/generic-logos/pull-request/1 .  I don't really know what I'm doing with that; I hope it is helpful.

Comment 2 Kevin Degeling 2021-11-22 19:39:17 UTC
Can concur. This bug makes it impossible to roll internal, corporate images of Fedora Linux, who have the trademarks removed for obvious reasons.

```
2021-11-22 20:26:22,239: Starting automated install..................................................Exception ignored in atexit callback: <function exitHandler at 0x7f41710e40d0>
2021-11-22 20:26:22,239: Traceback (most recent call last):
2021-11-22 20:26:22,239:   File "/usr/sbin/anaconda", line 75, in exitHandler
2021-11-22 20:26:22,239:     sync_run_task(task_proxy)
2021-11-22 20:26:22,239:   File "/usr/lib64/python3.10/site-packages/pyanaconda/modules/common/task/__init__.py", line 46, in sync_run_task
2021-11-22 20:26:22,239:     task_proxy.Finish()
2021-11-22 20:26:22,239:   File "/usr/lib/python3.10/site-packages/dasbus/client/handler.py", line 444, in _call_method
2021-11-22 20:26:22,239:     return self._get_method_reply(
2021-11-22 20:26:22,239:   File "/usr/lib/python3.10/site-packages/dasbus/client/handler.py", line 477, in _get_method_reply
2021-11-22 20:26:22,239:     return self._handle_method_error(error)
2021-11-22 20:26:22,239:   File "/usr/lib/python3.10/site-packages/dasbus/client/handler.py", line 497, in _handle_method_error
2021-11-22 20:26:22,240:     raise exception from None
2021-11-22 20:26:22,240: dasbus.error.DBusError: umount of /tmp failed (32)
2021-11-22 20:26:22,240: The following software marked for installation has errors.
2021-11-22 20:26:22,240: This is likely caused by an error with your installation source.
2021-11-22 20:26:22,240: 
2021-11-22 20:26:22,240: Problem: conflicting requests
2021-11-22 20:26:22,240:   - package gnome-user-share-3.34.0-6.fc35.x86_64 requires httpd, but none of the providers can be installed
2021-11-22 20:26:22,240:   - package httpd-2.4.51-2.fc35.x86_64 requires system-logos(httpd-logo-ng), but none of the providers can be installed
2021-11-22 20:26:22,240:   - package httpd-2.4.50-1.fc35.x86_64 requires system-logos(httpd-logo-ng), but none of the providers can be installed
2021-11-22 20:26:22,240:   - package fedora-logos-httpd-34.0.4-2.fc35.noarch is filtered out by exclude filtering
2021-11-22 20:26:22,240:   - package fedora-logos-httpd-35.0.0-2.fc35.noarch is filtered out by exclude filtering
2021-11-22 20:26:22,240: 
2021-11-22 20:26:22,240: ================================================================================
2021-11-22 20:26:22,240: ================================================================================
2021-11-22 20:26:22,240: Installation
2021-11-22 20:26:22,240: 
2021-11-22 20:26:22,240: 1) [x] Language settings                 2) [x] Time settings
2021-11-22 20:26:22,241:        (English (United States))                (US/Eastern timezone)
2021-11-22 20:26:22,241: 3) [x] Installation source               4) [!] Software selection
2021-11-22 20:26:22,241:        (https://mirrors.fedoraproject.o         (Error checking software
2021-11-22 20:26:22,241:        rg/mirrorlist?repo=fedora-               selection)
2021-11-22 20:26:22,241:        $releasever&arch=$basearch)
2021-11-22 20:26:22,241: 
```

Comment 3 Fedora Update System 2021-11-22 22:04:44 UTC
FEDORA-2021-d97a233249 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-d97a233249

Comment 4 Fedora Update System 2021-11-22 22:04:46 UTC
FEDORA-2021-4f6b3862de has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4f6b3862de

Comment 5 Fedora Update System 2021-11-23 00:34:10 UTC
FEDORA-2021-2471f5862b has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-2471f5862b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-2471f5862b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2021-11-23 01:06:22 UTC
FEDORA-2021-d97a233249 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-d97a233249`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-d97a233249

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-11-23 01:19:14 UTC
FEDORA-2021-4f6b3862de has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4f6b3862de`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4f6b3862de

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2021-11-30 01:11:26 UTC
FEDORA-2021-d97a233249 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2021-11-30 01:21:41 UTC
FEDORA-2021-4f6b3862de has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2021-11-30 02:23:01 UTC
FEDORA-2021-2471f5862b has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.