Bug 201600 - Unable to change Monitor Type with system-config-display-1.0.41-1
Unable to change Monitor Type with system-config-display-1.0.41-1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
: 202652 203232 204543 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-07 15:50 EDT by Will Woods
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 15:15:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log file created in FC6T2 (37.79 KB, text/plain)
2006-08-09 14:35 EDT, Bernd Bartmann
no flags Details
xorg.conf which was working fine in FC5 (3.32 KB, text/plain)
2006-08-09 14:36 EDT, Bernd Bartmann
no flags Details
broken xorg.conf generated during FC6T2 install (1.13 KB, text/plain)
2006-08-09 14:37 EDT, Bernd Bartmann
no flags Details
Xorg.0.log from problem in comment #1 (49.77 KB, text/plain)
2006-08-09 15:46 EDT, Wesley Harrell
no flags Details
patch to system-config-display/xConfigDialog.py (1.01 KB, patch)
2006-08-10 17:04 EDT, Will Woods
no flags Details | Diff

  None (edit)
Description Will Woods 2006-08-07 15:50:41 EDT
X does not autodetect my monitor settings:

(EE) R128(0): No DFP detected
(II) R128(0): <default monitor>: Using default hsync range of 31.50-37.90 kHz
(II) R128(0): <default monitor>: Using default vrefresh range of 50.00-70.00 Hz

I tried to use system-config-display to force it to use the proper Monitor Type
(LCD Panel 1680x1050), but nothing happens when I click "OK".

There is a python traceback when the button is clicked:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 321, in ok
    lower_vrefresh, upper_vrefresh = string.split(self.state.get_vsync(), "-")

I'm guessing that self.state.get_vsync() is not returning anything that can be
split, since there's no Monitor section in xorg.conf anymore.
Comment 1 Wesley Harrell 2006-08-08 13:08:47 EDT
My testbox also fails to have its monitor autodetected.  Trying to 
configure with system-config-display fails when I click the Monitor configure 
button and throws the following exception:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 330, in
configure_monitor
    self.state.monitor.getMonitorID(TRUE),
TypeError: getMonitorID() takes exactly 1 argument (2 given)
Comment 2 Adam Jackson 2006-08-08 13:17:31 EDT
Please attach the /var/log/Xorg.0.log from which you extracted those log messages.
Comment 3 Bernd Bartmann 2006-08-09 14:35:11 EDT
Same problem here. Big regression compared to FC5. Actually xorg.conf does not
even contains any Monitor section. Also no InputDevice section is generated for
my USB mouse. The system I use is an DELL Inspiron 8200 notebook with an Nvidia
graphics card and 1600x1200 display which was running fine in FC5. I'll attach
the old and new xorg.conf and the Xorg.0.log.
Comment 4 Bernd Bartmann 2006-08-09 14:35:59 EDT
Created attachment 133866 [details]
Xorg.0.log file created in FC6T2
Comment 5 Bernd Bartmann 2006-08-09 14:36:48 EDT
Created attachment 133867 [details]
xorg.conf which was working fine in FC5
Comment 6 Bernd Bartmann 2006-08-09 14:37:41 EDT
Created attachment 133868 [details]
broken xorg.conf generated during FC6T2 install
Comment 7 Wesley Harrell 2006-08-09 15:46:30 EDT
Created attachment 133879 [details]
Xorg.0.log from problem in comment #1

Here is that Xorg.0.log from the host having the problem descrivbed in comment
#1
Comment 8 Will Woods 2006-08-09 16:32:08 EDT
Re comment #3: Your xorg.conf isn't broken. xorg 7.1 just doesn't need
InputDevice/Monitor sections. It normally detects that stuff on startup. And, in
fact, it is correctly detecting your panel size: 

(--) NV(0): Panel size is 1600 x 1200

it's just missing the refresh rates, so it's using some weird default:

(II) NV(0): <default monitor>: Using default hsync range of 31.50-37.90 kHz
(II) NV(0): <default monitor>: Using default vrefresh range of 50.00-70.00 Hz

and thus you're stuck with 800x600. Same thing happens with my machine. But
that's a different problem altogether.

The bug being tracked here is that system-config-display can't be used to *fix*
this problem.
Comment 9 Alan Cox 2006-08-10 07:41:11 EDT
In my case - the X default is unsuitable for the monitor, clicking on the
monitor tab makes it spew a python traceback and until I can set the display
mode its rather hard to do much testing of FC6t2. Interestingly the modes
offered are only 800x600/640x480 although the monitor can do 1024x768/1280x1024.
X without config entries seems to pick something higher still which doesn't work.

No idea if t1 had the same bug, it never booted

Sev changed to high because it stops the sysytem being usable.
Comment 10 Will Woods 2006-08-10 17:04:40 EDT
Created attachment 133992 [details]
patch to system-config-display/xConfigDialog.py

This bug is triggered when rhpxl.xhwstate.ranges_to_string() returns a single
integer. This happens if the range is (x,x) - i.e. it will return "60" instead
of "60-60". s-c-d tries to split on '-' and fails with a ValueError.

The patch, therefore, tries to split the returned range on '-'. If a ValueError
is caught, it instead assigns the returned value to the upper and lower limit.

If that explanation is confusing.. it's probably easier to just read the patch.
Comment 11 Bill Nottingham 2006-08-16 12:22:29 EDT
*** Bug 202652 has been marked as a duplicate of this bug. ***
Comment 12 Nick Thorley 2006-08-18 03:48:57 EDT
Has the method of selecting a graphics card and monitor changed.  I am having
terrible probs with my FC6 test 2 install.  I presume I have the default - low
colour quality and strange resolution.  When i go into display to change it then
selecting cards - only gives me a list of types of card like radeon, nvidea etc
and not specific cards and clicking the monitor button does nothing.  Is there a
way around this or am i best waiting for the next release before i can use it.

Thanks
Comment 13 Nick Thorley 2006-08-20 12:30:14 EDT
Just in case everyone is still struggling - just thought i would let everyone
know after applying the latest patches the selection of monitor and graphics
card is fine.
Comment 14 Alan Cox 2006-08-21 14:01:40 EDT
Ditto here, pity that selecting actual modes isnt working at all.
Comment 15 Adam Jackson 2006-08-28 15:12:26 EDT
*** Bug 203232 has been marked as a duplicate of this bug. ***
Comment 16 Adam Jackson 2006-08-28 15:15:42 EDT
The split() bug should be sorted in s-c-d 1.0.44-1.
Comment 17 Adam Jackson 2006-08-29 16:19:28 EDT
*** Bug 204543 has been marked as a duplicate of this bug. ***
Comment 18 Jason 2006-08-29 17:17:24 EDT
I just updated to s-c-d 1.0.44-1 and there are only two monitors listed:
generic crt
generic lcd

all other monitors have disappeared.
Comment 19 Adam Jackson 2006-08-29 17:20:13 EDT
(In reply to comment #18)
> I just updated to s-c-d 1.0.44-1 and there are only two monitors listed:
> generic crt
> generic lcd
> 
> all other monitors have disappeared.

Correct.  And intentional.  If you want to see the complete list, click the
button that says "show me everything", but the idea is you'll never actually
need (or want) to.
Comment 20 Alan Cox 2006-08-31 08:06:41 EDT
Selecting modes still doesn't work as of the latest 31/08 update. No display
size lines are placed in the xorg.conf. On the brighter side one of the two
boxes this is causing problems with now defaults to an X mode that actually
works on the monitor.

Note You need to log in before you can comment on or make changes to this bug.