Bug 202081 - eclipse internal error with ICU resource bundle
eclipse internal error with ICU resource bundle
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
: 205639 207215 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-10 14:31 EDT by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.2.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 21:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Tromey 2006-08-10 14:31:19 EDT
I'm seeing an internal error with ICU not being able to find a resource.
This may mean there is a build bug of some kind, e.g. if a jar is made
incorrectly you could see this.  (It could mean something else though :-)

This is a chained exception, look for the "caused by"

!ENTRY org.eclipse.ui 4 0 2006-08-10 09:45:44.232
!MESSAGE Failed to execute runnable (java.util.MissingResourceException: Can't
find resource for bundle com.ibm.icu.impl.ICUResourceBundleImpl$ResourceTable,
key NumberPatterns)
!STACK 0
org.eclipse.swt.SWTException: Failed to execute runnable
(java.util.MissingResourceException: Can't find resource for bundle
com.ibm.icu.impl.ICUResourceBundleImpl$ResourceTable, key NumberPatterns)
   at org.eclipse.swt.SWT.error(org.eclipse.swt.gtk.linux.x86_3.2.0.v3232m.jar.so)
   at org.eclipse.swt.SWT.error(org.eclipse.swt.gtk.linux.x86_3.2.0.v3232m.jar.so)
   at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:126)
   at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3129)
   at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2831)
   at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1914)
   at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1878)
   at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:419)
   at
org.eclipse.ui.PlatformUI.createAndRunWorkbench(org.eclipse.ui.workbench_3.2.0.I20060605-1400.jar.so)
   at
org.eclipse.ui.internal.ide.IDEApplication.run(org.eclipse.ui.ide_3.2.0.I20060605-1400.jar.so)
   at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(org.eclipse.core.runtime_3.2.0.v20060603.jar.so)
   at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(org.eclipse.osgi_3.2.0.v20060601.jar.so)
   at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(org.eclipse.osgi_3.2.0.v20060601.jar.so)
   at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(org.eclipse.osgi_3.2.0.v20060601.jar.so)
   at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(org.eclipse.osgi_3.2.0.v20060601.jar.so)
   at java.lang.reflect.Method.invoke(libgcj.so.7rh)
   at org.eclipse.core.launcher.Main.invokeFramework(startup.jar.so)
   at org.eclipse.core.launcher.Main.basicRun(startup.jar.so)
   at org.eclipse.core.launcher.Main.run(startup.jar.so)
   at org.eclipse.core.launcher.Main.main(startup.jar.so)
Caused by: java.util.MissingResourceException: Can't find resource for bundle
com.ibm.icu.impl.ICUResourceBundleImpl$ResourceTable, key NumberPatterns
   at
com.ibm.icu.impl.ICUResourceBundle.handleGetObjectImpl(com.ibm.icu_3.4.4.1.jar.so)
   at
com.ibm.icu.impl.ICUResourceBundle.handleGetObjectImpl(com.ibm.icu_3.4.4.1.jar.so)
   at
com.ibm.icu.impl.ICUResourceBundle.handleGetObjectImpl(com.ibm.icu_3.4.4.1.jar.so)
   at com.ibm.icu.impl.ICUResourceBundle.handleGetObject(com.ibm.icu_3.4.4.1.jar.so)
   at java.util.ResourceBundle.getObject(libgcj.so.7rh)
   at java.util.ResourceBundle.getStringArray(libgcj.so.7rh)
   at com.ibm.icu.text.NumberFormat.getPattern(NumberFormat.java:1230)
   at com.ibm.icu.text.NumberFormat.createInstance(NumberFormat.java:1144)
   at
com.ibm.icu.text.NumberFormatServiceShim$1$RBNumberFormatFactory.handleCreate(NumberFormatServiceShim.java:109)
   at
com.ibm.icu.impl.ICULocaleService$LocaleKeyFactory.create(com.ibm.icu_3.4.4.1.jar.so)
   at com.ibm.icu.impl.ICUService.getKey(com.ibm.icu_3.4.4.1.jar.so)
   at com.ibm.icu.impl.ICUService.getKey(com.ibm.icu_3.4.4.1.jar.so)
   at com.ibm.icu.impl.ICULocaleService.get(com.ibm.icu_3.4.4.1.jar.so)
   at
com.ibm.icu.text.NumberFormatServiceShim.createInstance(NumberFormatServiceShim.java:91)
   at com.ibm.icu.text.NumberFormat.getInstance(NumberFormat.java:1139)
   at com.ibm.icu.text.NumberFormat.getIntegerInstance(NumberFormat.java:547)
   at com.ibm.icu.text.MessageFormat.makeFormat(MessageFormat.java:1449)
   at com.ibm.icu.text.MessageFormat.applyPattern(MessageFormat.java:494)
   at com.ibm.icu.text.MessageFormat.<init>(MessageFormat.java:381)
   at com.ibm.icu.text.MessageFormat.subformat(MessageFormat.java:1272)
   at com.ibm.icu.text.MessageFormat.format(MessageFormat.java:869)
   at java.text.Format.format(libgcj.so.7rh)
   at com.ibm.icu.text.MessageFormat.format(MessageFormat.java:844)
   at
org.eclipse.ui.views.markers.internal.ProblemView.formatSummaryBreakDown(ProblemView.java:252)
   at
org.eclipse.ui.views.markers.internal.ProblemView.updateTitle(ProblemView.java:240)
   at
org.eclipse.ui.views.markers.internal.MarkerView$UpdateJob.runInUIThread(MarkerView.java:228)
   at org.eclipse.ui.progress.UIJob$1.run(UIJob.java:94)
   at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
   at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
   ...17 more
Comment 1 Tom Tromey 2006-08-11 12:49:00 EDT
On irc Andrew Overholt said that this is a known problem with ICU and
that the Cacao guys have a fix.

IMO it is important to install this fix... today this bug caused an
Eclipse lockup for me, by posting an Error dialog at the wrong time;
another dialog was visible and I was unable to close either of them.
Comment 2 Ben Konrath 2006-09-28 15:25:15 EDT
*** Bug 205639 has been marked as a duplicate of this bug. ***
Comment 3 Ben Konrath 2006-09-28 15:28:02 EDT
*** Bug 207215 has been marked as a duplicate of this bug. ***
Comment 4 Ben Konrath 2006-09-28 15:45:23 EDT
A fix for this seems to have made it's way into icu4j 3.4.5 which is included in
Eclipse 3.2.1. I'm going to try to have Eclipse 3.2.1 in rawhide by tomorrow
morning.
Comment 5 Ben Konrath 2006-10-03 21:37:23 EDT
This is fixed in the latest package.

Note You need to log in before you can comment on or make changes to this bug.