Bug 202442 - Several OpenGL games fail to initialize due to a graphics hardware/driver conflict
Several OpenGL games fail to initialize due to a graphics hardware/driver con...
Status: CLOSED DUPLICATE of bug 217185
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 10:45 EDT by Peter Fernandes
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-04 20:20:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Fernandes 2006-08-14 10:45:45 EDT
Description of problem:
Several games, including ppracer and GL-117, fail to initialize with my Radeon
9250 graphics card due to what seems to be a conflict with OpenGL, and every set
of graphics drivers I've tried.  Supertux runs, but at a framerate extremely
lower than what I got before the conflict.  I am sure this is the same problem.

Version-Release number of selected component (if applicable):


How reproducible:
Every time one of the aformentioned games is run.

Steps to Reproduce:
1. Run any of the aformentioned games from Konsole.
2.
3.
  
Actual results:
Errors printed to the Terminal:

libGL warning: 3D driver claims to not support visual 0x4b
drmCommandWrite: -22
drmRadeonCmdBuffer: -22 (exiting)

Expected results:
The game in question will start normally, or at least without the
errors/warnings above.

Additional info:
I have tried this with:
FC5 as shipped

FC5 with official updates

X11R7.1 from the aiglx repository

kernel DRM module 20060809 from ATrpms
...all of which didn't solve the problem.
Comment 1 Hans de Goede 2006-08-23 01:07:19 EDT
Could you try downloading and installing (not upgrading but installing) the
latest kernel from rawhide and see if that helps?
Comment 2 Peter Fernandes 2006-09-02 19:05:07 EDT
The same errors are produced with the latest Rawhide kernel.  I at least know
that the errors are being thrown from OpenGL when it tries to initialize.
Comment 3 Dave Jones 2006-10-16 14:48:48 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 4 Peter Fernandes 2006-11-24 11:57:42 EST
The problem still exists on the latest FC6 kernel (2.6.18-1.2849.fc6).  
Googling around, I have noticed several other cases of this problem, but no 
solutions to be found.
Comment 5 Matěj Cepl 2007-04-04 18:17:39 EDT
Reporter, could you confirm please, that this bug still could be reproduced with
the latest release of Fedora (FC6)?

If yes, please, attach to this bug your X server config file
(/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug
report as individual uncompressed file attachments using the bugzilla file
attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 Peter Fernandes 2007-04-04 20:20:36 EDT

*** This bug has been marked as a duplicate of 217185 ***

Note You need to log in before you can comment on or make changes to this bug.