Bug 203831 - chkconfig breaks when encoutering broken symbolic links, symlinks
Summary: chkconfig breaks when encoutering broken symbolic links, symlinks
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: chkconfig (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 190430 209640 209983
TreeView+ depends on / blocked
 
Reported: 2006-08-23 21:47 UTC by tswan
Modified: 2014-03-17 03:01 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0424
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 18:43:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0424 normal SHIPPED_LIVE chkconfig bug fix update 2007-06-07 19:25:17 UTC

Description tswan 2006-08-23 21:47:13 UTC
Description of problem:


Version-Release number of selected component (if applicable):
RHEL 2.1,3,4

How reproducible: Always

Steps to Reproduce:
1. Create a (broken) symlink baz -> /foo/bar/baz in /etc/rc.d/init.d
2. Run chkconfig --list 
  
Actual results:
chkconfig breaks and cannot complete any further operations depending on where
the symlink falls in the visitation list

Expected results:
chkconfig should skip broken symlinks rather than becoming unusable

Additional info:
This could be critical since it inhibits further production and upgrades on a
series of hosts.

Comment 1 Bill Nottingham 2006-08-24 13:53:30 UTC
This is fixed in the current development tree, and will be fixed in RHEL 5. At
this point, this issue is not planned to be backported to current Red Hat
Enterprise Linux releases.

Comment 2 Kyle Gonzales 2006-09-20 21:21:35 UTC
There is a major customer that this affects, and the customer will not be able
to upgrade to RHEL3 or RHEL4 for several years.

This also causes problems with 3rd party packages that may not clean up its
symlinks accurately.  There are also valid use cases for this to occur.

Comment 8 Bill Nottingham 2006-10-17 17:40:16 UTC
Built as 1.3.13.5.EL3-1.

Comment 16 Red Hat Bugzilla 2007-06-11 18:43:01 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0424.html



Note You need to log in before you can comment on or make changes to this bug.