Bug 204216 - parport_pc and lp modules cause system hang
parport_pc and lp modules cause system hang
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-08-26 23:52 EDT by Mike Iglesias
Modified: 2008-05-06 12:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 12:16:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mike Iglesias 2006-08-26 23:52:32 EDT
Description of problem:
I installed Fedora Core 5 on an older Penguin 1u system.  After the install
finished and the system rebooted it hung after "Starting udev".  I thought the
problem may have been the one reported in bug 186164, but that did not turn out
to be the case.  I added a -x to the first line of
/etc/sysconfig/modules/udev-stw.modules, and the system stopped after the
modprobe for the parport_pc module.  I removed it from the list in the script
using the rescue CD and rebooted.  When the script tried to modprobe the lp
module, it hung again.  Removing that module from the list let the system boot

I tried disabling the parallel port in the BIOS, but the system still hung. 
There is no parallel port on the box.

The system was running Redhat 9 at one time with no problem.

Version-Release number of selected component (if applicable):

kernel version 2.6.15-1.2054_FC5smp and 2.6.17-1.2174_FC5smp

How reproducible:

Any time the system is booted

Steps to Reproduce:
1. Install FC5
2. boot to finish install
Actual results:

system hangs modprobing parport_pc and lp modules

Expected results:

system boots successfully

Additional info:

The system has:

Supermicro 370DER motherboard
1gb memory
2 866MHz P3 cpus
Comment 1 Mike Iglesias 2006-08-28 16:40:02 EDT
Update: I tried installing FC5 on another Penguin system which has the same
hardware as the first one.  This system was running RHEL 3 update 1 with no
problems, but FC5 hung like it did on the first system.
Comment 2 David Lawrence 2006-09-05 15:07:17 EDT
Changing to proper owner, kernel-maint.
Comment 3 Dave Jones 2006-10-16 20:57:07 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 4 Mike Iglesias 2006-10-19 18:52:58 EDT
The new kernel did not fix this issue; both the parport_pc and lp modules still
cause the system to hang.
Comment 5 Curtis Doty 2007-01-19 14:21:58 EST
Why oh why does udev-stw.modules (short-term workaround) still exist? It's been
over a year now.

curtis@twiki~/src/cvs.fedora.redhat.com/core/devel/udev$ cvs log -Nd '2006-01-11
12:11:24' udev.spec

RCS file: /cvs/dist/devel/udev/udev.spec,v
Working file: udev.spec
head: 1.195
locks: strict
access list:
keyword substitution: o
total revisions: 195;   selected revisions: 1
revision 1.137
date: 2006/01/11 12:11:24;  author: harald;  state: Exp;  lines: +25 -11
- removed group "video" from the rules
- fixed specfile
- load nvram, floppy, parport and lp modules in
  /etc/sysconfig/modules/udev-stw.modules until there
  is a better solution
- fixed more floppy module loading

Just an FYI that bit me today... I had the parallel port modules aliased off in
modprobe.conf. And with that setup, the shipped udev-stw.modules will hang the
system upon boot until the kernel panics.
Comment 6 Bug Zapper 2008-04-03 23:36:23 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 7 Bug Zapper 2008-05-06 12:16:13 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.