Bug 186164 - pcmcia-socket-startup hangs kernel
pcmcia-socket-startup hangs kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pcmciautils (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
: 185989 186386 187798 187956 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-21 17:46 EST by Matthew Daniel
Modified: 2007-11-30 17:11 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 06:11:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sysreport output (286.10 KB, application/x-bzip)
2006-04-01 17:59 EST, Michael J Knox
no flags Details
Sysreport of my PC (270.54 KB, application/x-bzip)
2006-04-02 23:52 EDT, Atalibio Schneider
no flags Details
udev hang - sysreport (356.39 KB, application/x-bzip)
2006-08-08 12:49 EDT, Ken Blair
no flags Details
Abend messages while attempting to load 12c-savage4 module (3.58 KB, text/plain)
2006-12-24 08:22 EST, Marcus O. White
no flags Details

  None (edit)
Description Matthew Daniel 2006-03-21 17:46:27 EST
Description of problem:
This bugzilla issue is being created to track the progress of the following
issue, as reported in the lists:
http://www.redhat.com/archives/fedora-devel-list/2006-March/msg00456.html

After a fresh install of FC5 (FC-5-i386-DVD.iso) on my Sony Vaio VGN-AX580G, I
am experiencing a hard hang after seeing the "Starting udev" text. I qualify
"hard hang" in that the system does not respond to any keystrokes (i.e. CTRL-C,
CTRL-\, etc) and the numlock and capslock lights no longer function.

Version-Release number of selected component (if applicable):
Stock udev from FC5 DVD

Steps to Reproduce:
1. Install FC5, accepting all defaults
2. Reboot
3. Observe hang
Comment 1 Russell Strong 2006-03-21 19:45:52 EST
I'm seeing the exact same problem on a Toshiba Tecra S2.  FC5t3 did not have 
this problem for me.
Comment 2 Matthew Daniel 2006-03-21 21:11:29 EST
I used the rescue CD to mount my new system and changed /etc/rc.d/rc.sysinit to
"sh -x /sbin/start_udev", in an effort to see what's [not] happening.

Here is the last lines on the console before freeze:
---8<----
loop=176
test -d /dev/.udev/queue
usleep 100000
--->8----
As you can imagine, there were lots of "loop=177 ..." friends above it.

I thought I'd report my findings in case that helps anyone, or if those CC'd on
this bug want to try on their system, too.
Comment 3 Russell Strong 2006-03-21 23:10:51 EST
Added acpi=off to the kernel cmdline and was able to get past the lockup.
Comment 4 Harald Hoyer 2006-03-22 03:34:31 EST
you could also boot from the rescue CD and set in /etc/udev/udev.conf
udev_log="debug"

I suspect, that a kernel module is causing the hangup, so look out for the last
"modprobe" to be executed.
Comment 5 Benjamin Thery 2006-03-22 09:18:33 EST
Same problem here on a NEC P550 laptop.
udev hangs at first boot after install.
And I confirm that added "acpi=off" option solved the udev hang.
Unfortunately the kernel crashes a bit later (general protection fault).
But it seems to be another problem.
Comment 6 Benjamin Thery 2006-03-22 11:25:07 EST
I edited /etc/udev/udev.conf and set: udev_log="debug"
The last log message I see before the hang is:

udevd-event[1104]: wait_for_sysfs: wait for
'/sys/devices/pci0000:00/0000:00:1d.2/usb4/4-0:1.0/bus' for 20 mseconds
Comment 7 Harald Hoyer 2006-03-22 11:56:42 EST
any "modprobe" message before that?
Comment 8 Matthew Daniel 2006-03-22 14:17:23 EST
(In reply to comment #7)
> any "modprobe" message before that?

I'm not trying to be naive about this, but what is the recommended way to
capture the console messages since once it locks up, the scrollback is gone?

I do not have a serial port on this machine, otherwise I'd ask about booting
over serial line (I've heard that's possible, anyway).

I tried the acpi=off as suggested, and I, too, receive a kernel panic but I
cannot confirm its impact on udev as my system never makes it that far (with
acpi=off).

I also edited the udev.conf and there were no modprobe messages on the screen at
hang-time. If there were modprobe messages at all, they were shoved off-screen
by the plethora of udevd-event messages (similar to comment #6).
Comment 9 H.J. Lu 2006-03-22 15:38:04 EST
I have the same problem on the identical hardware with FC5 as described in

http://www.redhat.com/archives/fedora-devel-list/2006-March/msg00456.html
Comment 10 Harald Hoyer 2006-03-23 03:05:18 EST
ok, next step... comment out all modprobe lines from:
/etc/udev/rules.d/*
try to boot

Comment 11 Benjamin Thery 2006-03-23 04:13:25 EST
I played a bit with udev rules this morning:

1. I commented all lines containing modprobes in *.rules files:
   --> it doesn't solve the problem. udev is still hanging.

2. I removed some udev rules file. I remembered pcmcia daemon made 
   this same laptop crash at boot with FC4, I add some problem with 
   the sound card too and I don't own a Wacom tablet: pcmcia.rules,
   wacom.rules and alsa.rules removed.
   --> problem seems to be solved! It seems PCMCIA on this laptop is
       supported.

3. I added back wacom.rules and alsa.rules to confirm the above
   statement:
   --> udev is ok, but HAL daemon crashes later in boot process

4. I removed alsa.rules again.
   --> udev still ok and HAL daemon starts without problem.

Conclusion:

PCMCIA seems to be the cause for udev hang.
There is also a problem with alsa but it may be unrelated.
Comment 12 Harald Hoyer 2006-03-23 04:56:55 EST
this is NOT an UDEV hang... this is the KERNEL which hangs ...
Comment 13 Harald Hoyer 2006-03-23 05:00:34 EST
please try to isolate the line in 60-pcmcia.rules, which crashes the kernel.
Comment 14 Harald Hoyer 2006-03-23 05:12:27 EST
*** Bug 186386 has been marked as a duplicate of this bug. ***
Comment 15 Benjamin Thery 2006-03-23 06:55:05 EST
(In reply to comment #12)
> this is NOT an UDEV hang... this is the KERNEL which hangs ...

When I say 'udev hangs', I only mean "the boot process halts after the 'Starting
 udev' message is displayed on screen and the machine seems to hang". 
No need to yell, I'm no specialist. :)
I'm just trying to help and make this kernel boot cleanly on my laptop.

As asked in comment #13, I re-installed 60-pcmcia.rules and tried to find the
line which causes of the hang:
  - comments every ACTION lines
  - loop:
      - uncomment one more ACTION line
      - reboot

ACTIONs 1 + 2 : OK
ACTIONs 1 + 2 + 3 : udev OK, but hald crashes 
                    (may be hald needs action 4 if 3 is executed)
                    (I can provide the dmesg output if needed)
ACTIONs 1 + 2 + 3 + 4 : udev OK, hald OK
ACTIONS 1 + 2 + 3 + 4 + 5 : machine hangs

Hope this helps.
Comment 16 Benjamin Thery 2006-03-23 06:59:00 EST
To avoid any confusion, action 5 is the last one in 60-pcmcia.rules. It is:

# if this is a PCMCIA socket which needs a resource database,
# pcmcia-socket-startup sets it up
ACTION=="add", SUBSYSTEM=="pcmcia_socket", \
                RUN+="/sbin/pcmcia-socket-startup"

I realized it wasn't very clear in my previous comment.
Comment 17 Harald Hoyer 2006-03-23 08:54:50 EST
ok...
Comment 18 Harald Hoyer 2006-03-23 08:58:58 EST
could you try to run as root:
# /sbin/pcmcia-socket-startup

if the laptop hangs, could you try to update pcmciautils to
ftp://people.redhat.com/harald/pcmciautils-012-1.i386.rpm

and rerun:
# /sbin/pcmcia-socket-startup
Comment 19 Andre 2006-03-23 09:09:46 EST
I've tried it. Laptop hangs.
Downloaded pcmciautils. Now it doesn't hang.
Comment 20 Benjamin Thery 2006-03-23 09:18:09 EST
As expected, running /sbin/pcmcia-socket-startup as root hangs the computer.

I installed your updated package and ran succesfully the new
/sbin/pcmcia-socket-startup: no crash.

I checked that every lines in 60-pcmcia.rules that no lines are commented.
It rebooted like a charm: no hang.

It seems you found the cause.

(BTW, I can't tell you if pcmcia actually works as I have no pcmcia card at
disposable here.)
Comment 21 Harald Hoyer 2006-03-23 09:40:03 EST
Cool! Good News! Thanks for all the help!
Comment 22 Harald Hoyer 2006-03-23 10:03:13 EST
ok, please also test:
ftp://people.redhat.com/harald/pcmciautils/012-0.FC5.1

for those using pcmciautils-012-1.i386.rpm:
# rpm -Uvh --oldpackage
Comment 23 Benjamin Thery 2006-03-23 10:14:00 EST
No problem here with pcmciautils-012-0.FC5.1.i386.rpm.
This rpm seems as good as the previous one.
Comment 24 Harald Hoyer 2006-03-24 09:45:56 EST
*** Bug 185989 has been marked as a duplicate of this bug. ***
Comment 26 Benjamin Thery 2006-03-24 10:20:07 EST
I've installed pcmciautils-012-0.FC5.2.i386.rpm from comment #25.
It works well on my laptop.
Comment 27 Jacek Piskozub 2006-03-24 12:21:24 EST
Same story (problem and workaround) with Acer Travelmate 4100.

This thing must be a total showstopper for an average user.
Comment 28 Richard Körber 2006-03-24 13:03:23 EST
After installing the RPM from comment #18, my Acer Travelmate 4600 boots up
fine, too. Thanks!
Comment 29 E Mair 2006-03-25 13:10:57 EST
udev freezes here as well, and this is not on a laptop with PCMCIA.

If I supply the "acpi=off" switch through GRUB, then the freeze won't happen,
but udev will complain about "No devices found" and there's a message saying
"ERROR: No arguments allowed with -i". There are no apparent ill effects from
these messages, as far as I can tell as a mere user. Not other than losing ACPI
functionality, that is.

I don't know if this could be relevant, but when I first tried to do an FC4 -> 5
upgrade, and later when I out of frustration wiped everything and made a fresh
install, I got strange messages seemingly pertaining to some RAID issue. That's
weird because I don't have any RAID controller. The message, right before the
mid-installation lockups, was "ERROR: pdc: wrong # of devices in RAID set"
followed by something about "pdc_<some seemingly random combination of letters>".

My affected hardware:
Asus A7M-266D mobo (AMD-760MPX) w. 2x Athlon MP, 1 GB RAM
Fedora on sda, connected to a Sym 53C896-based SCSI controller
hda (Windows) + hdb (storage) connected to on-board IDE (AMD-768)
CMI8738 on-board audio
VT6105 [Rhine-III] eth0
3c905C eth1
NEC USB2 PCI
Radeon 9600XT (mis-identified as RV350)
USB mouse, trackball, joystick, scanner, webcam
PS/2 keyboard with built-in serial touchpad
Comment 30 Ronald Warsow 2006-03-26 20:33:45 EST
first, i got no problem with udev or pcmcia and maybe it is not the right place
here, but i can confirm, that i see the line
"ERROR: No arguments allowed with -i" in fc5-devel since 2-3 month and in FC5.
but only on my amd 64 with i386 and x64_86 packages, not on an pentium 3 or my
notebook.
i search the bugzilla for a while, daily reading the mailing lists, no results,
only a discussion/bug about env in fc4-test?.

it seemed that i am quite alone or most people boot with rhgb.
so, since this line doesn't affect my work and remembering the discussion about
the "reorganisation" of bugzilla and the slip of the fc5 release day,i decided
to wait for fc5.
i still see that line. 
i search my /etc, no results.
i played with the thought to fill a bug, but on what component ???

nevertheless, FC5 is quit good !!!
thx to the developers, (maybe) the whole day hearing/reading, what is NOT
functioning. i know !

i think, the last 2 sentences have to be broadcasted or duplicated in, maybe,
the bugzilla, but on what component ...
Comment 31 valery brasseur 2006-03-27 02:32:33 EST
on my thoshiba M30x : default install hang on udev.
after apply the new pcmcia rpm from comment #18 : now it boot 
but hald coredump and now computer is unable to start X11 !!
I remove the hald start from init ... and it boot's OK (without hald ;-)
Comment 32 valery brasseur 2006-03-27 02:33:14 EST
on my thoshiba M30x : default install hang on udev.
after apply the new pcmcia rpm from comment #18 : now it boot 
but hald coredump and now computer is unable to start X11 !!
I remove the hald start from init ... and it boot's OK (without hald ;-)
Comment 33 Gianluca Sforna 2006-03-27 03:42:46 EST
Confirmed for my Acer Travlemate 8202 WLMi. 
The rpm in testing solves the problem.

Thanks a lot
Comment 34 Doug Pettit 2006-03-31 13:44:30 EST
Let me add just a twist to this problem. I installed FC5 earlier this week. Was 
running FC4 just fine. FC5 installed with no problem and I was able to run it 
for several days. Then, one morning, I got the exact same 'starting udev:' 
problem......after being successful for days that is. I re-installed FC4 and 
was not able to boot. Then, I reinstalled FC5 and witnessed the same udev 
situation. However, I left the machine for at least 3 hours, and when I 
returned, the machine had booted and was at a user prompt. I logged on fine, 
but the machine is now running slower than my old 8086 DOS machine.

Dell Inspiron 4000.....Any thoughts or ideas?

Doug
Comment 35 GP 2006-04-01 11:32:57 EST
I see the same problem on a new hp dv800t CTO laptop.
At the starting udev prompt, the system hangs (completely unresponsive...can
only power down by holding power button)

Seems to happen when udevstart is called from the /sbin/start_udev script. 
Commenting this out allows the system to boot (obviously not very well without
the /dev/ entries)

Will run strace or enable udev logging at a later time.  

Also seeing a bunch of PCI allocation errors just before the "...press "I" for
interactive startup" is displayed, along with a temperature error (0 degrees).

Maybe there is a problem with the drivers for intel 945pm chipset on this machine?

Was able to use FC4 (final) with a different problem (pcmcia service would hand
in a similar manner), but with that service disabled, was able to get everything
but the accelerated graphics to work (although the generic 'nv' driver looked
good enough for now...).
Comment 36 Michael J Knox 2006-04-01 14:26:53 EST
This is still an issue for myself. I have removed the pcmciautils package 
completely. I am not using a laptop. 

Removing the udev package allowed my machine to boot to a bash login 
(obviously with errors). I will try to get a sysreport of the machine
Comment 37 Michael J Knox 2006-04-01 17:59:27 EST
Created attachment 127189 [details]
sysreport output
Comment 38 Michael J Knox 2006-04-01 18:02:05 EST
I have installed udev from FC4 and now my system boots to the desktop, my sound
card is nowhere to be seen, but I will take what I can get for now. 

Let me know if any further info is required. 
Comment 39 Mark van Rossum 2006-04-02 08:13:24 EDT
I also find it hangs on boot.
- upgrading pcmciautils did not help
- kernel-2.6.16-1.2080_FC5 has the bug
- kernel-2.6.15-1.2054_FC5 is fine


Hardware: IBM T42p
Comment 40 Mark van Rossum 2006-04-02 19:30:56 EDT
More information on my t42p report above:

In my laptop there is a COnexant HSF modem. Downloading the stacksize=16k kernel 
from Linuxant fixed it.

It looks to me that there is a whole slew of potential causes for this bug.
Comment 41 Atalibio Schneider 2006-04-02 23:52:18 EDT
Created attachment 127223 [details]
Sysreport of my PC

I hope this can help
Comment 42 Atalibio Schneider 2006-04-02 23:54:53 EDT
I have same problem here.
I use a normal desktop (not notebook) with Asus K8V-X mainboard, Geforce Fx5200
with 256MB memory, 512 MB DDR RAM and 80 Gb PATA hard disk.

The systemm boots when i use the 

pci=off 
acpi-off

both options in kernel boot line.
Obviously, boot without AGP and PCI devices.

At this, when i clear /etc/udev/rules.d/ files, the system boots in text mode.
No graphic support available.

Look at sysreport file attached.
Comment 43 Peter Walsham (Axomic Ltd) 2006-04-03 06:02:00 EDT
I confirm upgrading pcmciautils fixes the udev problem for me:

Problem
============
Sony Vaio VGN FS115S
Fresh Fedora Core 5 install
Kernel 2.6.15-1.2054_FC5
On boot it would not get past "Starting udev"
It would boot if I set the kernel flag acpi=off 
But no access to battery status, a real pain on a laptop!

Solution
=============
rpm -Uvh pcmciautils-012-0.FC5.1.i386.rpm
ftp://people.redhat.com/harald/pcmciautils/012-0.FC5.1
Now boots fine and everything is working
Comment 44 Matthew Daniel 2006-04-03 11:40:15 EDT
Since we have multiple indications of success, do we want to mark this bug as FIXED?
Comment 45 Michael J Knox 2006-04-03 14:10:48 EDT
No, we have people that do not have a fix. Like myself for example
Comment 46 Atalibio Schneider 2006-04-03 14:20:42 EDT
Me too.

By the way, I configured my X Server successfully, but my other devices doesn´t
work.

i hope someone help us.

Regards.
Comment 47 Doug Pettit 2006-04-03 15:06:04 EDT
I agree with Michael Knox.....we need a definitive answer before this should be 
closed. Unfortunately, some of us, (like me), don't have the Linux savy to 
employ these 'workarounds'. I have tried some of the remedies posted, but still 
have problems. I am re-installing FC4 on my laptop as we speak.

Doug
Comment 48 Daniel Qarras 2006-04-03 15:20:58 EDT
FWIW, the pcmciautils-012-0.FC5.1.i386.rpm package solved my problem with Acer
Aspire 1692. The report is at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=187798 and is clearly a
duplicate of this one.
Comment 49 Harald Hoyer 2006-04-04 08:17:56 EDT
*** Bug 187798 has been marked as a duplicate of this bug. ***
Comment 50 Harald Hoyer 2006-04-04 08:53:52 EDT
For those who have still problems, _please_ open a seperate bug report along
with your possible workarounds.
Comment 51 Harald Hoyer 2006-04-05 09:25:33 EDT
*** Bug 187956 has been marked as a duplicate of this bug. ***
Comment 52 Robin Taylor 2006-04-10 08:13:16 EDT
I found this problem and after a lot of reinstall's I found that it didnt hang 
when the monitor was plugged into the onboard video port, and the video card 
removed. Im not sure if the card wasn't supported but it worked fine with FC4
Comment 53 Harald Hoyer 2006-04-10 09:01:48 EDT
Robin Taylor: which video card?
Comment 54 Eduardo N. H. 2006-04-10 22:07:19 EDT
try disabling selinux by pressing a on grub and appending selinux=disabled to
the kernel parameters. For some reason selinux came with enforced policy and the
labels on the files were wrong and boot stopped. 
Comment 55 Robin Taylor 2006-04-12 15:19:29 EDT
The card is a "Sparkle 8MB PCI SIS 6326", it wouldnt install in graphical form
either, the X server wouldnt load
Comment 56 Rickey Moore 2006-04-23 15:25:22 EDT
I've had the udev bug since I did the yum upgrade thing, so I blamed myself for
awhile. Mine complains about missing /etc/fstab.sys. I don't beleieve I recall
having that file in the 'old days', so it's a new one on me. <g> 

I'm trying the pcmcia rpm thingie, but it doesn't seem likely that it would be
the problem, for me. Ric
Comment 57 Rickey Moore 2006-05-09 13:32:48 EDT
Still no relief... how do I generate /etc/fstab.sys? The pcmcia update did not
help. What do you need of me to get some sort of resolution? I want to help... Ric
Comment 58 Harald Hoyer 2006-05-10 00:55:55 EDT
Rickey Moore, I don't know of any /etc/fstab.sys... What is this? Where does
this come from?
Comment 59 Ben Franklin 2006-05-13 19:29:11 EDT
Having similar problems with Lenovo N100. Haven't tried the RPMs yet - not quite
sure how to add rpms when the computer doesn't boot.
Comment 60 Gianluca Sforna 2006-05-15 03:32:52 EDT
(In reply to comment #59)
> Having similar problems with Lenovo N100. Haven't tried the RPMs yet - not quite
> sure how to add rpms when the computer doesn't boot.

I booted with the installer disc and activated rescue mode (linux rescue).
If your network card works in rescue mode, just do a "chroot /mnt/sysimage" at
the prompt and then a "yum update pcmciautils"

After this, the boot should work
Comment 61 Ben Franklin 2006-05-17 00:10:24 EDT
Yup - that worked. Now the Lenovo N100 no longer hangs on udev. Thanks.
Comment 62 Rickey Moore 2006-05-19 11:48:25 EDT
I tried this, yum reports that I already have this installed... so no relief. :(
Comment 63 Matthew Daniel 2006-05-20 10:19:39 EDT
This bug report has practically developed its own forum here. Can we assign this
is someone else or _close_it_ so I'm not getting CC'ed on all this tech support?

  Thanks,
  -- /v\atthew
Comment 64 Mattijs Riekerk 2006-05-24 20:50:56 EDT
(In reply to comment #54)
> try disabling selinux by pressing a on grub and appending selinux=disabled to
> the kernel parameters. For some reason selinux came with enforced policy and 
the
> labels on the files were wrong and boot stopped. 

This solved my long delay at starting udev...

More info about that bug here: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189856

Thanks
Comment 65 Rob Linklater 2006-05-27 00:16:11 EDT
   Starting udev on my system results in a shutdown, as if I switched off the 
power, immediate with no warning. It is a pentium 4, 3.2 GHz, 1 Gig ram, Soyo 
motherboard, two large hard drives, USB optical wheel mouse, LCD screen.
   I shall try the above fixes, will keep in touch as to progress.
TTYL,
Rob Linklater.
Comment 66 Gianluca Sforna 2006-05-27 09:00:04 EDT
I think the initial bug report was fixed with the pcmcia utils update, so the
bug IMHO should be closed as resolved.
Most of the other comments should belong to other (new?) bugs
Comment 67 Rickey Moore 2006-05-30 00:49:15 EDT
RE: #58
Sorry, missed that question. When I boot the screen says /etc/fstab.sys missing.
Dmesg nor /var/log/messages say nothing about this.  Strange. I do have /etc/fstab. 
Comment 68 Harald Hoyer 2006-05-30 05:50:21 EDT
The "fstab.sys" problem is not a udev problem... you may google a bit and find,
e.g.:
http://www.linuxquestions.org/questions/showthread.php?p=2191333
Rickey Moore, your problem is in the initrd.
Comment 69 Rob Linklater 2006-05-30 08:18:46 EDT
I erased 60-pcmcia.rules and alsa.rules in my rules.d subdirectory, but my 
system still shuts down when it reachea the " starting udev " line. Will 
downloading the fix file work if this test didn't?
Comment 70 Rob Linklater 2006-05-31 05:54:52 EDT
I am going to try restoring FC1 for now, I miss having my Linux up and having 
to use WinXP to do everything. I'll watch for a future fix of this bug, so that 
I can try upgrading again in the future.
TTYL.
Comment 71 Harald Hoyer 2006-05-31 05:59:24 EDT
Rob, please have a look at:
http://www.redhat.com/archives/fedora-test-list/2006-March/msg01542.html
Comment 72 Rob Linklater 2006-05-31 15:35:57 EDT
Thanks Harald...I've re-installed Fedora Core 1 and it's working well, although
all my email addresses, etc are gone. I looked at the above message, the fix it
refers to is no longer available. The oldest file is April...
Anyway, I have a desktop unit with no PCMCIA stuff on it. Thanks for trying to help.
TTYL,
Rob.
Comment 74 Rozak 2006-07-01 17:04:13 EDT
(In reply to comment #73)
> oops, should be:
> https://www.redhat.com/archives/fedora-announce-list/2006-April/msg00007.html

Still doesnt fix it for me. Running on a T-series Lifebook from Fujitsu-Siemens.
Followed the instructions for moving aside the start up script, that worked, got
a full system up, patched pcmciautils as described, rebooted and still get:

Starting udev: Wait timeout. Will continue in the background [FAILED]

Then a hang. Holding in the power button is the only way out.
Comment 75 Harald Hoyer 2006-07-03 06:59:27 EDT
Rozak, you have to play around with the ioports in /etc/pcmcia/config.opts and
exclude the port which makes problems.
Comment 76 Gabriel M. Elder 2006-07-21 15:32:25 EDT
AFAICT, this is a kernel-level issue or a bug in udev. I've got a pci wireless
NIC (00:08.0 Ethernet controller: Marvell Technology Group Ltd. 88w8335
[Libertas] 802.11b/g Wireless (rev 03) 00:08.0 0200: 11ab:1faa (rev 03)) in a
desktop workstation that <b><i>intermittently</i><b> (even better) hangs when
trying to boot kernel-2.6.17-1.2157_FC5. It gets to the point where it's
starting udev then this after about 20 seconds:
Starting udev: Wait timeout. Will continue in the backgroun[FAILED]
and appears to completely hang. acpi=off didn't help.

Same exact hardware, and i can boot just fine via kernel-2.6.15-1.2054_FC5
(haven't tried any other kernels yet). Then when i shut down and try to boot
into the most recent kernel, it happens again. When i pull the card out i can
boot fine via most recent kernel. This kinda bites. I'm hard-pressed to envision
a simple workaround at this point. I think i'll try the previous kernel release
for now and see what kind of results i get.
Comment 77 Gabriel M. Elder 2006-07-22 10:14:31 EDT
I am able to boot with kernel-2.6.16-1.2133_FC5.i686.rpm, but every kernel
revision package after this one seems to manifest the udev hang problem.
Hopefully this helps narrow down the source (pun intended:) of the problem.
Comment 78 Harald Hoyer 2006-07-24 04:52:25 EDT
Gabriel, kernel problem with the module.
Comment 79 Ken Blair 2006-08-08 12:49:24 EDT
Created attachment 133805 [details]
udev hang - sysreport
Comment 80 Ken Blair 2006-08-08 12:51:37 EDT
Hi
I get same problem - Starting udev .... [FAILED] then hang - on desktop
workstation. kernel-2.6.16-1.2133_FC5.x86_64 is fine, later kernels
(e.g kernel-2.6.17-1.2157_FC5.x86_64) give problem. Attaching sysreport.
Thanks.
Comment 81 Don Levey 2006-08-23 12:52:56 EDT
I ran into this udev/kernel hang problem.  My machine:

Acer Aspire 3102WLMi
AMD Sempron 3200+
ATI Radeon 1100 video
512 MB RAM
Internal 802.11 b/g wireless, internal card reader, etc.

I tried the solution stated here (updating pcmciautils) and that did not help.  
However, I figured that as long as I could chroot via the rescue CD, I might as 
well update everything while I was at it.  I simply did a 'yum update' to the 
stock FC5 install.  *THIS* worked; I am now able to boot.  I realise that with 
such a sledgehammer solution it isn't possible to determine which package 
update did the trick, but in my case it wasn't pcmciautils.
Comment 82 patrik 2006-08-26 12:12:47 EDT
I ran also into the udev/kernel problem

My system is: 
Fedora Core 5 x86_64 on an Acer Aspire 5102WLMi
AMD Turion 64 x2
ATI Radeon Xpress 1100 (fc recognize it as a Radeon Xpress M200)

I tried to install the recommended pcmciautils package above without success.
Then I downloaded the kernel from updates on fedora.redhat.com and install it
under rescue mode (chroot /mnt/sysimage) with the command rpm -i
kernel-2.6.x-x.x86_64.FC5.rpm (or something like that). I reboot with success.

Patrik Andersson
Comment 83 Darren Cook 2006-09-12 21:40:16 EDT
(Just another data point if someone is trying to track down this problem.)

I upgraded to FC5, from FC4, a week ago, and it has been running fine, yet in
this morning's boot it hung just after the udev message.

Yesterday's only change was re-detecting the sound card (I have two sound cards,
an onboard via82xx which has never worked (hardware problem I believe) but seems
to keep becoming the default, and a cmipci). However removing alsa.rules from
/etc/udev/rules.d made no difference (I also removed the pcmciautils rpm - this
is a desktop machine - and that also made no difference).

The fix was to add acpi=off to the grub boot settings.
I'm using 2.6.17-1.2174_FC5 kernel.
HTH - if you want more information let me know.
Comment 84 Kazutoshi Morioka 2006-09-15 05:05:05 EDT
Today I experienced udev hang after system crash.
I added "udevtimeout=3" to kernel commandline.
The udev timeouted, and system started.
Once the system was started, the system was started well without "udevtimeout=3".
Comment 85 Darren Cook 2006-09-20 08:36:40 EDT
Additional info (following from comment #83): acpi=off only worked for a couple
of boots. Then I had to use "acpi=off apm=off" to get it to boot.
Then after I installed the kernel update (2.6.17-1.2187_FC5) even that didn't work.
The solution I found was to remove 51-hotplug.rules from /etc/udev/rules.d/.
After that FC5 boots, even without the "acpi=off apm=off" parameters; I've had 6
perfect reboots in a row - a personal best since installing FC5 ;-).
Incidentally my USB scanner still gets auto-detected when I plug it in, so it
doesn't seem hotplug.rules was required? Or it is for some other functionality I
have no need for?
If you need more info let me know the commandline to run.
Comment 86 Anshul 2006-09-23 06:32:54 EDT
I have the same problem - system hangs after " Starting udev: ". My PC has the
foll. config -
AMD Athlon64 2800+ processor
Seagate SATA hard disk 
ATI Radeon X200 (onboard)
Comment 87 Joerg Schmidt 2006-10-06 05:32:28 EDT
(In reply to comment #81)
Hi 
my system would also not boot after installing FC5 (at the hald message).
Thanks for your tips in comment #60 and #81. I hadn't realised that the 
downloads of the ISO images are so outdated!
I also managed to do a 
yum update 
from the rescue CD as described. 1 Gb download!
Still didn't work.
Tried again
got an error during update that named.conf bind... conflicts with caching-
nameserver...
So I yum remove bind and then again a yum update
another 1Gb download!
If my machine wouldn't be so heavy I probably would have thrown it all the way 
to Redhat.
At last another yum update told me there is nothing else to update.
Reboot and IT WORKED!
Thanks guys, I couldn't have done it without you!

my system is:
Dell Poweredge 2900 with one dual core Xeon, 2 HDD( SAS/SATA), 2GB RAM
Comment 88 Marcus O. White 2006-12-17 08:19:10 EST
After installing FC6 on my system udev would hang and then the kernel would
abend. One work a round I found that works on a Dell DX370 and my homegrown
Intel-based system (VIA Technologies chipset) is to comment out the line:

ACTION=="add", SUBSYSTEM=="?*", MODALIAS=="?*", RUN+="/sbin/modprobe $modalias"

in /etc/udev/rules.d/50-udev.rules. This has also worked for co-workers
Intel-based workstation. Not sure of all the ramifications of soing this but,
the system boots up normally and all sub-systems appear to be working correctly.

Comment 89 Harald Hoyer 2006-12-18 04:23:57 EST
Please debug which module is causing the system hang:
Create /sbin/modprobe.sh:
#!/bin/sh
/sbin/modprobe -v -s $@ &>/dev/console

# chmod 0644 /sbin/modprobe.sh
and change the rule to:
ACTION=="add", SUBSYSTEM=="?*", MODALIAS=="?*", RUN+="/sbin/modprobe.sh $modalias"
Comment 90 Marcus O. White 2006-12-20 05:18:22 EST
It seems that the problem is with my Colorgraphic Predator LT 4 Video adapter. I
removed the card from my system and it booted up. Although, I couldn't see the
message for it scrolled off the screen. I'll see if I can it slow down...
Comment 91 Marcus O. White 2006-12-23 08:27:00 EST
The problem appears to be with the i2c_savage4.ko module. The Colorgraphic LT 4
Video adapter is a 4 port vga adapter that has worked under previous kernels.
Any ideas?
Comment 92 Marcus O. White 2006-12-24 08:22:59 EST
Created attachment 144343 [details]
Abend messages while attempting to load 12c-savage4 module
Comment 93 Harald Hoyer 2006-12-29 06:18:29 EST
add to /etc/modprobe.conf:
blacklist i2c_savage4

and open a new bug against component kernel with the backtrace.
Comment 94 Hege R. Frium 2007-03-29 05:43:35 EDT
Hi, I have tried to install FC6 on my new computer and it hangs on "starting
udev". I have packard bell computer with IntelCore 2 Duo E6300 processor and
first I tried with a Nvidia Geforce 7300SE graphics card and also with a ATI
Radeon X1300 Pro, but the same problem with both. My computer hangs and the
screen is turned off.

Note You need to log in before you can comment on or make changes to this bug.