Bug 205450 - Anaconda fails to install Fedora Core Develpment.
Summary: Anaconda fails to install Fedora Core Develpment.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
: 204805 205466 205543 (view as bug list)
Depends On:
Blocks: 208351
TreeView+ depends on / blocked
 
Reported: 2006-09-06 13:32 UTC by Thomas Woerner
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-23 16:19:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (52.37 KB, text/plain)
2006-09-06 13:32 UTC, Thomas Woerner
no flags Details
Anaconda error using kickstart method (63.07 KB, text/plain)
2006-09-19 09:37 UTC, Luya Tshimbalanga
no flags Details

Description Thomas Woerner 2006-09-06 13:32:42 UTC
Description of problem:
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 36, in comparePo
EVR
    (e2, v2, r2) = (po2.epoch, po2.ver, po2.rel)
AttributeError: 'str' object has no attribute 'epoch'

See attached log file.

Comment 1 Thomas Woerner 2006-09-06 13:32:43 UTC
Created attachment 135650 [details]
Anaconda log

Comment 2 Jeremy Katz 2006-09-06 13:43:24 UTC
Fixed in CVS

Comment 3 Jeremy Katz 2006-09-06 15:57:18 UTC
*** Bug 205466 has been marked as a duplicate of this bug. ***

Comment 4 Chris Lumens 2006-09-07 14:21:28 UTC
*** Bug 204805 has been marked as a duplicate of this bug. ***

Comment 5 Chris Lumens 2006-09-07 14:27:31 UTC
*** Bug 205543 has been marked as a duplicate of this bug. ***

Comment 6 Don Zickus 2006-09-08 19:52:16 UTC
PPC still fails.. 
Now it fails after determining all the dependencies for the packages.

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 944, in ?
    anaconda.intf.run(anaconda)
  File "/usr/lib/anaconda/text.py", line 540, in run
    anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 123, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 200, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/packages.py", line 135, in turnOnFilesystems
    anaconda.id.partitions.doMetaDeletes(anaconda.id.diskset)
  File "/usr/lib/anaconda/partitions.py", line 1351, in doMetaDeletes
    lvm.lvremove(name, vg)
  File "/usr/lib/anaconda/lvm.py", line 135, in lvremove
    raise SystemError, "lvremove failed"
SystemError: lvremove failed


Entering debugger...
> /usr/lib/anaconda/lvm.py(135)lvremove()
-> raise SystemError, "lvremove failed"
(Pdb)




Comment 7 Chris Lumens 2006-09-08 19:55:12 UTC
This is a different bug.  Please open a different bug report.

Comment 8 Don Zickus 2006-09-08 20:50:49 UTC
technically yes, but semantically no.  read the summary.  you have yet to
properly solve this problem.  i'm not going to file a new bug every time i
advance the anaconda screen and it crashes again.  



Comment 9 Peter Jones 2006-09-11 14:34:24 UTC
The original bug has been fixed, and you're now reporting an unrelated issue. 
As such, it needs to be a separate bug report.  Thank you.

Comment 10 Don Zickus 2006-09-11 15:34:39 UTC
Not really, my original bug before being dup'd here was that PPC failed to
install.  Well guess what it still fails to install on PPC.  I really don't care
how many bugs in anaconda get fixed, until I can install on PPC, I consider this
problem unresolved.  

If we want to be technical about things, you can consider the original fix for
this problem as 'does not resolve problem', because I still can't install.  Bugs
shouldn't be closed until a user acknowledges the fact that yes the fix did
solve his problem.  In my case, no it did not.  

Comment 11 Luya Tshimbalanga 2006-09-19 09:37:02 UTC
Created attachment 136617 [details]
Anaconda error using kickstart method

Comment 12 Chris Lumens 2007-02-23 16:19:57 UTC
Luya - this is a different bug than the original problem.  If you are still
seeing this in F7 test 2, please open a new bug report with the appropriate
details.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.