Bug 205619 - cupsd and eggcups take up near 100% cpu usage and must be killed before this is fixed
cupsd and eggcups take up near 100% cpu usage and must be killed before this ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
:
: 205705 206075 (view as bug list)
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-09-07 13:12 EDT by Jay Modi
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.2.3-1.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 07:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of ps -aux command (11.08 KB, text/plain)
2006-09-07 18:49 EDT, Jay Modi
no flags Details
CUPS error log file (43.48 KB, application/octet-stream)
2006-09-08 07:59 EDT, Jay Modi
no flags Details
CUPS error log file with debug2 info level (1.59 MB, application/x-bzip2)
2006-09-08 16:54 EDT, Jay Modi
no flags Details
strace.output file that was requested (344.70 KB, application/x-bzip2)
2006-09-11 08:22 EDT, Jay Modi
no flags Details
strace.output file (6.71 MB, application/octet-stream)
2006-09-11 09:11 EDT, ron banks
no flags Details
cups-config (33.92 KB, application/x-bzip2)
2006-09-13 07:48 EDT, ron banks
no flags Details
lpstat-s.output.head after cups-1.2.3-1.4 packages (407.74 KB, application/octet-stream)
2006-09-13 07:51 EDT, ron banks
no flags Details
cupsd.output (2.47 MB, application/octet-stream)
2006-09-13 11:26 EDT, ron banks
no flags Details
lpstat-t.output-1.2.3-1.5 (49.73 KB, application/octet-stream)
2006-09-13 12:19 EDT, ron banks
no flags Details
error_log-1.2.3-1.5 (1022.79 KB, application/octet-stream)
2006-09-13 12:26 EDT, ron banks
no flags Details

  None (edit)
Description Jay Modi 2006-09-07 13:12:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060808 Fedora/1.5.0.6-2.fc5 Firefox/1.5.0.6 pango-text

Description of problem:
cups will use 100% cpu usage until it is killed. Restarting the system does not work. May also be related to OpenOffice as cupsd and eggcups will use high cpu when an openoffice program is open and after it has closed.

Version-Release number of selected component (if applicable):
cups-1.2.3-1.2

How reproducible:
Always


Steps to Reproduce:
1. Start system
2. If not at 100% cpu open OpenOffice
3.

Actual Results:
CPU spikes to 100%, determined processes with command 'ps -aux'

Expected Results:


Additional info:
Comment 1 Jay Modi 2006-09-07 18:49:49 EDT
Created attachment 135819 [details]
output of ps -aux command

Look at the CPU % for cupsd and eggcups
Comment 2 Tim Waugh 2006-09-08 04:30:53 EDT
Please attach your /var/log/cups/error_log file.  Thanks.
Comment 3 Jay Modi 2006-09-08 07:59:33 EDT
Created attachment 135842 [details]
CUPS error log file
Comment 4 Tim Waugh 2006-09-08 08:26:18 EDT
Okay, I don't see anything in there that gives us any clue about what's going
on, so I'll need to enable more debugging output.

Please stop CUPS, as root:

  /sbin/service cups stop

Then clear out the error_log file:

  >/var/log/cups/error_log

Edit the /etc/cups/cupsd.conf file so that the LogLevel line reads:

LogLevel debug2

Then start CUPS again:

  /sbin/service cups start

Now, when you see the CPU usage at 100% again, please attach the
/var/log/cups/error_log file and hopefully it will shed some light on it.  Thanks.
Comment 5 Jay Modi 2006-09-08 12:56:13 EDT
I did what you said to do and the first log file I got was over 1.4gb and the
one I have right now is over 220mb. Do you want me to upload the whole thing?
Comment 6 Tim Waugh 2006-09-08 13:29:55 EDT
You could bzip2 it first, to save bandwidth:

  bzip2 -c /var/log/cups/error_log > error_log.bz2

Or, just take the first 10000 lines or so:

  head -n 10000 /var/log/cups/error_log > error_log.head

I'm sure that will be enough to diagnose the problem.  Thanks!
Comment 7 Jay Modi 2006-09-08 16:54:06 EDT
Created attachment 135879 [details]
CUPS error log file with debug2 info level
Comment 8 Tim Waugh 2006-09-11 05:27:22 EDT
*** Bug 205705 has been marked as a duplicate of this bug. ***
Comment 9 Tim Waugh 2006-09-11 07:42:45 EDT
Next thing I need is the strace.output file from running this command:

  strace -s2048 lpstat -s 2>strace.output

Leave it for a minute or so and then attach the file here.  Thanks.
Comment 10 Jay Modi 2006-09-11 08:22:37 EDT
Created attachment 135982 [details]
strace.output file that was requested

This was used when the CUPS log level was reset to info(I reset it because the
files were huge, but let me know if you want this on debug2)
Comment 11 ron banks 2006-09-11 09:11:18 EDT
Created attachment 135986 [details]
strace.output file

strace.output file
Comment 12 Tim Waugh 2006-09-11 12:20:40 EDT
Please try these test packages (1.2.3-1.3):

  http://people.redhat.com/twaugh/tmp/cups-devel/i386/

Does 1.2.3-1.3 fix the problem?
Comment 13 ron banks 2006-09-11 12:37:56 EDT
No. No difference.
Comment 14 Jay Modi 2006-09-11 16:18:12 EDT
Same here still have to kill cupsd and eggcups to get cpu usage down.
Comment 15 Tim Waugh 2006-09-12 05:00:43 EDT
Thanks for testing.

Here is the upstream bug report:
  http://www.cups.org/str.php?L1968

1.2.3-1.3 contains the 'str1968.patch' patch.
Comment 16 Tim Waugh 2006-09-13 04:55:37 EDT
This might be related to the configuration you have.  If you don't have any
passwords set for remote printers or anything, please do this (as root):

  tar jcf cups-config.tar.bz2 /etc/cups

and attach the cups-config.tar.bz2 file here.  Thanks.
Comment 17 Tim Waugh 2006-09-13 06:34:49 EDT
In addition to attaching the configuration here, please try these experimental
CUPS packages (1.2.3-1.4).  They have extra debugging turned on in two modules
and I think it might be useful to see the debugging from 'lpstat -s'.

  http://people.redhat.com/twaugh/tmp/cups-devel/i386/
Comment 18 ron banks 2006-09-13 07:48:40 EDT
Created attachment 136146 [details]
cups-config
Comment 19 ron banks 2006-09-13 07:51:01 EDT
Created attachment 136147 [details]
lpstat-s.output.head after cups-1.2.3-1.4 packages

still no glory
Comment 20 Jiri Cerny 2006-09-13 09:43:06 EDT
I am seeing the same problem: cups + eggcups eat 100% of processor and fill the
log files with an incredible rate. However, my /var/log/cups/error_log file is
full of lines like

E [13/Sep/2006:15:33:20 +0200] cupsdAcceptClient: skipping getpeercon()

which I did not find in error_logs attached above. The access_log contains many
of lines like

localhost - root [12/Sep/2006:14:34:57 +0200] "POST / HTTP/1.1" 200 124
Get-Printer-Attributes successful-ok

Maybe it can help. I have cups-1.2.3-3
Comment 21 Tim Waugh 2006-09-13 11:13:54 EDT
ron: that's great, I think we're narrowing down on the problem now.  Could you
now please try 'lpstat -s' again, but this time capture the CUPS debugging
output?  Here's how (all as root):

Stop CUPS:
  /sbin/service cups stop

Start CUPS in the foreground:
  /usr/sbin/cupsd -f &>cupsd.output

Then run 'lpstat -s' in another terminal, wait a couple of seconds, and then
control-C both lpstat and cupsd.  I'd really like to see the cupsd.output!  Thanks.
Comment 22 ron banks 2006-09-13 11:26:50 EDT
Created attachment 136162 [details]
cupsd.output

here ya go again!
Comment 23 Tim Waugh 2006-09-13 12:01:19 EDT
Thanks.

Please try these test packages (1.2.3-1.5):

  http://people.redhat.com/twaugh/tmp/cups-devel/i386/

Does 1.2.3-1.5 fix the problem?
Comment 24 ron banks 2006-09-13 12:19:43 EDT
Created attachment 136180 [details]
lpstat-t.output-1.2.3-1.5

some success? run away loop gone. can print now. here is output of 'lpstat-t'
Comment 25 Tim Waugh 2006-09-13 12:22:15 EDT
Great!  I'll get a non-debug build ready.
Comment 26 ron banks 2006-09-13 12:26:43 EDT
Created attachment 136181 [details]
error_log-1.2.3-1.5
Comment 27 Tim Waugh 2006-09-13 12:39:32 EDT
Please try these test packages (1.2.3-1.6):

  http://people.redhat.com/twaugh/tmp/cups-devel/i386/

The extra debugging information is removed, but they have my wbuffer fix.  These
should work normally.

ron, Jiri: let me know how they work for you.  Thanks!
Comment 28 Tim Waugh 2006-09-13 12:58:56 EDT
Of course, you can now change your /etc/cups/cupsd.conf 'LogLevel' line back to:

LogLevel info
Comment 29 ron banks 2006-09-13 13:30:58 EDT
As far as I'm concerned this bug is squashed. Thanks Tim.!
Comment 30 Fred New 2006-09-13 13:39:38 EDT
I've been tracking this bug from 205705, and this fix works for me, too.
Comment 31 Jay Modi 2006-09-13 16:05:41 EDT
Also works for me. Thanks!
Comment 32 Jiri Cerny 2006-09-13 16:34:38 EDT
Here it works too. Thanks. Jiri.
Comment 33 Tim Waugh 2006-10-23 08:46:37 EDT
*** Bug 206075 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.