Bug 205796 - worm man-page from bsd-games conflicts with the worm man-page from the new xscreensaver update
worm man-page from bsd-games conflicts with the worm man-page from the new xs...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 207847 (view as bug list)
Depends On: 207964
Blocks: 187892 207848
  Show dependency treegraph
 
Reported: 2006-09-08 11:58 EDT by James Wilkinson
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-19 12:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to move man pages from man6 to man6x (1.60 KB, patch)
2006-10-17 22:30 EDT, Christopher Stone
no flags Details | Diff

  None (edit)
Description James Wilkinson 2006-09-08 11:58:46 EDT
Description of problem:

Transaction Check Error:   file /usr/share/man/man6/worm.6.gz from install of
xscreensaver-extras-4.24-3.fc5 conflicts with file from package
bsd-games-2.17-10.fc5

bsd-games is from current Fedora Extras

Version-Release number of selected component (if applicable):
xscreensaver-extras-4.24-3.fc5
bsd-games-2.17-10.fc5

How reproducible:


Steps to Reproduce:
1. Install previous xscreensaver-extras and bsd-games
2. yum update
3.
  
Actual results:
See above.
Comment 1 Kevin Kofler 2006-09-15 08:27:02 EDT
Can we please get a fix for this? It breaks package upgrades. There is already 
a fix for this in extras-development CVS, it would just have to be backported.
Comment 2 Mamoru TASAKA 2006-09-24 13:00:01 EDT
*** Bug 207847 has been marked as a duplicate of this bug. ***
Comment 3 Mamoru TASAKA 2006-09-24 13:16:40 EDT
Note: my fix for FE-devel is NOT COMPLETE.

I moved all man pages in xscreensaver-{extras,gl-extras} to 6x.
This means that when both xscreensaver-extras and bsd-games are
installed, "man worm" always refers to bsd-games worm manual
and xscreensaver-extras worm manual will never be refered to.

I don't know how to deal with this problem in the most appropriate
way.
Comment 4 Christopher Stone 2006-09-24 13:26:54 EDT
Okay, well since Ray Strode doesn't seem to be getting any e-mails for this bug,
and since the fix in FE-devel is not "complete", I have decided to instead file
a bug against bsd-games to have the game "worm" be renamed.  Perhaps this is an
easier solution.  See bug #207848.
Comment 5 Ray Strode [halfline] 2006-09-25 07:49:57 EDT
Mamoru,

With your change does

man 6x worms

bring up the right man page?
Comment 6 Mamoru TASAKA 2006-09-25 09:23:22 EDT
(In reply to comment #5)
> Mamoru,
> With your change does
> man 6x worms
> bring up the right man page?

Well, what I did (for FE-devel) is that all the man files are still under
/usr/share/man/man6, with suffix .6x.gz
i.e. /usr/share/man/man6/boing.6x.gz , for example.

Because currently no package owns /usr/share/man/man6x and
I am not sure if I can create /usr/share/man/man6x directory
and have xscreensaver package own the directory.
So all files are now under /usr/share/man/man6/ and 
so man call must be "man 6 boing", for example.

If it is allowed that man has "6x" entry, then moving all xscreensaver man
files to /usr/share/man/man6x/ and restricting man call to "
man 6x <hack name>" in /usr/share/X11/app-defaults/XScreenSaver should work, 
for genuine xscreensaver hacks. 

The problem is that xplanet or rss-glx (can be used as xscreensaver hack)
are under 1 entry. However, current FC5 xscreensaver(-4.24-3.fc5) has already
restricted man entry to 6 in /usr/share/X11/app-defaults/XScreenSaver,
so this worry may be ignored for FC5.


------------------------------------------------------------------------------
So, I think that if creating /usr/share/man/man6x is allowed,
* moving all man xscreensaver man files to 6x
* restricting man entry to 6x in /usr/share/X11/app-defaults/XScreenSaver
is the best idea.
Comment 7 Mamoru TASAKA 2006-09-25 12:32:40 EDT
I want to know how man-pages maintainer thinks of this issue
(bug 207964).
Comment 8 Wart 2006-09-25 12:52:37 EDT
(In reply to comment #6)

> So, I think that if creating /usr/share/man/man6x is allowed,

I filed a bug report against the man-pages package asking for a 6x placeholder:
#207964

Until man-pages includes this directory, I think it would ok if
xscreensaver-extras created, but did not own, /usr/share/man/man6x.  Then once
man-pages is updated to own that directory, xscreensaver-extras would not need
to be changed again.
Comment 9 Mamoru TASAKA 2006-09-26 11:21:45 EDT
The reply from man-pages maintainer (Ivana Varekova) says:
-------------------------------------------------------------------
man package has man6x in section list:
MANSECT         1:1p:8:2:3:3p:4:5:6:7:9:0p:n:l:p:o:1x:2x:3x:4x:5x:6x:7x:8x
there will not be any problem with man pages in 6x section. 
man-pages package have no man page which belongs to 6x (6x should be used by
xorg packages), so there is no need to have /usr/share/man/man6x directory in
this package.
-------------------------------------------------------------------

So, for FE-devel I
* decided to have xscreensaver-{extras,gl-extras} own 
  /usr/share/man/man6x directory
* moved all man pages to /usr/share/man/man6x and make man pages
  have .6x.gz suffix
* changed the man page entry in /usr/share/X11/app-defaults/XScreenSaver
  ( in source, it is driver/XScreenSaver.ad.in) as:

*manualCommand: gnome-terminal --title '%s manual' \
                --command '/bin/sh -c "man 6x %s 2>/dev/null || man 1 %s ; read
foo"'

in xscreensaver-5.01-2, which is currently under:
http://buildsys.fedoraproject.org/plague-results/fedora-development-extras/xscreensaver/

It seems that this xscreensaver can correctly show xscreensaver worm
man page even if bsd-games is installed, too.
Comment 10 Wart 2006-10-01 19:33:31 EDT
Now that this is fixed in FE-devel, is there any chance we can push the same fix
to FC-5?
Comment 11 Christopher Stone 2006-10-14 19:23:58 EDT
What is the status on this bug?  I'm able to install both packages now on FC5,
should this be closed?
Comment 12 Kevin Kofler 2006-10-14 19:43:26 EDT
No. The bug is NOT fixed. Either you don't actually have both affected packages 
installed (The xscreensaver-extras subpackage is the problem, not the main 
xscreensaver package.) or your depsolver is broken and disables RPM's file 
conflict checks. I definitely can't upgrade the xscreensaver packages with 
Synaptic. (I just double-checked to make sure.)
Comment 13 Wart 2006-10-15 15:12:52 EDT
(In reply to comment #9)
> So, for FE-devel I
> * decided to have xscreensaver-{extras,gl-extras} own 
>   /usr/share/man/man6x directory

/usr/share/man/man6x (and other man[0-8]x directories) are now owned by the
filesystem package in FE6 (BZ #208121).  Please don't own /usr/share/man/man6x
in the xscreensaver packages.
Comment 14 Christopher Stone 2006-10-17 18:53:12 EDT
Yep, I tried to upgrade to the latest bsd-games package and it won't upgrade:
Transaction Check Error:   file /usr/share/man/man6/worm.6.gz from install of
bsd-games-2.17-12.fc5 conflicts with file from package
xscreensaver-extras-4.24-3.fc5

What can I do to help close this bug?  I looked at the xscreensavers spec file
and removing ownership of /usr/share/man/man6x did not look trivial, that is
there was no explicit %dir in the %files section.

I will look into it more this weekend as Ray Strode seems absent in this
discussion :(  Hopefully I can come up with a patch.  Im not sure if I have
permissions to apply this patch, but I will try to contact someone who does. 
I'm not sure why Ray does not maintain this package. :(
Comment 15 Wart 2006-10-17 19:01:57 EDT
(In reply to comment #14)
> What can I do to help close this bug?  I looked at the xscreensavers spec file
> and removing ownership of /usr/share/man/man6x did not look trivial, that is
> there was no explicit %dir in the %files section.

From an initial glance at the spec file, you should be able to add
%{_mandir}/man[1-9]x after line 318 (in rawhide).

> I will look into it more this weekend as Ray Strode seems absent in this
> discussion :(  Hopefully I can come up with a patch.  Im not sure if I have
> permissions to apply this patch, but I will try to contact someone who does. 
> I'm not sure why Ray does not maintain this package. :(

I would naively assume that you should be able to merge changes from the devel
branch into the FC5 spec file (which is part of core, right).  Maybe you could
do a diff on the FC5 and FC6 spec files to generate a patch and attach it to
this bug report?
Comment 16 Christopher Stone 2006-10-17 20:29:09 EDT
Okay, I spent about 30 minutes trying to figure this out.  I *think* this is all
that needs to be done:

vi xscreensaver-4.24-fix-man-pages.patch and change all occurances of "6" to "6x".

I altered the patch in this way, rebuilt in mock, and now the
xscreensavers-extras RPM places all the man pages in the 6x mandir.

So if this is all that is required, then this is an *extremely* easy fix. 
Please let me know if this is not enough.

I recently read some new process about what needs to be done before we can start
making changes ourselves if the maintainer is not responding.  I'm not sure how
long we are supposed to wait.  I guess if nothing is done by Monday I will make
an attempt to patch this myself in cvs and push a new build, but I doubt I have
permissions to do that, in which case I will e-mail the fedora-maintainers list
and see if I can get someone else to make this change for us.

Ray Strode:  I hope you are feeling okay and not in the hospital or anything.
Comment 17 Ray Strode [halfline] 2006-10-17 22:07:53 EDT
I'm not in the hospital. I'm just really busy working on other bugs right now. 
If you attach a patch to this report, I'll push the build through and issue an
update.
Comment 18 Christopher Stone 2006-10-17 22:30:08 EDT
Created attachment 138740 [details]
Patch to move man pages from man6 to man6x

Here is the patch, note that this is actually a patch to a patch.  Applying
this patch, the xscreensavers-extras rpm places man pages in the
/usr/share/man/man6x directory.  I did not test if "man 6x worm" works, nor did
I test if this actually fixes the conflict with bsd-games, but I think this is
all that needs to be done.

Glad to see you are alive and well. :)
Comment 19 Fedora Update System 2006-10-18 10:43:43 EDT
xscreensaver-4.24-4.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 20 James Wilkinson 2006-10-19 12:57:01 EDT
xscreensaver-*.x86_64 1:4.24-4.fc5 from updates-testing and bsd-games from
Extras install fine here -- thanks!

I'm marking this bug closed because it looks closed to me, and I was the
original reporter. If anyone disagrees, I'm sure they'll re-open it and tell me
why I was wrong...
Comment 21 Kevin Kofler 2006-10-19 12:58:29 EDT
The update still has to go to the non-testing updates.
Comment 22 Fedora Update System 2006-10-19 17:15:10 EDT
xscreensaver-4.24-4.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.