Bug 206244 - [si_LK] Different behaviour in kedit and gedit for "ee" with scim-sinhala - Priority - A
[si_LK] Different behaviour in kedit and gedit for "ee" with scim-sinhala - P...
Status: CLOSED DUPLICATE of bug 206261
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: Sinhala
  Show dependency treegraph
 
Reported: 2006-09-13 03:40 EDT by A S Alam
Modified: 2013-07-02 20:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 07:21:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
issue in gedit/kedit (24.42 KB, image/png)
2006-09-13 03:40 EDT, A S Alam
no flags Details
Problem is clearly visible here (135.33 KB, image/png)
2006-09-26 08:37 EDT, Mayank Jain
no flags Details

  None (edit)
Description A S Alam 2006-09-13 03:40:09 EDT
Description of problem:
when you type following keystroke with scim-sihala in kedit (correct) and 
gedit (wrong)
e+e
you can see the actual problem

Version-Release number of selected component (if applicable):
scim-sinhala-0.2.0-1.fc6

How reproducible:
Everytime during typing above combintion

Steps to Reproduce:
1. Open kedit
2. select Scim-sinhala for input
3. type e e
4 repeat step with gedit

Actual results:
gedit is not showing correct output as kedit

Expected results:
gedit's output should be like kedit

Additional info:
Screenshot attached
Comment 1 A S Alam 2006-09-13 03:40:09 EDT
Created attachment 136141 [details]
issue in gedit/kedit
Comment 2 Tyronne Wickramarathne 2006-09-19 04:51:45 EDT
(In reply to comment #1)
> Created an attachment (id=136141) [edit]
> issue in gedit/kedit
> 


this feature works fine on kedit , but the problem exists in gedit
Comment 3 Jens Petersen 2006-09-19 04:58:50 EDT
Reassigning to pango then.
Comment 4 Matthias Clasen 2006-09-19 13:17:46 EDT
I have to admit that I don't see a big difference in the screenshot.
Comment 5 Behdad Esfahbod 2006-09-19 13:21:21 EDT
I don't see the difference either.
Comment 7 Mayank Jain 2006-09-26 08:37:23 EDT
Created attachment 137131 [details]
Problem is clearly visible here

Gedit & kedit shown in the picture with "ee" being pressed using scim-sinhala

scim-1.4.4-34.fc6
scim-sinhala-0.2.0-1.fc6
pango-1.14.4-1.fc6
gedit-2.15.9-1.fc6
kdeutils-3.5.4-3.fc

However, copy & paste from kedit to gedit pastes the same ligerature in gedit
as it appears in kedit.
Comment 8 Mayank Jain 2006-09-26 08:38:29 EDT
C #7 provides the required needinfo.
Comment 9 Rahul Bhalerao 2006-09-27 06:29:08 EDT
This can not be a bug. Its just a coincidence that shape of 0D92(ee) matches with 
the shape of 0D91+0DCA (e + virama). We cannot expect combination of 0D91 with
0DCA to result 0D92. 0D91 and 0D92 are both independent vowels. Ideally pango
should not allow any vowel to be followed by virama(0DCA in case of sinhala).
Comment 10 Mayank Jain 2006-09-27 06:54:33 EDT
Copy paste from kedit to gedit works, hence this seems like a scim-sinhala bug.

Also, the bug summary is misleading... leading to Comment #9.
Changing bug summary to more meaningfull sentence.

Jens... any comments?
Comment 11 Jens Petersen 2006-09-27 07:12:04 EDT
Does it happen even without scim-bridge or with GTK_IM_MODULE=scim?
Comment 12 Rahul Bhalerao 2006-09-27 11:08:20 EDT
This is a definitely not a Pango bug. The rawcodes work correctly on pango.
Its mostly scim-sinhala bug if it has different implementation for gnome and kde.
scim-sinhala on gnome, gives 0d91 on first keystroke on 'o'. It is expected it
generates 0d92 on second 'o' keystroke and remove the earlier 0d91. 
This does not happen on Gnome application. But since pango is able to render
0d91 and 0d92 both properly, using rawcode, and pango does not involve in the
input mechanism, its not a pango bug. Latest cvs-repository build of
scim-sinhala does not have this problem. Similar problem was present with bug
#207110, and that too is working fine.
Comment 13 Jens Petersen 2006-09-28 07:01:47 EDT
This sounds very similar to bug 206261?

(In reply to comment #12)
> Latest cvs-repository build of scim-sinhala does not have this problem.

Err, which cvs repo?
Comment 14 Jens Petersen 2006-09-28 07:21:53 EDT

*** This bug has been marked as a duplicate of 206261 ***

Note You need to log in before you can comment on or make changes to this bug.