Bug 206253 - [si_LK] drops previous key event older than 1 sec - Priority - B
[si_LK] drops previous key event older than 1 sec - Priority - B
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-sinhala (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks: FC6Target Sinhala
  Show dependency treegraph
 
Reported: 2006-09-13 05:30 EDT by Tyronne Wickramarathne
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 05:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tyronne Wickramarathne 2006-09-13 05:30:39 EDT
Description of problem:
to type sinhala letter mahaapraana dayanna, ධ in SCIM-SINHALA , the key
combination are as follows

d+H

in the above key sequence. the latenccy in typing the second letter, after
pressing the first key results in producing a different output.


the unicode value of the letter, which should appear correctly is 0DB0


Version-Release number of selected component (if applicable):
scim-sinhala-0.2.0-1.fc6

How reproducible:
always

Steps to Reproduce:
1.activate scim-sinhala
2.open kedit
3.type d
4.wait for 3-5 seconds
5.type H
  
Actual results:
it displays two letters: දහ
U+0DAF U+0DC4 (given the unicode values of the two letters)

Expected results:
ධ
the key combination, d+H should produce the charector 0DB0 (unicode value of the
charector)

Additional info:
Comment 1 Jens Petersen 2006-09-19 02:32:49 EDT
Is this with scim qtimm or XIM qtimm?
Comment 2 Jens Petersen 2006-09-19 02:34:13 EDT
And is this related to bug 206244?
Comment 3 Tyronne Wickramarathne 2006-09-19 03:43:14 EDT
(In reply to comment #1)
> Is this with scim qtimm or XIM qtimm?
this is with scim-qtimm-0.9.4.5
Comment 4 Tyronne Wickramarathne 2006-09-19 04:48:00 EDT
(In reply to comment #2)
> And is this related to bug 206244?

No, this is not related to bug id 206244. 

i have used Kedit to verify this functionality for Gedit suffers with some bugs
and you can't test this issue on  Gedit properly. for the bugs exists in Gedit
will hamper the tests.

this is a commom issue for Gedit/Kedit/ooffice for this is a problem with the
input method.

Kedit is the best environment to be used for testing for that doesn't have any
other bugs ontop of it. so you can use Kedit for testing.
Comment 5 Mayank Jain 2006-09-19 05:51:34 EDT
My findings...

Gnome Desktop
1) Works with scim-1.4.4-34.fc6 scim-sinhala-0.2.0-1.fc6 pango-1.14.3-1.fc6
2) Not works with scim-1.4.4-34.fc6 scim-sinhala-0.2.0-1.fc6 pango-1.14.3-2.fc6
Remarks - typing "H" in (2) does nothing to "d"

KDE
1) Does not works in kdeutils-3.5.4-2.fc6
2) Works in kdeutils-3.5.4-3.fc6
Remarks - the delay, if acused when typing the second char, outputs two
characters, rather than modifying the first char.

A better way to reproduce this bug would be to type some junk chars
"abcd[space]abcd" after typing "d". This would clear any buffers (if present) &
would be better than to wait for a random time.

Thanks,
Mayank
Comment 6 Jens Petersen 2006-09-19 09:04:15 EDT
Thanks Mayank, reassigning to pango based on your comments.
Comment 7 Leon Ho 2006-09-19 09:40:29 EDT
It does not smell like a rendering engine problem.

Does it sounds like d and H get committed seperately if it is typed slowly? 

Keep in mind that it may not be 100% reproducible, so it looks like if different
minor version of the packages can make a difference?

Does cut and paste work? If yes, then it should not be a rendering problem.
Comment 8 Mayank Jain 2006-09-20 04:13:52 EDT
Hi Leon,

Copy paste from kedit to gedit does works.

>Does cut and paste work? If yes, then it should not be a rendering problem.
Umm... if it works in Kedit, it should have also worked (or not worked) in the
same way with gedit.


Behdad, what do you say on this?

Thanks,
Mayank
 
Comment 9 Tyronne Wickramarathne 2006-09-20 04:31:44 EDT
(In reply to comment #7)

> Does it sounds like d and H get committed seperately if it is typed slowly? 

yes, this is exactly where the problem is. if you type slowly those two letters
in scim-sinhala, the letters d and H , it displays two letters. but it must
render just one letter, unicode value of which is 0DB0.

after pressing "d", the second letter "H" changes the shape of the first letter.
but this is not happenning if you're slow in typing.
Comment 10 Leon Ho 2006-09-20 04:52:20 EDT
Re: comment #8, remember there is a difference in input toolchains as well,
namely on the immodule: scim-bridge-gtk vs scim-qtimm; and the toolkit IM API.
Comment 11 Mayank Jain 2006-09-20 05:30:54 EDT
(In reply to comment #10)
> Re: comment #8, remember there is a difference in input toolchains as well,
> namely on the immodule: scim-bridge-gtk vs scim-qtimm; and the toolkit IM API.

Aah.. yes, i completely forgot that.
I agree with llch.

Comment 12 Mayank Jain 2006-09-25 03:44:32 EDT
Latency issue also found in...
pango-1.14.4-1.fc6
evolution-2.8.0-5.fc6
scim-1.4.4-34.fc6
scim-sinhala-0.2.0-1.fc6

Test case:
Fire evolution, new mail, start scim-sinhala & type "kRoo"
After typing "k" from "kRoo", either wait for some time or type random number of
scpaces " " so as to clear any buffers/create-latency.
Then also try with "kRoo" in one go, ie. without any delay.
Comment 13 Jens Petersen 2006-09-28 05:53:56 EDT
Ok the reason for this is very simple: as I suspected scim-sinhala-trans is indeed
using a timer between key events - if more than 1s passes then the previous
event is forgotten.

Tyronne, it is trivial to increase the timeout or even remove it,
but I don't know how that we will feel for users?
Comment 14 Jens Petersen 2006-09-28 10:06:12 EDT
I added a patch to remove the timeout in scim-sinhala-0.2.0-2.fc6.
Comment 15 Xiaohong Wang 2006-09-29 05:25:58 EDT
Verified in latest FC6:
scim-sinhala-0.2.0-2.fc6 
scim-1.4.4-34.fc6

It is the expect input in kedit


Note You need to log in before you can comment on or make changes to this bug.