Bug 206925 - 2.6.17-1.2630.fc6 - INFO: possible recursive locking detected
2.6.17-1.2630.fc6 - INFO: possible recursive locking detected
Status: CLOSED DUPLICATE of bug 200025
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 05:09 EDT by Ivo Sarak
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 00:54:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2006-09-18 05:09:04 EDT
Description of problem:
"INFO: possible recursive locking detected" message in DMESG.

Version-Release number of selected component (if applicable):
FC6test3, kernel 2.6.17-1.2630.fc6.

How reproducible:
Always.

Steps to Reproduce:
1. Install the FC6test3 on Dell C610.
2. Start up the system.
  
Actual results:
=============================================
[ INFO: possible recursive locking detected ]
2.6.17-1.2630.fc6 #1
---------------------------------------------
kseriod/124 is trying to acquire lock:
 (&ps2dev->cmd_mutex#2){--..}, at: [<c06130d8>] mutex_lock+0x21/0x24

but task is already holding lock:
 (&ps2dev->cmd_mutex#2){--..}, at: [<c06130d8>] mutex_lock+0x21/0x24

other info that might help us debug this:
4 locks held by kseriod/124:
 #0:  (serio_mutex){--..}, at: [<c06130d8>] mutex_lock+0x21/0x24
 #1:  (&serio->drv_mutex){--..}, at: [<c06130d8>] mutex_lock+0x21/0x24
 #2:  (psmouse_mutex){--..}, at: [<c06130d8>] mutex_lock+0x21/0x24
 #3:  (&ps2dev->cmd_mutex#2){--..}, at: [<c06130d8>] mutex_lock+0x21/0x24

stack backtrace:
 [<c04051ee>] show_trace_log_lvl+0x58/0x171
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043b915>] __lock_acquire+0x778/0x99c
 [<c043c0aa>] lock_acquire+0x4b/0x6d
 [<c0612f69>] __mutex_lock_slowpath+0xbc/0x20a
 [<c06130d8>] mutex_lock+0x21/0x24
 [<c0596e68>] ps2_command+0x7e/0x2cd
 [<c059c365>] psmouse_sliced_command+0x1c/0x5a
 [<c059f863>] synaptics_pt_write+0x1e/0x43
 [<c0596d52>] ps2_sendbyte+0x3e/0xd6
 [<c0596ee2>] ps2_command+0xf8/0x2cd
 [<c059bf98>] psmouse_probe+0x1d/0x68
 [<c059cf0c>] psmouse_connect+0xfa/0x221
 [<c0594785>] serio_connect_driver+0x1e/0x2e
 [<c05947ab>] serio_driver_probe+0x16/0x18
 [<c055509e>] driver_probe_device+0x45/0x92
 [<c05550f3>] __device_attach+0x8/0xa
 [<c0554a33>] bus_for_each_drv+0x3a/0x65
 [<c055514e>] device_attach+0x59/0x6e
 [<c0554771>] bus_attach_device+0x16/0x2b
 [<c0553bc3>] device_add+0x1f8/0x2e0
 [<c0595207>] serio_thread+0xc6/0x283
 [<c04364a9>] kthread+0xc3/0xf2
 [<c0402005>] kernel_thread_helper+0x5/0xb
DWARF2 unwinder stuck at kernel_thread_helper+0x5/0xb
Leftover inexact backtrace:
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043b915>] __lock_acquire+0x778/0x99c
 [<c043c0aa>] lock_acquire+0x4b/0x6d
 [<c0612f69>] __mutex_lock_slowpath+0xbc/0x20a
 [<c06130d8>] mutex_lock+0x21/0x24
 [<c0596e68>] ps2_command+0x7e/0x2cd
 [<c059c365>] psmouse_sliced_command+0x1c/0x5a
 [<c059f863>] synaptics_pt_write+0x1e/0x43
 [<c0596d52>] ps2_sendbyte+0x3e/0xd6
 [<c0596ee2>] ps2_command+0xf8/0x2cd
 [<c059bf98>] psmouse_probe+0x1d/0x68
 [<c059cf0c>] psmouse_connect+0xfa/0x221
 [<c0594785>] serio_connect_driver+0x1e/0x2e
 [<c05947ab>] serio_driver_probe+0x16/0x18
 [<c055509e>] driver_probe_device+0x45/0x92
 [<c05550f3>] __device_attach+0x8/0xa
 [<c0554a33>] bus_for_each_drv+0x3a/0x65
 [<c055514e>] device_attach+0x59/0x6e
 [<c0554771>] bus_attach_device+0x16/0x2b
 [<c0553bc3>] device_add+0x1f8/0x2e0
 [<c0595207>] serio_thread+0xc6/0x283
 [<c04364a9>] kthread+0xc3/0xf2
 [<c0402005>] kernel_thread_helper+0x5/0xb


Expected results:
No error messages.

Additional info:
Comment 1 David Timms 2006-09-18 10:13:06 EDT
same back trace of of bug 205102.
Comment 2 Warren Togami 2006-09-28 00:54:41 EDT

*** This bug has been marked as a duplicate of 200025 ***

Note You need to log in before you can comment on or make changes to this bug.