Bug 207133 - network-functions-ipv6 infinite loop
network-functions-ipv6 infinite loop
Status: CLOSED DUPLICATE of bug 207137
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 12:35 EDT by Teodosiy Kirilov
Modified: 2014-03-16 23:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 13:43:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Teodosiy Kirilov 2006-09-19 12:35:23 EDT
Description of problem:
probably a misspelling 
in /etc/sysconfig/network-scripts/network-functions-ipv6 causes infinite 
repeated loading of the script

Version-Release number of selected component (if applicable):
initscripts-8.40-1
(updated with yum on 19.sep 2006)

How reproducible:
Initialize IPv6 Network

Steps to Reproduce:
Try loading /etc/sysconfig/network-scripts/network-functions-ipv6
  
Actual results:
network device initialization ends with a segmentation fault because script
loads itself 

Expected results:


Additional info:
diff -Naur network-functions-ipv6 network-functions-ipv6-repair
--- network-functions-ipv6      2006-09-11 19:15:01.000000000 +0200
+++ network-functions-ipv6-repair       2006-09-19 18:32:44.000000000 +0200
@@ -1,6 +1,5 @@
 #!/bin/sh
 #
-. ./network-functions-ipv6
 #
 # Taken from: network-functions-ipv6
 # (P) & (C) 1997-2005 by Peter Bieringer <pb@bieringer.de>
Comment 1 Bill Nottingham 2006-09-19 13:43:52 EDT

*** This bug has been marked as a duplicate of 207137 ***
Comment 2 Bill Nottingham 2006-09-19 14:24:48 EDT
*** Bug 207145 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.