Bug 207209 - LM_SENSORS doesn't work with Asus P4PE
LM_SENSORS doesn't work with Asus P4PE
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 17:59 EDT by David Tiller
Modified: 2008-02-05 08:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 08:34:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 112740 None None None Never

  None (edit)
Description David Tiller 2006-09-19 17:59:01 EDT
Description of problem:
lm_sensors 2.9.2-1 fails to find any sensors on boot. The exact same config
worked properly under 2.6.16-1.2111_FC5.


Version-Release number of selected component (if applicable):
2.6.17-1.2187_FC5

How reproducible:
Always happens when booting 2.6.17-1.2187_FC5 on an ASUS P4PE.

Steps to Reproduce:
1. configure lm_sensors under a previous kernel.
2. install/upgrade kernel 2.6.17-1.2187_FC5.
3. boot
  
Actual results:
lm_sensors fails to find any sensors

Expected results:
lm_sensors should find all the same sensors as the previous kernel 


Additional info:
See bug #112740 for more info regarding a possible quirk patch that may have
been left out of the latest build. It references this URL:
http://www.ussg.iu.edu/hypermail/linux/kernel/0309.0/0574.html

This was also reported in bug #197507.
Comment 1 David Tiller 2006-09-19 18:22:07 EDT
These patches may warrant a second look: (from
http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.17)

commit 2d1e1c754d641bb8a32f0ce909dcff32906830ef
Author: Jean Delvare <khali@linux-fr.org>
Date:   Sat Apr 1 16:46:35 2006 +0200

    [PATCH] PCI: Add PCI quirk for SMBus on the Asus A6VA notebook
    
    The Asus A6VA notebook was reported to need a PCI quirk to unhide
    the SMBus.
    
    Signed-off-by: Jean Delvare <khali@linux-fr.org>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

commit ce007ea59729d627f62bb5fa8c1a81e25653a0ad
Author: Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006@gmx.net>
Date:   Mon May 15 09:44:33 2006 -0700

    [PATCH] smbus unhiding kills thermal management
    
    Do not enable the SMBus device on Asus boards if suspend is used.  We do
    not reenable the device on resume, leading to all sorts of undesirable
    effects, the worst being a total fan failure after resume on Samsung P35
    laptop.
    
    Signed-off-by: Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006@gmx.net>
    Signed-off-by: Pavel Machek <pavel@suse.cz>
    Cc: <stable@kernel.org>
    Signed-off-by: Andrew Morton <akpm@osdl.org>
    Signed-off-by: Linus Torvalds <torvalds@osdl.org>
Comment 2 David Tiller 2006-09-20 12:54:52 EDT
Cause pinned to second patch listed above. See
http://lkml.org/lkml/2006/7/26/249 This seems to apply to P4B boards, not P4PE
boards. Can it differentiate?
Comment 3 Dave Jones 2006-10-16 17:38:33 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 4 Dave Jones 2006-11-24 17:10:24 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug after installing all the
current updates, please reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

Thank you.
Comment 5 claudepi 2007-01-05 00:04:23 EST
Hello,

I am still having this problem with my ASUS p4pe mobo.  

Everything worked fine up through kernel:

2.6.15-1.2054_FC5

Any kernel after that (up to 2.6.18-1.2257.fc5) has given me the following
errors on boot up (after "Uncompressing Linux..OK booting kernel"):

ACPI: Invalid PBLK length [5]
ACPI: Getting cpuindex for acpiid 0x1
Red Hat Nash.....


Then lm_sensors fails.  I believe this to be a fairly serious problem.  When I
login after all of these errors, my cpu temperture goes through the roof.  I
have seen get to as high as 70 C before I shut down, whereas it normally
operates around 55 C.


100% reproducible.....just login to any kernel after 2.6.15-1.2054_FC5. 
Everything noted above works fine in that kernel.

thanks for any help!
Comment 6 Jon Stanley 2008-02-05 08:34:59 EST
Closing since there was an error in previous mass-close and they remained in
NEEDINFO.

Note You need to log in before you can comment on or make changes to this bug.