Bug 207846 - (finance-YahooQuote) Review Request: perl-Finance-YahooQuote - Perl interface to get stock quotes from Yahoo! Finance
Review Request: perl-Finance-YahooQuote - Perl interface to get stock quotes ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Stone
Fedora Package Reviews List
:
Depends On: 197841
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2006-09-24 12:35 EDT by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-23 13:08:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2006-09-24 12:35:53 EDT
http://togami.com/~warren/fedora/perl-Finance-YahooQuote-0.21-1.src.rpm
http://togami.com/~warren/fedora/perl-Finance-YahooQuote.spec
Description: Perl interface to get stock quotes from Yahoo! Finance
Comment 1 Christopher Stone 2006-09-24 14:40:12 EDT
BuildRequires needs perl(HTTP::Request::Common) in order for mock to run %check.
Comment 2 Warren Togami 2006-09-24 17:24:12 EDT
Oops, we need to turn off the %check because a package build must not require
network access.  Thanks.

http://togami.com/~warren/fedora/perl-Finance-YahooQuote-0.21-2.src.rpm
http://togami.com/~warren/fedora/perl-Finance-YahooQuote.spec
Comment 3 Christopher Stone 2006-09-25 18:12:57 EDT
Warren:  I tried to build this under mock with %check enabled and a BR of
perl(HTTP::Request::Common).  This also results in a failure and warnings
mentioned in the build log of missing packages.  By using a BR of
perl(HTTP::Request), this fixes the problem.

perl(HTTP::Request) needs to be added to the BR in order for %check to function
and should be added even though it is not used for official builds.  A developer
who enables the %check section would not automatically know this otherwise.

The build log also indicates that rpm is adding a Requires of
perl(HTTP::Request::Common), however, when I tried using this for a BR, it fails
and the following warnings are shown:
Warning: prerequisite HTML::Parser 2.2 not found.
Warning: prerequisite HTTP::Request 1.23 not found.
Warning: prerequisite LWP::UserAgent 1.62 not found.

These packages do not show up as being required by rpm.  Therefore, I think a
"Requires: perl(HTTP::Request)" also needs to be added to the spec file.  Please
add this unless you can show that it is not required.


==== Review Checklist ====
- rpmlint output clean
- package named according to package naming guidelines
- filename matches spec's %{name}
- package meets packaging guidelines
- package licensed with opensource compatible license
- license in spec matches actual license
- license included in %doc
- spec written in American english
- spec file legible
- sources match upstream
844d26ef02f16216840aac5815a6a6a7  Finance-YahooQuote-0.21.tar.gz
- package successfully compiles and builds on FC5 x86_64
- package does not contain locales
- package does not contain shared libraries/static libraries/pkgconfig files or
any other files required for a devel subpackage
- package is not relocatable
- package does not contain duplicate files in %files
- permissions on files set properly
- package contains proper %clean section
- macro usage is consistent
- package contains code
- no large documentation files
- files in %doc do not affect runtime
- no need for .desktop files

=== MUST ===
- Please address concerns I have about BuildRequires and Requires issues I
mention above.
Comment 4 Christopher Stone 2006-09-25 18:57:43 EDT
I've looked into this problem a bit more and the root.log is showing that using
perl(HTTP::Request::Common) brings in the mod_perl package instead of the
perl-libwww-perl package.

Should mod_perl be Providing perl(HTTP::Request::Common)?
Comment 5 Christopher Stone 2006-09-27 18:53:26 EDT
Ok, I found the problem, see bug #208348
Comment 6 Christopher Stone 2006-12-22 12:36:03 EST
This package is currently approved for FC7+ only.

mod_perl-2.0.3-3 must be built for FC6/FC5 before branching to those releases.

See bug #197841 for more information.
Comment 7 Warren Togami 2006-12-23 13:08:02 EST
Imported and branched on FC5 and FC6.  (mod_perl while problematic was a
non-issue for this.)

Note You need to log in before you can comment on or make changes to this bug.