Bug 208104 - Removing surrounding text support from Wijesekera keymap (si_LK)
Removing surrounding text support from Wijesekera keymap (si_LK)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: m17n-db (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mayank Jain
:
Depends On:
Blocks: FC6Target Sinhala 208820
  Show dependency treegraph
 
Reported: 2006-09-26 10:15 EDT by Mayank Jain
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 01:06:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
si-wijesekera-preedit.mim - test version (5.49 KB, text/plain)
2006-10-12 02:32 EDT, Mayank Jain
no flags Details

  None (edit)
Description Mayank Jain 2006-09-26 10:15:02 EDT
Description of problem:
Removing surrounding text support from Wijesekera keymap (si_LK) as many
applications besides gtk+ break rendering with surrounding text

The new keymap can be a static keymapping & can be prepared using scim-sinhala
Comment 1 Jens Petersen 2006-09-26 10:24:29 EDT
I believe there are changes in cvs for m17n-lib and scim-m17n that
allow it to fallback to preedit instead of using surrounding-text
when it is not supported by the client frontend.
Comment 3 Mayank Jain 2006-10-03 16:37:50 EDT
Hi, apologies for delayed reply.

If we go on & try to implement all the key combinations for the wijesekera
keymap, we'll need to implement 44x11 combinations (minimum, max is 44x17) -
which does not includes the ligeratures in which user uses more (or less) number
of modifiers.

GTK+ is working as expected with wijesekera, however problems are seen in QT.
Comment 4 Mayank Jain 2006-10-12 02:32:49 EDT
Created attachment 138305 [details]
si-wijesekera-preedit.mim - test version

Tyronne, can you please try the preedit version of wijesekera keymap & update
bugzilla wiht the changes?

Thanks,
Mayank
Comment 5 Tyronne Wickramarathne 2006-10-13 07:24:03 EDT
i have tested this by entering "fld" after selecting wijesekera-preedit input
method, on KDE and Gnome. both works fine but couldn't test it on OOo for my
system has not been updated and still not due to the bandwidth issues at the Sri
Lanka RH office. (the OOo version i have is buggy too.)

Mayank: great if you can type in the "fld" key combination on OOo and make sure
that you get the same results as in Gnome and in KDE.
Comment 6 Jens Petersen 2006-10-16 04:36:28 EDT
Looks fine in OO.o too.
Comment 7 Mayank Jain 2006-10-16 06:42:31 EDT
Yup, even "fl`da" combination works fine in OO.o
Jens, should i then go ahead & replace old wijesekera with this one? Or are we
waiting for more testing?

Thanks,
Mayank
Comment 8 Mayank Jain 2006-10-16 06:44:58 EDT
Okay, "fld" and "fl`da" work as expected in kde/gnome/oo.o with the preedit
version of wijesekera keymap.
Comment 9 Jens Petersen 2006-10-16 07:38:28 EDT
(In reply to comment #7)
> Jens, should i then go ahead & replace old wijesekera with this one? Or are we
> waiting for more testing?

Yes, I think it is better to replace the current map with the new one.
I suggest dropping the -preedit suffix in the filename and inside
the file too.
Comment 10 Mayank Jain 2006-10-16 09:37:00 EDT
Jens, I did removed the preedit from the file name... 
Comment 11 Mayank Jain 2006-11-06 06:52:28 EST
Using Wijesekera with preedit mode -  Since this is fixed in current release for
devel branch, moving to modified for QE to test.
Comment 12 Jens Petersen 2006-11-06 20:04:37 EST
It is fixed in the FC6 update too, right?
Comment 14 Jens Petersen 2006-11-06 20:11:03 EST
*** Bug 200403 has been marked as a duplicate of this bug. ***
Comment 16 Danishka Navin 2007-11-21 05:26:48 EST
working in OO on RHEL 5.1

Note You need to log in before you can comment on or make changes to this bug.