Bug 208242 - b44 module doesn't work with xen kernel
b44 module doesn't work with xen kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Brian Brock
:
Depends On:
Blocks: 216472
  Show dependency treegraph
 
Reported: 2006-09-27 06:32 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 06:44:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2006-09-27 06:32:32 EDT
Description of problem:
The b44 module with kernel-2.6.18-1.2693.fc6xen doesn't work:
b44.c:v1.01 (Jun 16, 2006)
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
b44 0000:03:00.0: No usable DMA configuration, aborting.
ACPI: PCI interrupt for device 0000:03:00.0 disabled
b44: probe of 0000:03:00.0 failed with error -5

ifconfig/ifup fails on this device, even though the module is loaded:
# lsmod | grep b44
b44                    34133  0
mii                     9793  1 b44


The dmesg part with a non-xen kernel kernel-2.6.18-1.2693.fc6:
b44.c:v1.01 (Jun 16, 2006)
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 177
eth0: Broadcom 4400 10/100BaseT Ethernet 00:14:22:f8:cc:ef


# lspci -v
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
        Subsystem: Dell Unknown device 01cd
        Flags: bus master, fast devsel, latency 64, IRQ 177
        Memory at dcbfe000 (32-bit, non-prefetchable) [size=8K]
        Capabilities: [40] Power Management version 2
Comment 1 Mark C Davis 2006-11-01 09:46:17 EST
Me too: FC6 (Zod)on Lenovo AMD desktop.  Otherwise identical symptoms
Comment 2 Jindrich Novy 2006-11-03 10:08:33 EST
same here:
02:0e.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
        Subsystem: Hewlett-Packard Company NX6110/NC6120
        Flags: bus master, fast devsel, latency 64, IRQ 185
        Memory at d0008000 (32-bit, non-prefetchable) [size=8K]
        Capabilities: [40] Power Management version 2
Comment 3 Jindrich Novy 2006-11-03 10:23:25 EST
doesn't work with 2.6.18-1.2798.fc6xen as well.
Comment 4 James Martin 2006-11-20 12:07:32 EST
I'm having the same issue as well.. on a dual-core AMD here, 
2.6.18-1.2849.fc6xen doesn't work with b44.
Comment 5 Stephen Tweedie 2006-11-27 07:27:35 EST
Can you please try the kernel at

http://people.redhat.com/sct/packages/kernel/kernel-xen-2.6.18-1.2857.4.2.fc6.0.2.sct/

and see if that works any better?  Thanks.
Comment 6 Jindrich Novy 2006-11-28 01:59:09 EST
Fix confirmed, b44 module now works for me with your kernel. Thanks!
Comment 7 Felix Schwarz 2006-11-28 10:21:42 EST
Works for me, too.
Comment 8 Calvin Webster 2006-11-28 15:30:24 EST
Insalled the new kernel.

The b44 module loads and eth0 starts up now, but I can't connect to anything and
my logs are filling up with thousands of messages like this:

------------------------------------
printk: 71 messages suppressed.
4gb seg fixup, process beagled-helper (pid 5749), cs:ip 73:0811cb2a
------------------------------------

What else should I be looking at? I've included other relevant info below.

Thanks!

--Cal Webster



top
------------------------------------
top - 14:43:23 up  2:06,  4 users,  load average: 1.02, 1.01, 1.03
Tasks: 138 total,   3 running, 135 sleeping,   0 stopped,   0 zombie
Cpu(s):  1.5%us,  0.3%sy,  0.0%ni, 48.1%id,  0.0%wa,  0.3%hi, 49.8%si,  0.0%st
Mem:   1938712k total,  1865236k used,    73476k free,   250936k buffers
Swap:  2031608k total,        0k used,  2031608k free,  1310788k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
    3 root      39  19     0    0    0 R  100  0.0 122:58.13 ksoftirqd/0
------------------------------------

ifconfig:
-------------------------------------
eth0      Link encap:Ethernet  HWaddr 00:14:22:EF:61:DC  
          inet addr:192.168.3.107  Bcast:192.168.3.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2437 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:104186 (101.7 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4736 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4736 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:3433226 (3.2 MiB)  TX bytes:3433226 (3.2 MiB)

peth0     Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          UP BROADCAST NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:17 

vif0.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:2681 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:116361 (113.6 KiB)  TX bytes:0 (0.0 b)

xenbr0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:2681 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:78827 (76.9 KiB)  TX bytes:0 (0.0 b)
-------------------------------------

netstat -i
-------------------------------------
Kernel Interface table
Iface       MTU Met    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0       1500   0        0      0      0      0     2474      0      0      0 BMRU
lo        16436   0     4749      0      0      0     4749      0      0      0 LRU
peth0      1500   0        0      0      0      0        0      0      0      0 BOU
vif0.0     1500   0     2718      0      0      0        0      0      0      0 BORU
xenbr0     1500   0     2718      0      0      0        0      0      0      0 BORU
-------------------------------------


route
-------------------------------------
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.3.0     *               255.255.255.0   U     0      0        0 eth0
default         kc130ssa        0.0.0.0         UG    0      0        0 eth0
-------------------------------------

ping -c 2 kc130ssa
-------------------------------------
PING kc130ssa (192.168.3.254) 56(84) bytes of data.
From 192.168.3.107 icmp_seq=1 Destination Host Unreachable
From 192.168.3.107 icmp_seq=2 Destination Host Unreachable
-------------------------------------

dmesg | tail
-------------------------------------
printk: 104495 messages suppressed.
4gb seg fixup, process beagled-helper (pid 5749), cs:ip 73:0811cbff
printk: 109 messages suppressed.
4gb seg fixup, process beagled-helper (pid 5749), cs:ip 73:0811cb2a
printk: 69 messages suppressed.
4gb seg fixup, process beagled-helper (pid 5749), cs:ip 73:0811cb2a
printk: 63 messages suppressed.
4gb seg fixup, process beagled-helper (pid 5749), cs:ip 73:0811cbff
printk: 71 messages suppressed.
4gb seg fixup, process beagled-helper (pid 5749), cs:ip 73:0811cb2a
-------------------------------------

dmesg | egrep '^printk|^4gb' | wc -l
-------------------------------------
2580
-------------------------------------

Network Manager messages eth0:
-------------------------------------
Nov 28 12:47:59 wizard NetworkManager: <information>    eth0: Device is fully-su
pported using driver 'b44'. 
Nov 28 12:47:59 wizard NetworkManager: <information>    nm_device_init(): waitin
g for device's worker thread to start 
Nov 28 12:47:59 wizard NetworkManager: <information>    nm_device_init(): device
's worker thread started, continuing.
...
Nov 28 12:48:00 wizard NetworkManager: <information>    Activation (eth0) Stage 
5 of 5 (IP Configure Commit) complete. 
-------------------------------------
Comment 9 Stephen Tweedie 2006-11-28 17:29:51 EST
The 
  4gb seg fixup, process beagled-helper (pid 5749), cs:ip 73:0811cb2a
messages are nothing to do with networking --- they are notifications of mono
applications using segment accesses which cannot be efficiently supported under Xen.

NetworkManager is unlikely to work well with Xen's default bridging network
setup: you probably want to configure routed networking for Xen if you have
NetworkManager running at all.
Comment 10 Randy Hendry 2006-12-04 11:12:43 EST
Stephen's kernel works for me too on a Dell Inspiron 5150 (with 1GB real 
memory and the same ethernet interface).  It had the exact same symptoms as 
noted above. 
Comment 11 Calvin Webster 2006-12-11 17:26:27 EST
I'm still not getting any networking in the Xen kernel. I can't even ping the
local gateway.

I've disabled NetworkManager and left the other network settings as they were.

The IRQ assignments still don't look right to me. Here's how they differ in
"dmesg" between non-Xen (<) and Xen (>) kernel boots. At a glance, it looks like
the IRQ numbers are being truncated.

191c163
< ACPI: PCI Interrupt 0000:00:01.0[A] -> GSI 16 (level, low) -> IRQ 169
---
> ACPI: PCI Interrupt 0000:00:01.0[A] -> GSI 16 (level, low) -> IRQ 16
193c165
< ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 16 (level, low) -> IRQ 169
---
> ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 16 (level, low) -> IRQ 16
195c167
< ACPI: PCI Interrupt 0000:00:1c.1[B] -> GSI 17 (level, low) -> IRQ 177
---
> ACPI: PCI Interrupt 0000:00:1c.1[B] -> GSI 17 (level, low) -> IRQ 17
197c169
< ACPI: PCI Interrupt 0000:00:1c.3[D] -> GSI 19 (level, low) -> IRQ 185
---
> ACPI: PCI Interrupt 0000:00:1c.3[D] -> GSI 19 (level, low) -> IRQ 18


Is there some special procedure to make the virtual interfaces and bridge come
up correctly?

This was what I had to do to get QEMU bridging to work:
 
Rename a copy of ifcfg-eth0 to ifcfg-br0
Remove all the IP related entries from original ifcfg-eth0 but leave the HWADDR.
Set "dev.rtc.max-user-freq = 1024" in /etc/sysctl.conf
Load the "tun" module
Run this sequence of commands:

    ifdown eth0
    ifdown br0
    modprobe bridge
    brctl addbr br0
    brctl stp br0 off
    brctl setfd br0 1 
    ifup eth0
    brctl addif br0 eth0

Do I need to do this same thing to get Xen kernel networking running?
It sure seems like it should be simpler than that.

I'd be grateful for some pointers. Maybe this is all covered somewhere in Xen
docs. I'm certainly not getting the "out-of-the-box" experience that the on-line
docs say "most" people are supposed to get.








Comment 12 Stephen Tweedie 2006-12-12 06:22:21 EST
re comment #11:

Can you please open a separate bug for this?  From your report

The b44 module loads and eth0 starts up now, but I can't connect to anything and
my logs are filling up with thousands of messages like this:

and the fact that eth0 *has* now got an IP address, your eth0 interface is up
and running.  Any other problems are separate, and need to be reported as such,
otherwise we can't properly track them independently of the original b44 problem.
Comment 13 Karsten Hopp 2006-12-12 06:55:40 EST
SCT: I've installed your kernel and get a slightly different message when the
module loads:
b44.c:v1.01 (Jun 16, 2006)
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 17 (level, low) -> IRQ 17
eth0: Broadcom 4400 10/100BaseT Ethernet 00:xx:xx:xx:xx:xx

So this looks fine (apart from the low IRQ).

Network still doesn't work, but that's another issue. I'll open a new bug for that.
Comment 14 Calvin Webster 2006-12-12 10:49:08 EST
I've submitted a new Bug #219309
Summary: No networking: IRQ nrs appear truncated

Thank you!
Comment 15 Stephen Tweedie 2006-12-13 08:54:18 EST
Patch available, tested, and merged upstream; reassigning for merge/rebase into
rawhide.
Comment 16 Felix Schwarz 2006-12-21 07:43:55 EST
Will this patch be included into FC6 kernels? 2.6.18-1.2868 does not work for me.
Comment 17 Xiaodong Ma 2006-12-23 15:21:09 EST
My Dell inspiron640m works after install new kernel and add localhost 127.0.0.1
to /etc/hosts, everything is fine now
Comment 18 Julian Yap 2007-01-02 15:33:52 EST
Identical issues for me.

Running latest kernel 2.6.18-1.2869.fc6xen.

Relevant 'lspci -v' output:
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
	Subsystem: Dell Inspiron 6000 laptop
	Flags: bus master, fast devsel, latency 64, IRQ 193
	Memory at dfdfe000 (32-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>
Comment 19 William 2007-01-10 19:17:01 EST
re comment #13
I have a dell inspiron 6000 b44 module tried kernel 2.6.18-1.2869 xen.
With ifconfig bCM4401-b0 gets set to IRQ 19.

Networking still does not work for me same as comment#13.

What can I do?

Thanks for any help
Comment 20 Andrei Pascal 2007-01-22 06:05:07 EST
Still does not work on an Acer Aspire 5630, kernel-xen-2.6.19-1.2895.fc6,
BCM4401-B0 (rev. 02).
Comment 21 Daniel Moree 2007-02-28 14:54:36 EST
need to update the kernel package that supposedly fixed this issue. the new
kernel is 2.6.19-1.2911 and the problem is still evident, so i'd be nice to have
an updated kernel fix for xen
Comment 22 Calvin Webster 2007-03-01 09:42:07 EST
dito
Comment 23 Calvin Webster 2007-07-02 12:37:10 EDT
b44 in latest FC6 Xen kernels work fine now for me. See Bug #219277.
Comment 24 Karsten Hopp 2007-07-03 06:44:18 EDT
confirmed, latest  Xen kernel works for me as well. I'll close this report.

Note You need to log in before you can comment on or make changes to this bug.