Bug 208724 - Hangs if clicing on "Send/Receive"
Hangs if clicing on "Send/Receive"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 212499 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-30 18:23 EDT by Henrik Nordstrom
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: evolution-data-server-1.8.2-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 11:24:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
10000 repeating lines of strace output (1.06 MB, application/octet-stream)
2006-11-27 16:55 EST, Graeme Fowler
no flags Details

  None (edit)
Description Henrik Nordstrom 2006-09-30 18:23:25 EDT
Description of problem:

Hangs on SMTP is clicking on the "Send/Receive" button.

Note: There is no mail in the outbox pending to be sent.

Version-Release number of selected component (if applicable):

evolution-2.8.0-6.fc6

How reproducible:

always

Steps to Reproduce:
1. start evolution
2. click on send/receive button
3.
  
Actual results:

send/receive dialog stays forever, indicating that the smtp sending is not
finished. Abort does nothing, but closing the dialog with the close button
works. But after this any mail sent gets stuck in the outbox.

Expected results:

dialog should finish. mail should continue to be sent as usual.

Additional info:

evolution from Core 5 works fine with the same configuration and messages the
outbox (dual-boot with shared home directory).

configuration is using mailserver:587 (msa port) with TLS encryption cram-md5
authentication, but it appears the same problem is seen on plain SMTP configuration.
Comment 1 Henrik Nordstrom 2006-10-02 19:53:55 EDT
If the send/receive problem does not show up the first time, click on it rapidly
a few times and it should show up..
Comment 2 Michal Babej 2006-11-06 09:25:52 EST
exactly the same problem in my case. Might be also a server related problem in
my case - server not responding (as in 80% of cases it works fine.) However,
shouldn't there be some reasonable time-outs on sending/receiving ???
Comment 3 Henrik Nordstrom 2006-11-06 10:45:24 EST
In my case it's defenitely NOT server load. Server is actually the same machine
noe, and practically idle, even if the IMAP software is rather old.. (RH9,
running in a chroot now after a hdd failure on the old server).
Comment 4 Matthew Barnes 2006-11-06 11:17:19 EST
*** Bug 212499 has been marked as a duplicate of this bug. ***
Comment 5 Joshua M. Thompson 2006-11-14 18:17:05 EST
Having this problem too. It used to happen on occasion with earlier versions,
but since upgrading to FC6 it happens 99% of the time. Usually the hang occurs
while updating one of my IMAP accounts but sometimes it occurs during SMTP send
and the email remains in the local outbox. Only solution is to keep kill -9'ing
evolution and restarting it until it doesn't hang.
Comment 6 Graeme Fowler 2006-11-27 16:51:08 EST
I confirm this problem; if I hit "Send/Receive" then the same thing happens;
sometimes on one of my two IMAP accounts, other times on the default outbound
SMTP server.

I'm running strace on a cleanly started process at the moment; it seems the main
evo process (as opposed to any of the sub-processes like the data server etc) is
spinning on a UNIX socket, repeating the content in the following attachment.

Hitting "cancel" either on the stuck 'session' or 'cancel all' results in no
change; closing the dialogue by hitting the close window button takes me back to
evo but I can't do anything related to getting new mail or sending when I'm there.

As in Comment #5 the only thing I can do is send a SIGKILL, which then spits
several segfaults into the trace.
Comment 7 Graeme Fowler 2006-11-27 16:55:06 EST
Created attachment 142232 [details]
10000 repeating lines of strace output

PID 20402 is main evolution process
Comment 8 Graeme Fowler 2006-11-27 16:59:09 EST
Correction to Comment #6: hitting the close window button takes me back to
evolution where I can happily change folders, whereupon I get a refreshed folder
view. However, the folder view does not seem to be refreshing itself.

So the send/receive window hangs up, but is closeable.

As an addendum here, occasionally when trying to quit evolution it hangs up -
and an strace indicates the same symptom - spin,spin,socket...
Comment 9 Alexander Larsson 2007-01-10 09:59:12 EST
Bug 217568 has a fix for this, and a change e_msgport_wait behaviour in rawhide
also fixed this.
Comment 10 Matthew Barnes 2007-01-10 11:24:21 EST
Fixed in evolution-data-server-1.8.2-2.fc6.
Comment 11 Henrik Nordstrom 2007-01-14 23:27:34 EST
Still no sign of this FC6 update on the update servers, almost 5 days later..

Note You need to log in before you can comment on or make changes to this bug.