Bug 217568 - evolution send mail hangs after evolution has been running for more than an hour; then hangs when trying to exit.
Summary: evolution send mail hangs after evolution has been running for more than an h...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution   
(Show other bugs)
Version: 5.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Matthew Barnes
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 219719 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-28 18:05 UTC by John Flanagan
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: evolution-data-server-1.8.0-15.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-19 20:28:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the send/receive popup (53.07 KB, image/x-xcf)
2006-11-28 18:05 UTC, John Flanagan
no flags Details
Fix for EMsgPort race (1.23 KB, patch)
2007-01-10 14:09 UTC, Alexander Larsson
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 384183 None None None Never

Description John Flanagan 2006-11-28 18:05:55 UTC
Description of problem:
After using evolution for a while, I get to a point when I can no longer send
mail.  Clicking on "Send/Recieve" hangs waiting for the SMTP transaction to
complete, which doesn't.  I attached a screenshot of that dialog.  Trying to
quit out of evolution at this point just hangs.  killall evolution is the only
way out.

Version-Release number of selected component (if applicable):


How reproducible:
2 for 2 so far since installing RHEL5 Beta2

Steps to Reproduce:
1. start evolution
2. use for a while
3. click "send/receive" and watch the SMTP send "waiting"
  
Actual results:
no mail gets sent;

Expected results:


Additional info:

So, to get out of this, one must quit evolution. BUT, evolution hangs exiting.
killall evolution.  Upon restart, sending mail works again.

Comment 1 John Flanagan 2006-11-28 18:05:55 UTC
Created attachment 142312 [details]
screenshot of the send/receive popup

Comment 2 John Flanagan 2006-11-29 14:56:06 UTC
I'm finding myself having to "killall evolution" at least 6 times a day now. 
I'd say that's a useability issue.  Probably something that needs to get fixed
before we ship IMHO.  Setting blocker to ?


Comment 3 Rod Nayfield 2006-11-29 15:14:30 UTC
I have this issue constantly also.  Beta2.

It is worth noting that I have other issues with evolution (every quit causes a
crash and bug buddy pops up, find contacts does not work by any field, etc.)

I will open other bzs on those




Comment 4 Matthias Clasen 2006-12-15 14:52:25 UTC
*** Bug 219719 has been marked as a duplicate of this bug. ***

Comment 5 Tim Reilly 2006-12-15 16:08:21 UTC
As described in Bug 219819, I can trigger this pretty readily on some machines
by performing two send/receives in quick succession or by performing a
send/receive right after a single mail send. In other words, the problem occurs
immediately instead of after a few hours.

For what it's worth, the fedora evolution has, so far, not shown me this error.

Comment 7 Matthew Barnes 2007-01-08 17:20:43 UTC
I found a couple similar upstream bugs, but there's been no progress on either
of them.  One was from an Ubuntu user.

http://bugzilla.gnome.org/show_bug.cgi?id=382540
http://bugzilla.gnome.org/show_bug.cgi?id=384183

Comment 8 Alexander Larsson 2007-01-09 12:15:12 UTC
Its also mentioned in:
http://bugzilla.gnome.org/show_bug.cgi?id=317213

Comment 9 Alexander Larsson 2007-01-09 12:17:36 UTC
Corresponding for fc6 is bug 208724

Comment 10 Alexander Larsson 2007-01-10 14:09:18 UTC
Created attachment 145255 [details]
Fix for EMsgPort race

I figured this out. Its a race condition in the new EMsgPort implementation.
e_msgport_wait() saves the message in msgport->cache and returns it later in
e_msgport_get(). However, two threads can end up running e_msgport_wait() (if
two threads are waiting and two messages are put), which will result in cache
being overwritten with the last message.

This patch fixes it by making cache a list.

Comment 11 Bastien Nocera 2007-01-10 14:18:05 UTC
I see the same problem on FC6. Would be happy to test this given packages.

Comment 12 Alexander Larsson 2007-01-10 14:34:36 UTC
Built fix in evolution-data-server-1.8.0-15.el5

Comment 13 Tim Reilly 2007-01-18 22:48:02 UTC
This bug has gone away for me with the new package, but since it's such a deep
bug, could you retest this bug for me John? Or someone else who was experiencing
it regularly.

Comment 14 Matthew Barnes 2007-01-19 00:26:07 UTC
FWIW, I've had numerous reports from Fedora Core 6 users that this patch has
solved the same hang-on-exit and hang-on-send/receive issues for them.

Comment 15 Michal Babej 2007-01-19 14:12:06 UTC
I have used Evo in latest nightly builds of RHEL5 client, and this bug also
seems to be gone.

Comment 16 John Flanagan 2007-01-19 20:18:00 UTC
I upgraded to the latest [2.8.0-33.el5] and all seems happy!  Thanks!

John


Note You need to log in before you can comment on or make changes to this bug.